Highlighted

Nvidia drivers do not work well with premiere pro 2020 (higher than v13.2) but v13.1 does

New Here ,
Sep 30, 2020

Copy link to clipboard

Copied

I recently bought GTX 1060 Ti and installed latest Nvidia driver (v456.55).

With the Nvidia driver and Mercury Playback Engine GPU Acceleration enabled, Premiere Pro 2020, higher than v13.2 make the project monitor freeze when resizing the mask area or applying Lumetri Color effects. But when I downgrade Premiere Pro 2020 lower than v13.1 does not have the freezes anymore.
I suppose the freezes happen only when premiere pro uses GPU.

I tried multiple older Nvidia drivers but no luck.

 

Does anyone have the same issue or know any workarounds for this issue?

 

Here are my components below.

OS

Windows 10 (ver 2004)

Motherboard

ASUS ROG MAXIMUS XI HERO (WI-FI AC)

GPU SAPPHIRE NITRO+ RADEON RX 580 8G
CPU Intel CPU Core i7-8700K
SSD Samsung SSD 500GB 970 EVO M.2
Memory Crucial 8GB BLS16G4D240FSB x2

 

Thanks in advance.

 

[Moderator note: double posted, answers will be in the other identical thread. This thread is locked.]

TOPICS
Effects and Titles, Error or problem, Freeze or hang, Hardware or GPU

Views

56

Likes

Translate

Translate

Report

Report
This conversation has been locked.

Nvidia drivers do not work well with premiere pro 2020 (higher than v13.2) but v13.1 does

New Here ,
Sep 30, 2020

Copy link to clipboard

Copied

I recently bought GTX 1060 Ti and installed latest Nvidia driver (v456.55).

With the Nvidia driver and Mercury Playback Engine GPU Acceleration enabled, Premiere Pro 2020, higher than v13.2 make the project monitor freeze when resizing the mask area or applying Lumetri Color effects. But when I downgrade Premiere Pro 2020 lower than v13.1 does not have the freezes anymore.
I suppose the freezes happen only when premiere pro uses GPU.

I tried multiple older Nvidia drivers but no luck.

 

Does anyone have the same issue or know any workarounds for this issue?

 

Here are my components below.

OS

Windows 10 (ver 2004)

Motherboard

ASUS ROG MAXIMUS XI HERO (WI-FI AC)

GPU SAPPHIRE NITRO+ RADEON RX 580 8G
CPU Intel CPU Core i7-8700K
SSD Samsung SSD 500GB 970 EVO M.2
Memory Crucial 8GB BLS16G4D240FSB x2

 

Thanks in advance.

 

[Moderator note: double posted, answers will be in the other identical thread. This thread is locked.]

TOPICS
Effects and Titles, Error or problem, Freeze or hang, Hardware or GPU

Views

57

Likes

Translate

Translate

Report

Report
Sep 30, 2020 0
Most Valuable Participant ,
Sep 30, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Sep 30, 2020 0
New Here ,
Sep 30, 2020

Copy link to clipboard

Copied

@John T Smith Thanks for the quick reply!

I checked them out and as long as I properly understand, none of my components including CPU and GPU and its drivers are obsolete and I'm sure that Adobe supports them all but correct me if I'm wrong.

Sorry but I realized I put wrong components in my post.

So here are the correct components again.

 

OS

Windows 10 (ver 2004)

Motherboard

ASUS PRIME Z370-A

GPUGeForce GTX 1660 Ti AERO ITX 6G OC - MSI
CPUIntel CPU Core i7-8700K
SSDSamsung SSD 500GB and 250GB 970 EVO M.2
MemoryCrucial 8GB BLS16G4D240FSB x2

 

What else can I do to resolve or mitigate the issue?

Likes

Translate

Translate

Report

Report
Sep 30, 2020 0