Opacity of layers changes when rendered out video to h.264

New Here ,
Feb 19, 2020 Feb 19, 2020

Copy link to clipboard

Copied

OK. So I'm a 20+ year Premiere Veteran  working on pro projects in the Tradeshow industry...so not a Noob. In the motion graphics that I produce I often have a bottom layer that is a white color matte. I have animated background or artwork on the layer above it. When I bring in some text overlays above this, I usually keyframe the opacity of the animated background down to 20% or lower. This allows the animation to get "pushed back into a whitebackground" and allow the text layers to pop on a primarily white background with the animation just visible but not in the way.

 

Suddenly today when I render out a project that looks and acts perfectly normal in the project window, the final rendering seems to just "omit" the object with the opacity set to 20%. It's literally gone. I have tried this with GPU acceleration enabled and disabled in Premiere project settings and in the Media encoder output settings. Same results with Premiere encoding or if I push it to Adobe Media encoder. Ironically the preview window in media encoder displays it fine as its encoding but when exported the final video just shows white.

 

I tried this with Premiere 2019, 2020 and 2018 with the same results. I loaded this same project on my laptop and the issue does not exist. It renders fine. What can be causing this and how do I go about troubleshooting? My system is:

 

workstation (misbehaving)

Windows 10 Professional 1909 and all updates.

Intel Core i9 7920x

Asus Strix motherboard

64GB Ram

Nvidia GTX1080ti

Samsung NVME storage and an external USB 3 Raid Array

 

My laptop (working properly)

Windows 10 Home 1909 all updates

Core i7 9750

32GB Ram

RTX2080

2 NVME drives

 

Only realy software difference I can see is that the RTX 2080 in laptop is using drivers from later Oct 2019 and my desktop is using Dec drivers. I am not prone to believe this should affect how Premiere renders out when using a software only setting but I thought I'd add that to the mix.

 

Also when I do simple test and add a title onto a white background and set opacity to 50% in premiere via effects panel, it looks normal on screen but when rendered it looks more like 15% opaccity. If I set it below 30% it appears to render as if it were at 0%. So there is some kind of shift going on here.

 

Thanks for any help. I have a critical job due next week and this has caused a major problem.

TOPICS
Error or problem

Views

136

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 19, 2020 Feb 19, 2020

Copy link to clipboard

Copied

There are quite a few Resolve users that are having troubles with Nvidia drivers later than early January, and are recommending to fellow users to stay with earlier drivers. So ... you might test rolling back the desktop's drivers to an earlier version and see if it works.

 

Neil

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2020 Feb 19, 2020

Copy link to clipboard

Copied

The Nvidia Driver didn't help. I did a clean removal and then installed the same October driver that worked on my laptop and got the same results. I have however determined that the opacity issue is not present when I overlay a graphic on a video....so the same text that completely disappeared at 40% on a white background stays at 40% as it should when over a video. I tried it on a grey background and the opacity seemed to be normal. I then tried in on a "not pure white" background....RGB 235 235 235 instead of the 255 and it failed again. So it seems as if premiere is not liking overlay on a bright background. Which is weird since I have used this technique for years creating motion graphics. The white background was always a base to fade textures and animations into. Anyone else have any ideas? Maybe my description could give someone a clue as to where I should look to resolve this. The bottom line is it occurs across 2018,2019 and 2020...so it has something to do with how it handles color space across all versions. Thanks.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2020 Feb 20, 2020

Copy link to clipboard

Copied

Update: I seem to have somehow isolated this issue to Adobe Media encoder compressing to h.264 codec. I tried outputting to Quicktime Pro Res and then to DnxHR codec and the opacity is perfect on both files. So....how do I trouble shoot this issue? I have 2 other almost identical computers and configurations that export to  H.264 without this issue. Is there an h.264 codec issue on this specific machine that I can begin to troubleshoot? I was "this" close to rebuilding it from scratch but I have projects that I am in the middle of and cannot really afford the downtime right now.

 

Thanks.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

I had this very same issue. I'm

surprised there's not more conversation about this. I get the weird h264 issue with a white matte layer with photos animating over the top. Usually just scale and position in after Effects. 

did you ever figure out a solution for this?! 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

A couple of things to try.

- Project Settings > set the renderer to software only

- Sequence Settings > turn off Composite in linear color

- Media Encoder > also set the renderer to software only

 

Hope it helps

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

Looking through other threads, turns out all you have to do is use a white image behind your animated photos, instead of using the white solid shapes as a matte.  It fixed the issue.

 

thbaks for replying and for your thoughts though!

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines