Pink/green line on edge of screen during cross-dissolve transitions to and from black

Community Beginner ,
May 05, 2011 May 05, 2011

Copy link to clipboard

Copied

I've seen this posted as a known bug in Premiere, but I haven't found a decent solution to it.  Here's a screen cap of what it looks like:

Pink Line cap.jpg

Notice the pink verticle line on the right side of the frame. This happens when I'm exporting it out of the timeline to another format - it doesn't look like this in the timeline. I have done a few tests and it seems to only do this when:

A) it's fading from black or to black - cross-dissolving from one video to another doesn't do it

and

B) the output video is in widescreen 16:9

It doesn't happen when I'm creating an HD video and it doesn't happen when it's an SD video in "D1/DV NTSC (0.9091)" aspect.

Thoughts?

Views

26.4K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , May 01, 2014 May 01, 2014
I should point out a couple of things here:In my experience, I don't have a CUDA card, so I assume I'm using Mercury Playback Engine. However, I seem to always get a pink line if I use Adobe Media Encoder. If I just export directly from Premiere, I don't get it. All of my sequences are exported at 1280x720 or 856x480, both of which are divisable by 4. Given these two points, I'm inclined to say the problem is with AME and it needs to be solved by Adobe. Using opacity instead of transitions is ju...

Likes

translate

Translate

Translate
LEGEND ,
May 05, 2011 May 05, 2011

Copy link to clipboard

Copied

I do widescreen DV all the time and have never seen this.  Can't think of anything off hand that could be a cause.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 05, 2011 May 05, 2011

Copy link to clipboard

Copied

Haven't had that exact problem with pink line, but have solved similar problems by making sure I put a few seconds of black video on the front and back ends of my media timeline work area before exporting. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 13, 2011 Jul 13, 2011

Copy link to clipboard

Copied

I have the same problem.  Pink line (4 pixels wide).

I'm also using widescreen HD footage and resizing it down.  In my case to 460 by 258.

All looks fine during preview, but the final render comes out with a 4 pixels wide line pink lines on the right side during transitions.

My background is white, so it can blend in to the web page where I'm placing the video, and I have a white matte as my video 1 layer.  I tried scaling the matte to 120% of the video's size, but that made no difference.

Anyone got any ideas?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 13, 2011 Jul 13, 2011

Copy link to clipboard

Copied

I just fixed the problem by altering the resized dimensions.

My dimensions used to be 460 by 258 and my original footage is 1920 by 1080.  The reduction factor to get from 1920 to 460 is 4.1739, which would make the height actually 258.75 pixels.

So I decided to try a reduction factor of 4, which gets me a reduced size of 480 by 270.

Using these dimensions, everything renders fine with no pink lines on the right.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 14, 2011 Jul 14, 2011

Copy link to clipboard

Copied

I have seen this before also, you can file a bugreport if you like.

https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 31, 2012 May 31, 2012

Copy link to clipboard

Copied

Premiere_Pro_Pink_Bar.jpg

PROBLEM: Everytime I used a cross dissolve on this particular Premiere Pro (PR)  project, a pink bar on the right side of the screen appeared. I started off with HD footage and ended up working in a rather odd frame size of 566 X 318 (16:9 square pixels). I doubt the problem was related to scaling down the HD video footage however, because as you can see from my screnshot, the problem existed even with  graphics and animations. I saw the problem in my timeline, but assumed it would go away after the final render. No such luck.

SOLUTION: Good old After Effects (AE) to the rescue. I imported my PR sequence into AE and rendered that comp using the Adobe Media Encoder (AME). I try to always end with exporting from AME because of the two pass encoding option that AE does not provide (If this isn't important to you, just skip this last step). In the end, a rather annoying, silly and inconveniet work-around  to eliminate a known bug. These kinds of odd, quirky and unpredictable glitches are making my hair turn gray!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 31, 2012 May 31, 2012

Copy link to clipboard

Copied

a rather odd frame size of 566 X 318

Try to keep the dimension evenly divisible by 8.  That might just clear it up for you.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 01, 2012 Jun 01, 2012

Copy link to clipboard

Copied

Awesome! This project actually just got scrapped, but I'll be sure to remember this neat little math trick for next time. Thanks!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 25, 2013 Feb 25, 2013

Copy link to clipboard

Copied

Has anyone come up with a workable solution to this? I'm getting the same thing with a dissolve when I export, and I cannot figure out how to get rid of it. I've tried exporting various sizes of the clip, nothing works. This is really unacceptable from Adobe.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 26, 2013 Feb 26, 2013

Copy link to clipboard

Copied

For what it's worth, I've discovered (after hours of playing around with settings) that when you're using dissolves in video, for some reason setting the Source Scaling option in the encoder to "Scale to Fill" seems to work.

If your Source Scaling says "Scale to Fit", try changing this option and it should work.

I tested this using .mp4/h.264 encoding, 856x480, baseline profile. It works in Premiere's media encoder. If I try to take the sequence into AME separately, it doesn't. I don't know why.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2016 Apr 28, 2016

Copy link to clipboard

Copied

this fix worked perfectly for me.. thank you !!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2013 Feb 26, 2013

Copy link to clipboard

Copied

I found a fix for this by exporting the areas where I had fades into a different file type -- in my case, it was an 1080 HD project, so I think I exported HD DPX video files -- and then I dropped those exported files into the timeline over the problem areas. Kind of a pain, of course, but it only took me maybe an hour to do all of the fade-to-black and fade-from-black areas. I'm currently doing a 5K project in Premiere and I haven't noticed this problem there.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 26, 2013 Feb 26, 2013

Copy link to clipboard

Copied

Makes an ok workaround, but why should you have to work around like this? This is clearly a known issue, it should be identified and fixed as such.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 27, 2013 Jun 27, 2013

Copy link to clipboard

Copied

This is a highly annoying stupid glitch.  Sure would be nice if Adobe cared enough to fix the problem.  Ok, Adobe?  Fix it.  Stupid problem to have. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 28, 2013 Jun 28, 2013

Copy link to clipboard

Copied

Yes! Yet again, I trusted Adobe Media Encoder to export 856x480 .mp4/h.264, and yet again, pink line during dissolves. If I export directly within Premiere, I have no problems.

This is flat out unacceptable. The point of AME is to allow me to export multiple versions of a project at once. If I can't use this, the product isn't saving me any time.

Now I have to export 1280x720, take that into QuickTime Pro, and export 856x480.

Get it together and fix, Adobe!

Does anyone have the ear of someone at the company that we can pester for a fix? This is silly...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 27, 2013 Aug 27, 2013

Copy link to clipboard

Copied

Hey Guys

Just popped here after encountering the same problem for the first time (was so embarrassed when I presented a rough-cut to the client and noticed it). Has anyone reported this to Adobe, strange the first post was 2011 and we are still facing this bug in 2013. Is it me or is Adobe slipping up?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2020 Jan 08, 2020

Copy link to clipboard

Copied

Perfect 🙂 That worked. Thank you for sharing that.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 19, 2013 Sep 19, 2013

Copy link to clipboard

Copied

I have the same problem. I have a client that wants a 710x400 size from 1080HD video. I found a workaround though. Instead of using a transition, I just keyframed the opacity of the clip. Pink line gone.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 02, 2013 Oct 02, 2013

Copy link to clipboard

Copied

hi dorseymkt,

try this, select your format and preset.... then select Scale to Fill -- and then select checkbox Render at Maximum Depth...

I think some of the solutions here are workarounds and just patches the problem, but not a real fix

let me know if that works for you -- or for anyone in here.

johnrex27

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 03, 2013 Oct 03, 2013

Copy link to clipboard

Copied

WIll try this over the weekend and get back to you...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 23, 2014 Apr 23, 2014

Copy link to clipboard

Copied

Can SOMEONE at Adobe fix this please? Flat out unacceptable. It's been a bug for THREE YEARS and I just exported a project to AME and again, I get pink lines. Completely unacceptable for a $1,500 product. FIX IT!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 30, 2014 Apr 30, 2014

Copy link to clipboard

Copied

My solution to the Pink Bar phenomenon --

I too experienced the “pink bar” on dissolves problem, and I was in the midst of finishing an 8 DVD set of a medical conference video from Barcelona, and since I had no time to test, I took someone's advice that you can only ramp the opacity instead of using dissolves, and I spent hours changing hundreds of dissolves to opacity ramps. After this project, I decided that it was a real pain working this way and I decided to investigate/test further.

I had a GT120 graphics card that came with my Mac Pro 2009 tower computer during that project. It doesn’t give CUDA acceleration in Premiere or Adobe Media Encoder so my only choice so far was using the Mercury Playback Engine Software Only. Last week I got a Quadro 4000 card that does allow Cuda acceleration, and I noticed that the pink line problem disappeared. But I wanted to figure out what was going on so I did a lot of tests exporting with Premiere and AME on both graphics cards separately to see what was going on.

Here are my conclusions:

The pink lines APPEARS when you do the following: You are using the Mercury Playback Engine Software Only to render (in either Premiere or AME), AND at least one of your output dimensions are not directly divisible by 4.

So for instance, I was rendering out a scene to H.264 using my GT120 card that only allowed the Mercury Software Playback Engine at the following dimensions: 854x480 and the problem would occur. If I output it at 852x480 the problem would disappear. The reason being that 854/4= 213.5 and 852/4=213 (a whole number). This would also hold true for the height dimension, so for instance 460x258, in this case 258 is not divisible evenly by 4.

If you render using a CUDA enable card, and you have turned it on in both Premiere>>Project Settings>>General>>Renderer: Mercury Playback Engine GPU Acceleration (CUDA), and in Adobe Media Encoder>>Preferences>>General>>Video Rendering Renderer: Mercury Playback Engine GPU Acceleration (CUDA), then this problem doesn’t exist, even for sizes that are not divisible evenly by 4. So you can render at 854x480 and be fine as long as you’ve set your preferences to CUDA Hardware. (You can still have the pink bar glitch if you change to Software Only rendering even though you have a CUDA card, so make sure CUDA is selected.)

One other thing to note is that in the Adobe Media Encoder Preferences, there is an item that says “Enable native Premiere Pro sequence import”. It is my understanding that if you check this, it will default to the renderer you have set in AME, and if unchecked it will default to the renderer selected by Premiere Pro. So if you have a CUDA card just make sure AME and Premiere are set to use CUDA.

Anyway, the conclusion I came to is that if you are using a computer that doesn’t have a CUDA card and you have to use the Mercury Software Playback Engine, then just make sure both dimensions of the video you output are evenly divisible by 4.

(If you have to use a dimension not divisible by 4 on a Software Only computer, then experiment using Maximum Render Quality - sometime this would fix the problem, but I need to get back to editing now so I’ll let others figure out when this works and doesn’t).

I hope this helps, and please feel free to chime in if you have any different experiences with this pink bar phenomenon.

Thanks,

Lane

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 01, 2014 May 01, 2014

Copy link to clipboard

Copied

I should point out a couple of things here:

  • In my experience, I don't have a CUDA card, so I assume I'm using Mercury Playback Engine. However, I seem to always get a pink line if I use Adobe Media Encoder. If I just export directly from Premiere, I don't get it.
  • All of my sequences are exported at 1280x720 or 856x480, both of which are divisable by 4.

Given these two points, I'm inclined to say the problem is with AME and it needs to be solved by Adobe. Using opacity instead of transitions is just silly - we've been using transitions in digital editing packages for years, so this shouldn't cause pink pixels.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 30, 2014 Apr 30, 2014

Copy link to clipboard

Copied

Hi robodog,

I'm glad you appreciate my post. Basically I work at a medical videography company and up until this year I'd been shooting surgeries/conferences in SD and editing on FCP7 which has been a great, simple workflow. But we upgraded to HD and I was faced with choosing the correct path. Just for sheer volume of material I shoot alone, the fact that Premiere Pro can work with native files and doesn't have to transcode material to ProRes like FCPX or FCP7 does made the shift a no-brainer. It will save me hours of time and loads of hard drive space.

There was another problem I noticed in Premiere Pro with the tinny metallic sound on audio dissolves. I'll have to see if this problem persists with my new Quadro 4000 graphics card (or if it is even related). I think people mentioned if you are using AME to make sure to uncheck the "Enable native Premiere Pro sequence import". So with that unchecked, and using a CUDA card, hopefully I won't see either issue in the future.

I'll post again if I come across some relevant information that can help Premiere Pro/AME users with some technical hurdles that I am experiencing as well. I'm not a big poster nor am I a Premiere expert by any means, but these problems that crop up need to be addressed and figured out by the community instead of just posting criticisms of Adobe and giving up before really trying to test things out ourselves.

If editors are using Premiere Pro to post some Hollywood movies, obviously not everyone is experiencing the dreaded pink bar when using dissolves. Hopefully now that the problem is identified, maybe it can logically be addressed by Adobe programmers. But now we at least have a work around.

Thanks,

Lane

P.S. I'm already happily married...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines