Highlighted

Playback lag. Nothing helped.

New Here ,
Sep 16, 2020

Copy link to clipboard

Copied

Hey everyone please HELP, I am strugling hard with playback lag. It is extremely choppy and I cant edit. I have tried everything I have found here or on the internet. Starting simply with lowering playback quality, through different instalations, setting proxies to hardware check and much more. I have about 20 thing on my list that I have tried and NOTHING helped. I need to have it fixed ASAP.

 

First it started with 4K videos from Sony camera (.MXF) but now not even the Media Encoder helped (I tried to go from 4K to 1080p youtube quality). 

 

Any suggestions please?

Adobe Community Professional
Correct answer by Byron Cortez | Adobe Community Professional

If you updated to the latest version of Premiere Pro 14.4, I can suggest you go back to 14.3.2 because this lag is being reported in several users, surely we will soon have a correction update.

TOPICS
Error or problem

Views

83

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Playback lag. Nothing helped.

New Here ,
Sep 16, 2020

Copy link to clipboard

Copied

Hey everyone please HELP, I am strugling hard with playback lag. It is extremely choppy and I cant edit. I have tried everything I have found here or on the internet. Starting simply with lowering playback quality, through different instalations, setting proxies to hardware check and much more. I have about 20 thing on my list that I have tried and NOTHING helped. I need to have it fixed ASAP.

 

First it started with 4K videos from Sony camera (.MXF) but now not even the Media Encoder helped (I tried to go from 4K to 1080p youtube quality). 

 

Any suggestions please?

Adobe Community Professional
Correct answer by Byron Cortez | Adobe Community Professional

If you updated to the latest version of Premiere Pro 14.4, I can suggest you go back to 14.3.2 because this lag is being reported in several users, surely we will soon have a correction update.

TOPICS
Error or problem

Views

84

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 16, 2020 0
Adobe Community Professional ,
Sep 16, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2020 0
Adobe Community Professional ,
Sep 16, 2020

Copy link to clipboard

Copied

If you updated to the latest version of Premiere Pro 14.4, I can suggest you go back to 14.3.2 because this lag is being reported in several users, surely we will soon have a correction update.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2020 1
New Here ,
Sep 26, 2020

Copy link to clipboard

Copied

I went back to versioin 14.3.2 as @Byron Cortez suggested. Premiere Pro 2020 works great.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2020 0