Playback stutters, read 50 posts, tried everything

Community Beginner ,
Mar 05, 2021 Mar 05, 2021

Copy link to clipboard

Copied

So I was editing H264 4K video with Adobe stock music yesterday and had no issues, so this is extra frustrating.
I've just installed CC this week and am trying it out, but I've never had this issue with PowerDirector, not a good start Adobe.
It's a short real estate video under 1 minute, no effects on the clips yet, in fact I've just got 2 clips and its hanging and skipping like crazy!

Yes audio input is set to 'none', I have it rendering at 1/4 resolution (I'd rather not though) and the playback window is small.

My PC handles DCS (the most demandind flight sim out there) just fine, so this is annoying.

Windows 10 Home 64-bit (10.0, Build 19042) (19041.vb_release.191206-1406

i7-4770K CPU @ 3.50GHz (8 CPUs)

16GB RAM - Premier is getting 11GB
EVGA GTX 1070 8GB
I have no other programs running and Premier priority is set to high.

Please tell me this is something simple, I have a strong PC and the video format is extremely common, you wouldn't expect a workflow killing issue right out of the gate with the latest version of Premier and a tiny project, or should you?

TOPICS
Editing, Error or problem, Formats, Freeze or hang, Performance

Views

29

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 05, 2021 Mar 05, 2021

Copy link to clipboard

Copied

I've removed all audio and it is still hanging at and clip change without any effects.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines