PP 2021 very laggy

Community Beginner ,
May 05, 2021 May 05, 2021

Copy link to clipboard

Copied

Anyone else getting serious lagging issues in 2021?  Comparing identical projects (via exporting xmp and opening in 2020) and there's no comparison. Working on multi screen collages, up to 60 video clips per screen, and having little or no lag in 2020 and tons in 2021. GPU decoding is checked, cache cleared (which helped a little but only slightly)

 

Ryzen 3900

GTX 1660

Windows 10 64bit

PCIe M2 SSD

64GB RAM 

TOPICS
Hardware or GPU

Views

571

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 05, 2021 May 05, 2021

Copy link to clipboard

Copied

Hi Nockle,

We appreciate you writing in and sharing the system details. Do you experience lag during playback or during using the application features? Please share more details.

Also, please check if your computer meets the GPU requirements for using the application. https://helpx.adobe.com/premiere-pro/kb/gpu-and-gpu-driver-requirements-for-premiere-pro.html

 

Looking forward to your response.

Regards,

Shivangi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

My PC does meet the requirements for GPU acceleration. The lag is during playback, and Premiere 2020 is quite a lot better in this regard, so I've rolled back to that. I'm hoping it's a setting that I haven't checked as identical projects in 2020 work a lot faster. To confirm, I've checked GPU acceleration, and have the most recent Nvidia studio drivers 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

LATEST

try changing the renderer in your project settings.   Updates usually put greater demands on your system so what works well in earlier versions may not work as well after an update. 

 

Have you tried a proxy workflow?  This can make an enormous difference.  Not always easy to get your head around it initially, but rock solid once you've figured it out.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines