Highlighted

Premiere 2020 on Mac being randomly stuck // Adobe help please!

New Here ,
Sep 03, 2020

Copy link to clipboard

Copied

Hello I am a professional video editor, with deadlines and deliveries to do. Premiere keeps freezing and not working randomly: the same project one day works, the next day is completely stuck. I've spent several days/hours trying to figure out what's wrong, without solution.

I am currently on a MacPro 2013 OS 10.13.6

3.5 GHz 6-Core Intel Xeon E5

12 GB 1866 MHz DDR3


My current verison of Premiere is 14.3.0

I haven't tried chaging OS or Premire version yet (it's the first time I work on Premiere 2020 and seems to heavy for my system)

The errors I experience: video not showing in Program monitor, troubles in loading footage (footage keeps showing as *loading*),  a recurring message A low-level exception occurred in Device Controller (note: the error message shows in all my projects, even with a empty new project I used as test). Screenshot of error attached.

It's getting really frustrating as I am losing lots of hours of work for nothing so please help.

Thanks

Silvia 

TOPICS
Crash, Error or problem, Freeze or hang, Performance

Views

31

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere 2020 on Mac being randomly stuck // Adobe help please!

New Here ,
Sep 03, 2020

Copy link to clipboard

Copied

Hello I am a professional video editor, with deadlines and deliveries to do. Premiere keeps freezing and not working randomly: the same project one day works, the next day is completely stuck. I've spent several days/hours trying to figure out what's wrong, without solution.

I am currently on a MacPro 2013 OS 10.13.6

3.5 GHz 6-Core Intel Xeon E5

12 GB 1866 MHz DDR3


My current verison of Premiere is 14.3.0

I haven't tried chaging OS or Premire version yet (it's the first time I work on Premiere 2020 and seems to heavy for my system)

The errors I experience: video not showing in Program monitor, troubles in loading footage (footage keeps showing as *loading*),  a recurring message A low-level exception occurred in Device Controller (note: the error message shows in all my projects, even with a empty new project I used as test). Screenshot of error attached.

It's getting really frustrating as I am losing lots of hours of work for nothing so please help.

Thanks

Silvia 

TOPICS
Crash, Error or problem, Freeze or hang, Performance

Views

32

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 03, 2020 0

Have something to add?

Join the conversation