Premiere CC Open Captions - Poor rendering (aliasing) (Premiere Pro 14.9 and earlier)

Community Beginner ,
Jun 12, 2017 Jun 12, 2017

Copy link to clipboard

Copied

Hi

I'm creating open captions (burned in) on a project in premiere pro CC. I am finding it hard to display text that looks nice visually as the text has very jagged edges. Are there no aliasing options like there are for titles ? The lack of options seems crazy. I tried using a blur effect to soften the text but this seems to behave a bit weirdly, there is a threshold before the blur has any effect at all and then it is too strong.

 

Someone suggested creating the subtitles at twice the size, and although this is a bit of an odd work around for something so basic, my captions are all done and I can no longer change the format size (the reason why this limitation is in place is beyond me)

 

Anyone have a good work around for making premiere captions nice and smooth (the same way any other program less than 25 years old can...)?

 

thanks!!

TOPICS
Editing, Effects and Titles

Views

14.0K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

New Here , Jan 28, 2019 Jan 28, 2019
Hi, I've run into the same problem today.Try this to see if it helps:right click in project manager on the caption file, go to modify > interpret footage.Under Alpha Channel, select "Conform Alpha Premultiplication" to: and check "Premultiplied Alpha"Regards,Aljosa

Likes

translate

Translate

Translate
Explorer ,
Sep 08, 2017 Sep 08, 2017

Copy link to clipboard

Copied

Same problem here. The open captions look fine in the preview, but terrible after rendering.  I tried different fonts, no difference. Will redo it with after effects manually. Man, wtf, really.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 08, 2017 Sep 08, 2017

Copy link to clipboard

Copied

Hey,

I found an answer to this.

What you need to do is add your subs to the timeline, then right click. From the menu, choose 'Scale to frame size'2017-09-08 12_19_11-Adobe Premiere Pro CC 2017 - X__YouTube Channel_Brand_Brand Vision_Brand Vision..png

This will now make the text really smooth and you can then use the Captions panel to change font size, typeface etc.

To apply the changes to all the captions, right click on one of the captions and choose 'select all'.

2017-09-08 12_20_04-Adobe Premiere Pro CC 2017 - X__YouTube Channel_Brand_Brand Vision_Brand Vision..png

Cheers,

Col

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 05, 2018 Feb 05, 2018

Copy link to clipboard

Copied

Nothing changed for me by doing this... still kinda crapy display. also I wanted to soften or even reduce the opacity of the edges but It just lack the controls or doesn't let me do it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 12, 2018 Feb 12, 2018

Copy link to clipboard

Copied

This for sure isn't helpful but I gave up on premiere for this and continue to add everything concerning text-layers in after effects.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 28, 2019 Jan 28, 2019

Copy link to clipboard

Copied

Hi, I've run into the same problem today.

Try this to see if it helps:

right click in project manager on the caption file, go to modify > interpret footage.

Under Alpha Channel, select "Conform Alpha Premultiplication" to: and check "Premultiplied Alpha"

Regards,

Aljosa

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 28, 2019 Jan 28, 2019

Copy link to clipboard

Copied

Thank you so much. This worked for me!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 30, 2019 Jan 30, 2019

Copy link to clipboard

Copied

This seems promising, as I suspect an issue on how the text is interpreted against the caption background, even if transparent. But in my test, I did not see any difference. What font are you using?

My .srt is a simple one, properties matching the video sample. I used regular PR text (Essential Graphics), matched for font, style, size, color (Arial, Regular, 50, White). The caption is on a black background, but the video background lets it all stand out. Instead of "fit," I set the program monitor to 400% (otherwise full resolution), and I can easily see the greater antialiasing for the Caption text compared to EG. The EG antialiasing is fine and even; the caption antialising is uneven and abrupt in places.

Exported to H.264 with captions burned in. The appearance is the same as the preview. The differences is not apparent without zooming in, but visible on close inspection even at 100%.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 17, 2019 Apr 17, 2019

Copy link to clipboard

Copied

Hi, Have tried this and unfortunately the text in the export is still the same! (attached below). This is an animated video which will be shown on a big screen, surprised something so basic such as captions are turning like this, any leads please? : My settings below, thanks in advance!

Screenshot (21).pngScreenshot (20).pngScreenshot (19).png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 18, 2019 Apr 18, 2019

Copy link to clipboard

Copied

See another workaround here:

Re: Captions Text Poor Quality

If nothing works, I see no good alternative but to use regular text (not the caption tool).

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

Just discovered that this only works, if you have an "edge" of 1px. Smooth text, but with a red stroke. Then I just changed the color of the stroke to the main text color I wanted.

 cf317113d68c100de328ad81ee778483.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 10, 2020 Jul 10, 2020

Copy link to clipboard

Copied

You are a hero! Not only did it anti-alias for me, but it also aligned my texts centered in the bar! I had a difficult time searching on how to center the texts vertically and setting Edge to 1 worked. The only caveat is that it removed font weight for me and had to adjust Edge to simulate a bold weight. But that's load better than ugly pixelized captions. Cheers!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2021 Mar 29, 2021

Copy link to clipboard

Copied

This has been bugging me for such a long time. Tried all the above but no dice. Always ended up doing it in AFX. 

Can't tell you how happy I am to say that your Workaround fixed it for me.

Thank you!!!!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2020 Nov 17, 2020

Copy link to clipboard

Copied

Thank you so much. This was driving me crazy—a little black outline around my text, aliased. Now it's fixed, phew.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2021 Mar 05, 2021

Copy link to clipboard

Copied

It worked! I love you!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 19, 2020 Aug 19, 2020

Copy link to clipboard

Copied

Found the answer to this - keep the scale of your captions the same, trying to rescale them causes the poor quality. Instead, go into the captions editor and change the font size. This retains the quality whilst increasing the size of the captions, they look pretty crisp.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 24, 2021 Jan 24, 2021

Copy link to clipboard

Copied

This is it right here. Do not scale in your effects panel. What I do, is modify the captions so the width is two times the size of my actual sequence. (this solves for the ends getting cut off.) And then increase font size in the captions panel. You can position the frame with Effect controls, just don't scale. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 16, 2021 Feb 16, 2021

Copy link to clipboard

Copied

I can't find the captions editor anywhere I might be looking in the wrong place would you mind helping me out?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

If you double click on the captions within your timeline, it should open up the editor on the left (where media is usually displayed). Otherwise go to Window > Captions and you'll get the same result.

 

To change the size, look for the font name, beside that is the font weight (Bold, regular, medium) and then beside that - to the right - is size.

 

Just change that and it'll scale whilst maintaining quality.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

So I did exactly that but all the edges of the captions are really rough after exporting I don't know what to do since this is a video for a university application and every detail matters.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

Does it look "rough" in the preview?

 

If not then it could be down to your export settings.

 

If the above is that your preview looks fine and crisp, could you write out your export settings?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

No even in the preview at full resolution the captions still look rough it's almost as though there's a small black outline around each letter (edge opacity is set to 0%)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

That tends to be the case if you zoom right in. At 100% resolution you'll be able to see what the captions genuinely look like.

 

I exported my project at:

 

FORMAT: H.264
RENDER AT MAX DEPTH: TRUE
PROFILE: HIGH
LEVEL: 5.1
USE MAX. RENDER QUALITY: TRUE

 

This is obviously adapted towards my project but if you can use some of them then do so.

 

In the export see how the captions come out.

 

Try them in a few different resolutions and if not I'll do some digging.

 

The more you zoom in on anything then you're going to get a pixellated view because it's built using pixels (sounds like I'm teaching you to suck eggs but that's the basics of it).

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

I think you just fixed the issue for me here's what I did to "fix it" sorta (it's less sharp on the edges)

1. I copied your exports setting and that helped for sure.

2. I change "edge" from 0 to 1 and selected white on the color spectrum since my captions are white and that seemed to help.

3. I reduced the size of my captions by about 20 units and they're now clearer.

Also don't worry about sounding like you're teaching me basic stuff since i'm still a beginner with premiere pro or video editing in general 🙂

Thanks a lot for your help!!!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2021 Apr 25, 2021

Copy link to clipboard

Copied

Any tips for the new Premiere Pro update 2021? The workflow is different now... 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines