Premiere crashes instantly when opening

Community Beginner ,
Dec 08, 2020

Copy link to clipboard

Copied

Ive been using Premiere for years and years and yes it has it faults but it never had such an issue where it couldnt even open!

 

Im a professional video editor so need everything running smoothly and have been on 14.0.1 for ages with no problem, i did update a while back and it crashed so i rolled back

 

Lately premiere was getting super laggy and CPU hungry so i decided to update to both 14.5 and 14.6 and i cant even open premiere let alone a project

 

Im on a 2019 Macbook pro 16" i9 on OS Catalina 10.15.7

 

I did a cache and preference reset on premiere to no avail

 

Please help 😞

Try the 14.7, it includes some bug fixes.

TOPICS
Crash, Error or problem

Views

107

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere crashes instantly when opening

Community Beginner ,
Dec 08, 2020

Copy link to clipboard

Copied

Ive been using Premiere for years and years and yes it has it faults but it never had such an issue where it couldnt even open!

 

Im a professional video editor so need everything running smoothly and have been on 14.0.1 for ages with no problem, i did update a while back and it crashed so i rolled back

 

Lately premiere was getting super laggy and CPU hungry so i decided to update to both 14.5 and 14.6 and i cant even open premiere let alone a project

 

Im on a 2019 Macbook pro 16" i9 on OS Catalina 10.15.7

 

I did a cache and preference reset on premiere to no avail

 

Please help 😞

Try the 14.7, it includes some bug fixes.

TOPICS
Crash, Error or problem

Views

108

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 08, 2020 0
Enthusiast ,
Dec 08, 2020

Copy link to clipboard

Copied

Try the 14.7, it includes some bug fixes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2020 1
Community Beginner ,
Dec 08, 2020

Copy link to clipboard

Copied

cool thanks that worked!

 

i never download the latest version but apparently it fixed what ever was causing the startup crashes

 

On a side note do you know if you can delete the entire adobe application support registry to create a "clean install"?

 

Ive picked up a number of 3rd party extensions over the years and think that was causing launch issues

or at least delete the entire CEP Folder?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2020 0
Enthusiast ,
Dec 08, 2020

Copy link to clipboard

Copied

Have you given this a try?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2020 1
Community Beginner ,
Dec 08, 2020

Copy link to clipboard

Copied

I have not!

I remember having something similar on FCP 7 back in the day but this looks amazing

You sir, are a gentleman and a scholar 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2020 0
New Here ,
Dec 08, 2020

Copy link to clipboard

Copied

I have same issue, but on W10 and versions 14.6,14.7. and 14.8 beta. 14.5 works correctly. Any solution?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2020 0
New Here ,
Jan 09, 2021

Copy link to clipboard

Copied

I found solution for my problem. I have to disconnect from the internet before I open PP. I don't know why, but it works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 09, 2021 0
Participant ,
Dec 08, 2020

Copy link to clipboard

Copied

Sorry to hear you are going through that. I posted on here this weekend about the identical problems you were having and almost felt like the issues I was having was an isolated issue only to find out other uses were having it as well from here to Twitter. I wasn't expecting 14.7 until next week but I'll give it a try on my home computer so I don't lose hours trying to remedy the issues.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2020 1
New Here ,
Dec 08, 2020

Copy link to clipboard

Copied

Had the same prob. Did my own work around before. Had to open a new project and then open the old project via "File>Open project (⌘+O)".

 

These following steps made it work for me atleast. Im on OS Catalina.

 

Step 1: Click blank on the desktop screen once and then you will see the Go option on top near Apple icon -> Click on Go option and then select the option of Go to folders -> a box will open, type ~/Library in the box and enter -> go to application support folder -> go to Adobe folder -> there you will see the premiere pro folder, rename this folder to premiere pro.old

 

Step 2: Close this window -> click blank on the desktop -> click on that Go option and then go to documents -> go to Adobe -> there you will see the premiere pro folder, rename this folder to premiere pro.old

 

After this it worked just fine 🙂 

 

It is due to the preferences which get distorted somehow...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2020 2
Community Beginner ,
Dec 08, 2020

Copy link to clipboard

Copied

interesting! does that just keep all the old preferences and rebuild everything into a fresh new directory?

at the moment it seems to be working fine on the latest version (14.7) but this is good to know if it bugs out again

im also on catalina btw, im would be on Mojave but the new macbook come stock catalina and no way im going big sur 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2020 0
New Here ,
Dec 08, 2020

Copy link to clipboard

Copied

Yep, correct! 

 

Ah, sweet...I had the latest update aswell but still had the issue. 

 

Hope you dont get that nasty crashes back, ciao!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2020 0
Participant ,
Dec 08, 2020

Copy link to clipboard

Copied

I'm contemplating updating to Catalina again at the end of the year. Last time I was on it which around 10.15.3, it did damage that required me to rollback to Mojave and refuse my Fusion drive. Do you find that your experience using Premiere, AE and other Adobe apps to be smoother?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2020 0