Highlighted

Premiere Not Showing Playback Window on Selected Monitor.

New Here ,
Apr 17, 2019

Copy link to clipboard

Copied

Im having an issue with Premiere and my 3 monitor set up.

The left most monitor is a LG TV known as Monitor #1 to the computer, monitor #2 is my main display, a dell monitor, and the right most dell monitor is #3.

Under Edit>Preferences> Playback... I have Pause Media Encoder and Enable Mercury boxes checked. I want the playback window to appear on the TV, monitor #1. But if I select the box for #1 and apply, the window appears automatically on monitor #3 and when I look at the settings again Monitor #3 box is checked. If I select monitor #2, no playback window appears anywhere. If I check monitor #3, playback appears on monitor 3.  So the program is recognizing I have 3 monitors, but it only wants to use one of them.

All settings are correct in the display settings of Windows 10. I've installed the newest gfx card drivers, reset Premiere, the computer and tried multiple files. Still I have had no luck. I even tried unplugging monitor #3 and that didn't change it either. For whatever reason Premiere only wants to work with Monitor #3.

Specs:

Premiere Pro ver: 13.1.0 (Build 193)

Windows 10 Pro

nVidia 680

Intel i4770

32gb RAM.

Views

2.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Not Showing Playback Window on Selected Monitor.

New Here ,
Apr 17, 2019

Copy link to clipboard

Copied

Im having an issue with Premiere and my 3 monitor set up.

The left most monitor is a LG TV known as Monitor #1 to the computer, monitor #2 is my main display, a dell monitor, and the right most dell monitor is #3.

Under Edit>Preferences> Playback... I have Pause Media Encoder and Enable Mercury boxes checked. I want the playback window to appear on the TV, monitor #1. But if I select the box for #1 and apply, the window appears automatically on monitor #3 and when I look at the settings again Monitor #3 box is checked. If I select monitor #2, no playback window appears anywhere. If I check monitor #3, playback appears on monitor 3.  So the program is recognizing I have 3 monitors, but it only wants to use one of them.

All settings are correct in the display settings of Windows 10. I've installed the newest gfx card drivers, reset Premiere, the computer and tried multiple files. Still I have had no luck. I even tried unplugging monitor #3 and that didn't change it either. For whatever reason Premiere only wants to work with Monitor #3.

Specs:

Premiere Pro ver: 13.1.0 (Build 193)

Windows 10 Pro

nVidia 680

Intel i4770

32gb RAM.

Views

2.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 17, 2019 0
Adobe Community Professional ,
Apr 17, 2019

Copy link to clipboard

Copied

Is there any OS level scaling of the LG TV as far as the computer is concerned?

I know in my own 3-monitor setup, when I started with 13.0.1, I could select the UHD monitor and the setting stuck only if scaling was at 100%. Any other setting in the OS, it wouldn't 'stick'.

Now, a few weeks later, it seems to have decided it's all fine, now. I can set any scaling on that monitor, select it for Mercury Transmit, and it sticks.

AfterEffects was the opposite, it would ONLY work if scaling was at 150%. But after a while, I found that if I set the monitor for 150% in the OS, started AfterEffects, turned on video preview transmit, it would allow the UHD monitor to "take" for transmit. Close Ae, set the monitor to say 200% scaling, re-open Ae, the monitor was still selected. BUT ... if I de-selected transmit, nope ... couldn't reselect.

Further, Ae will NOT not include my 1920x1080 '2' monitor in transmit out! So ... I can get the UHD but I also ALWAYS get the 1920x1080 anytime transmit out is on.

Talked with the engineers at NAB, and they are aware. But I don't know when we'll get a fix.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2019 0
New Here ,
Apr 18, 2019

Copy link to clipboard

Copied

To be sure i'm looking in the right spot for the scaling. Right Click blank area on desktop > Display Settings > Select the monitor in the "graph/picture" at the top of the window > Check "Scale and Layout" section? If so all displays are set to 100% scaling.1920x1080. Landscape orientation.  Advanced scaling settings are off.

I just tried another combination of playback settings that I dont think I did last time all with a totally new file. Unchecking "Adobe DV" in Playback and then selecting monitor 1 and applying causing nothing to happen. Same with monitor 2. If I select monitor 3 with Adobe DV checked it behaves as normal appearing on monitor 3 like you would expect.

So with Adobe DV unchecked nothing happens for 1 and 2. With Adobe DV checked playback for monitor 1 is shown on monitor 3.

Im starting to think this is likely an issue with my PC instead of the program itself, but I have no clue what the issue could be.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2019 0
Adobe Community Professional ,
Apr 18, 2019

Copy link to clipboard

Copied

There is something screwy with transmit out for some of us. The AdobeDv is supposed to be like for an old analog or something. Shouldn't be affecting any standard computer monitor, I wouldn't think.

This is just weird.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2019 0
Community Beginner ,
Sep 28, 2020

Copy link to clipboard

Copied

I know this is an old thread but I had the same issue today with third screen.. simply starting to move the main panel to that monitor sorted it.. good tip, thanks.. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 28, 2020 0
New Here ,
Apr 18, 2019

Copy link to clipboard

Copied

I managed to try it out on another computer with a different 3 monitor set-up and they dont have any issues so there's likely something screwy with my PC...I just have no idea what it could be or what to even try at this point.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2019 0
Adobe Community Professional ,
Apr 18, 2019

Copy link to clipboard

Copied

Try changing monitor scaling in the OS, try changing the size of the Pr window in the 'main' monitor ... that's all I've got.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2019 0
New Here ,
Apr 18, 2019

Copy link to clipboard

Copied

I just got through talking with Adobe Support. They couldn't figure out what the problem was either but said that it is a known issue with this release and that i'll have to wait for a fix to be released with the next update. They also suggested rolling back to ver 13.0.3, but I did that earlier today and still had a problem.

I have no idea what to do now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2019 0
Adobe Community Professional ,
Apr 18, 2019

Copy link to clipboard

Copied

Yea ... I know.

The 12.x versions didn't have this, and ... I'm wondering if you could get the 13.0.3 to work IF ...

  • you downloaded the Adobe CC Cleaner Tool;
  • used that to do BOTH the uninstall AND the cleanup of all bits for Premiere 2019;
  • rebooted, reinstalled Premiere 2019 from the Adobe CC app;
  • rebooted, launched Premiere 2019.

The instructions for the Cleaner Tool say to uninstall THEN run the cleaner. I've had the opportunities over the last few years to become very acquainted with that tool ... enough to be very comfortable in saying that quite often, if you uninstall the app before running the Cleaner Tool, it isn't as capable of a ​complete​ scrubbing of the computer of all bits as if you run the Cleaner Tool with the app installed.

I've talked about this even with the engineers at NAB, and they're very comfortable with this even though "it's not the way the instructions were written."

Might be worth a try. First time running that rather odd "tool" takes maybe fifteen minutes for the whole process. I picked up enough experience to do it under seven minutes a couple times. Sigh.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2019 0
Explorer ,
Apr 26, 2019

Copy link to clipboard

Copied

Same thing here, even though the playback monitor is selected in preferences, it has stopped working. Everything had been working correctly, even with 13.1.1 update, until today. Has been working great until now. 

I have yet to do the uninstall / cleaner tool mentioned by Neil, but none of the other tips and suggestions have got it working for me. Hopefully some sort of update from Adobe soon I would hope.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2019 0
Explorer ,
Apr 26, 2019

Copy link to clipboard

Copied

So I just fixed the issue on my system. While troubleshooting I swapped the main Premiere panel to my playback monitor and all the sudden my other monitor popped up full screen playback. So that got me thinking. I am on Windows 10 and below are the steps I took to solve the issue. 

Right click Desktop, go to Display Settings and see what number order your monitors are labeled.  Mine was swapped around, so the monitor I us as my "Main Display" was labeled as 2 rather than 1.

I simply swapped the order to which they were plugged into my GFX card, and they changed over numbers. There might be another way to make them switch number order but this is what worked for me.

Once the playback monitor was set as 2, everything stated working normal again within Premiere.

I am not sure what happened to the system between last night and today, but I would make sure to check the monitor order if you are having this issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2019 2
New Here ,
Oct 20, 2020

Copy link to clipboard

Copied

Thank you thank you!! This fixed the issue for me as well. On a Mac you just need to do the equivellent. I was also able to switch back to my preferred main display and got everything back to normal.

 

I'm guessing anyone who's set up more than one monitor on a Mac knows where to find the display settings, but just in case:

System Preferences—>Displays—>Arrangement

 

  • Your displays will be represented as a blue rectangle; one will have a light grey bar at the top, that's your current main display.
  • Drag that bar to a new rectangle/monitor
  • Go back into Premiere (your workspace will be out of wack, but that's okay for now)
  • Set playback to your desired monitor (this should work now)
  • Go back to display preferences and drag that grey bar back to your prefered main monitor (your work space should be back to normal)
  • You may need to set playback to your desired monitor again

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2020 0