Premiere not using Nvidia GPU even though it's enabled

Community Beginner ,
Dec 03, 2020

Copy link to clipboard

Copied

I've made dozens of videos this year using Premiere and getting it to use the GPU for encoding. About a month ago, Premiere started using CPU, taking my render times from around 8min to 1 hour or more.

 

Nothing has changed hardware-wise:

2080 RTX

i7-8700k

32GB Ram

 

My render settings are exactly the same: HEVC (H.265), Hardware Encoding using Nvidia Codec, 60fps, VBR 1 pass, 25 Mbps.

 

I have exhausted every resource I could find, and I still don't understand why Premiere refuses to use my GPU. PLEASE help.

TOPICS
Export

Views

140

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

2 Correct Answers

Community Beginner , Dec 08, 2020
monoespacial_yt Community Beginner , Dec 08, 2020
Well, I SOLVED it! I uninstalled all Nvidia Drivers using Safe mode + DDU tool from guru3d.Then I reinstalled Game Ready Drivers (Not the Studio Drivers, which probably work as well) because I do use ShadowPlay and a bunch of features a lot.Tried the same settings in Adobe I always use and it worked. 2min to encode instead of 1 hour.

Likes

Translate

Translate
Jump to answer Jump to answer
Engaged , Dec 04, 2020
basil1891 Engaged , Dec 04, 2020
assuming Premiere setting are proper, I'd suggest to manually check/update nvidia driver, use this page:https://www.nvidia.com/Download/Find.aspx

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional ,
Dec 03, 2020

Copy link to clipboard

Copied

Have you checked the settings for preferences for hardware encoding and decoding?

 

 I know they've made some changes, and truthfully I'm not too great on the details of how various CPU/GPU/settings changes work.

 

Neil

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Dec 03, 2020

Copy link to clipboard

Copied

60 fps is not supported at all by any hardware encoder. It must be precisely 59.94 fps for so-called "60 fps" video output (only broadcast-standard frame rates - 23.976, 25, 29.97, 50 and 59.94 fps - are supported). Any nonstandard frame rate (and yes, 30.00 fps and 60.00 fps are considered "nonstandard") will automatically default the encoder to the software-only mode.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 04, 2020

Copy link to clipboard

Copied

After reading your comment, I tried switching it to 59.94 fps and it is still using the CPU. So that's not it either unfortunately.

Screenshot 2020-12-04 083002.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Dec 04, 2020

Copy link to clipboard

Copied

Next thing to check:

 

Have you ever updated the Nvidia drivers from the Nvidia Web site itself (not Microsoft Update, which almost NEVER offered the latest driver versions)? Newer versions of Premiere Pro now require newer driver versions just to work properly.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Engaged ,
Dec 04, 2020

Copy link to clipboard

Copied

assuming Premiere setting are proper, I'd suggest to manually check/update nvidia driver, use this page:

https://www.nvidia.com/Download/Find.aspx

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 04, 2020

Copy link to clipboard

Copied

Might very well be a driver issue. Just tested an export to 120 fps and GPU was maxed out.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 04, 2020

Copy link to clipboard

Copied

Should I download Studio Driver or Recommended?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 04, 2020

Copy link to clipboard

Copied

Studio Driver!

Which card do you have?

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 04, 2020

Copy link to clipboard

Copied

2080 rtx

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 04, 2020

Copy link to clipboard

Copied

Sorry you posted that already.

this is the one you need to install

https://www.nvidia.com/Download/driverResults.aspx/166881/en-us

nvidia.jpg

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 08, 2020

Copy link to clipboard

Copied

Well, I SOLVED it!

 

I uninstalled all Nvidia Drivers using Safe mode + DDU tool from guru3d.

Then I reinstalled Game Ready Drivers (Not the Studio Drivers, which probably work as well) because I do use ShadowPlay and a bunch of features a lot.

Tried the same settings in Adobe I always use and it worked. 2min to encode instead of 1 hour.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more