Premiere Pro 14.6 Lagging on Playback

New Here ,
Dec 01, 2020

Copy link to clipboard

Copied

I'm having debilitating lag on some PP projects but not others. This particular project of the day PP won't playback smoothly on anything unless fully rendered. I've updated Premiere, my graphics driver, and Windows, but nothing seems to help. I'm currently editing at 1/4 resolution, have turned off high quality playback, all waveforms, and allocated more memory. Nothing seems to help.

 

Windows 10

Nvidia RTX 2080

Ryzen 7 2700x 8-Core

32gb Memory

SSD 970 EVO Plus500gb systems drive

HD 4TB WD7200 project files and storage

 

TOPICS
Editing, Freeze or hang, Performance

Views

41

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Pro 14.6 Lagging on Playback

New Here ,
Dec 01, 2020

Copy link to clipboard

Copied

I'm having debilitating lag on some PP projects but not others. This particular project of the day PP won't playback smoothly on anything unless fully rendered. I've updated Premiere, my graphics driver, and Windows, but nothing seems to help. I'm currently editing at 1/4 resolution, have turned off high quality playback, all waveforms, and allocated more memory. Nothing seems to help.

 

Windows 10

Nvidia RTX 2080

Ryzen 7 2700x 8-Core

32gb Memory

SSD 970 EVO Plus500gb systems drive

HD 4TB WD7200 project files and storage

 

TOPICS
Editing, Freeze or hang, Performance

Views

42

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 01, 2020 1
Adobe Community Professional ,
Dec 03, 2020

Copy link to clipboard

Copied

Hello,

 

Sorry to hear that. Is it happening with any specific project or all the projects?

Please try these steps and check if it helps.

If these rebooting steps doesn't work try to change the video renderer in Premiere Pro to Mercury Playback Engine Software Only and check if it helps.

FAQ: How to change the Video Renderer in Premiere Pro?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2020 1
Adobe Community Professional ,
Dec 03, 2020

Copy link to clipboard

Copied

Hi @nicoleo13128341 ,

 

Great suggestions from @Joëlle Bh .

 

Try rendering using software only first. It usually tends to be a GPU issue.

 

Good luck

mj

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2020 0
Adobe Community Professional ,
Dec 03, 2020

Copy link to clipboard

Copied

Is GPU accleration and GPU encoding and decoding enabled The video below may or may not help. That being said what are your stats in Windows task manager?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2020 1
Adobe Employee ,
Dec 03, 2020

Copy link to clipboard

Copied

Yeah, I was going to suggest some of the thing's Andy goes over here. Doing a clean reinstallation of video drivers may help, if nothing else does, Nicole.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2020 0