Highlighted

Premiere Pro 14 won't startup in OSX Catalina without deleting a folder every time

Explorer ,
Jan 07, 2020

Copy link to clipboard

Copied

Ever since I upgraded OSX to Catalina, I have to delete the "14.0" folder from "/Users/x/Documents/Adobe/Premiere Pro" or it won't launch.

 

How do I make this pain in the butt stop?

Hi everyone.  In case anyone else is struggling with the permissions sinc ethe upgrade to Catalina (as in you didn't give it permission when it prompted you for the downloads, desktop, documents, or removable drives), and you want to change your mind, I figured it out,

 

Go to your settings, security and privacy, and click on the tab named "privacy" on top.

 

Select "Files and folders" on the left hand menu and there it all is.  You can select or deselect which applications have which permissions.

 

Screen Shot 2020-04-02 at 9.40.35 PM.png

Topics

Crash, Error or problem

Views

704

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Pro 14 won't startup in OSX Catalina without deleting a folder every time

Explorer ,
Jan 07, 2020

Copy link to clipboard

Copied

Ever since I upgraded OSX to Catalina, I have to delete the "14.0" folder from "/Users/x/Documents/Adobe/Premiere Pro" or it won't launch.

 

How do I make this pain in the butt stop?

Hi everyone.  In case anyone else is struggling with the permissions sinc ethe upgrade to Catalina (as in you didn't give it permission when it prompted you for the downloads, desktop, documents, or removable drives), and you want to change your mind, I figured it out,

 

Go to your settings, security and privacy, and click on the tab named "privacy" on top.

 

Select "Files and folders" on the left hand menu and there it all is.  You can select or deselect which applications have which permissions.

 

Screen Shot 2020-04-02 at 9.40.35 PM.png

Topics

Crash, Error or problem

Views

705

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 07, 2020

Copy link to clipboard

Copied

Have you checked the permissions for the folder?  From the finder, select the folder and hit command-i.  And then go to the bottom of the window for sharing and permissions.   Make sure your active user has full permissions.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jan 09, 2020

Copy link to clipboard

Copied

The folder permissions are okay, but I do remember after the Catalina update that the system did randomly start asking if premiere could have permissions to different folders and I denied it.

 

Is there a place I can adjust whatever those prompts were for?  My user has full access but I'm not certian the application does.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jan 07, 2020

Copy link to clipboard

Copied

Hi @daveybuoy,

 

Thanks for reaching out. As @mgrenadier mentioned, this could be a permission related issue. Here's how you can change the permissions for the folder: https://support.apple.com/en-in/guide/mac-help/mchlp1203/mac

If that doesn't help then create a new user account with admin rights and check the issue in it.

Let us know how it goes.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 10, 2020

Copy link to clipboard

Copied

you say folder permissions are ok, but you can't always tell if they are actually ok or not.  And these sort of issues are more likely to happen after an OS upgrade.  As Nishu Kush suggested, creating a new user with administrator privileges may help you see if permissions are actually an issue.   It's also sometimes useful to do a complete clean install of the OS and apps. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Apr 02, 2020

Copy link to clipboard

Copied

Hi everyone.  In case anyone else is struggling with the permissions sinc ethe upgrade to Catalina (as in you didn't give it permission when it prompted you for the downloads, desktop, documents, or removable drives), and you want to change your mind, I figured it out,

 

Go to your settings, security and privacy, and click on the tab named "privacy" on top.

 

Select "Files and folders" on the left hand menu and there it all is.  You can select or deselect which applications have which permissions.

 

Screen Shot 2020-04-02 at 9.40.35 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 30, 2020

Copy link to clipboard

Copied

When I go into this tab, everything except for Premiere Pro will show up. It doesn't let me allow PP to have folder access and therefore doesn't even let me open PP, because every time I do that it asks me to give it folder permissions, and I can't even do that (running macOS Big Sur)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 30, 2020

Copy link to clipboard

Copied

Bigsur hasn't been released yet. If you expect premiere to run on it you're
making a mistake

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 12, 2020

Copy link to clipboard

Copied

I had the same issue with Big Sur Beta. I had to add an allow under full disk permissions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 19, 2020

Copy link to clipboard

Copied

Hi! I have the same problem. Do you have a solution?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 19, 2020

Copy link to clipboard

Copied

running big sur beta?  probably not a smart thing...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 19, 2020

Copy link to clipboard

Copied

+San4ez55 If allowing it Full Disk Access doesn't work, you might have to use another computer or downgrade back down to an earlier macOS for now until this bug gets fixed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 23, 2020

Copy link to clipboard

Copied

THe fix for this is adding premiere pro to the Full Disk Access section of Security/privacy!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...