Highlighted

Premiere Pro 2020: Can't create text

Community Beginner ,
Nov 14, 2020

Copy link to clipboard

Copied

Hello -

 

I 'm editing a video clip my playback handle is over the section where I want to add text.

I go to the Graphics option on the top of the screen. I go to Essential Graphics, I click on T to create a text layer.  I click on the video and whatever I press doens't work.  I try to create a text box, and if I press H, PP activates the Hand tool.

When I Press T, I don't get any text options.

I went to the Edit section of the Essential Graphics and I can't even add a Text layer there.

I have gone to YouTube to watch a bunch of video to add text.  And I'm doing it right, per the video, but PP is not being cooperative.

 

Help.

TOPICS
Effects and Titles, Error or problem, How to

Views

99

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Pro 2020: Can't create text

Community Beginner ,
Nov 14, 2020

Copy link to clipboard

Copied

Hello -

 

I 'm editing a video clip my playback handle is over the section where I want to add text.

I go to the Graphics option on the top of the screen. I go to Essential Graphics, I click on T to create a text layer.  I click on the video and whatever I press doens't work.  I try to create a text box, and if I press H, PP activates the Hand tool.

When I Press T, I don't get any text options.

I went to the Edit section of the Essential Graphics and I can't even add a Text layer there.

I have gone to YouTube to watch a bunch of video to add text.  And I'm doing it right, per the video, but PP is not being cooperative.

 

Help.

TOPICS
Effects and Titles, Error or problem, How to

Views

100

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 14, 2020 0
Adobe Community Professional ,
Nov 14, 2020

Copy link to clipboard

Copied

Click the Text tool (shortcut T) in the tool bar, then either click in the program monitor and start typing your text, or click-drag to create a text box.

 

In the first way, the text you type will be a line until you press Enter key to 'break' to a second line.

 

In the second way, the text will automatically wrap to stay in the box you created. After you create the text box by click/drag, you then need to click in the box to select the inside of the box, then you start typing your text.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2020 0
Community Beginner ,
Nov 16, 2020

Copy link to clipboard

Copied

Hi Neil -

 

Thanks for your suggestion. I tried that process before I made the post here. 

When I click on the shortcut or pressed T, and then clicked on the program monitor, PP did nothing.

 

It didn't create a new layer, it didn't let me type anything. Whether I typed something or created a text box, nothing happened.

I watched a bunch of videos to make sure I was doing it correctly, and PP still didn't want to do it.

 

Perhaps there's another bug within PP that no one else has documented yet.

 

Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Engaged ,
Nov 16, 2020

Copy link to clipboard

Copied

Can you create a new project from scratch and only try to create a text layer? Just to see if the project is buggy or premiere itself.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Community Beginner ,
Nov 16, 2020

Copy link to clipboard

Copied

Hi Sami -

 

Good idea... I will try that.

 

Thanks

 

Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Community Beginner ,
Nov 16, 2020

Copy link to clipboard

Copied

Hi Sami  -

 

I created a new project. I created a simple timeline with a color matte, and I tried to apply text to it.

Nothing happened.  The text tool would not work.

I clicked on the Text shortcut, and when I tried to enter any text, PP wouldn't do anything.

I usually press H to start my text tests, and every test so far has triggered the Hand tool.

I tried just entering text, and also creating a text box... and everything fails.

 

Thanks


Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Engaged ,
Nov 16, 2020

Copy link to clipboard

Copied

Can you attach this new project? I'll try adding a text layer for you, maybe we can figure this out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Community Beginner ,
Nov 16, 2020

Copy link to clipboard

Copied

Hi Sami -

I opened the file again, created one layer with the matte color... and tried to add text.

Again.. nothing.  I press T or click on the shortcut, and then press H, I get the Hand tool activated.

Here's a link to the file.

https://cloud.degoo.com/share/SpTQGjbDw7TXtm

let me know if you have any problems with it.

 

I'm doing this work on a PC / Win10 64 bit / PP 2020 / 64GB RAM / More than enough storage.

 

Thanks


Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Adobe Employee ,
Nov 16, 2020

Copy link to clipboard

Copied

Hi Doug,

Apologies for the frustration. Try this. Choose the Graphics Workspace. Then choose Window > Workspaces > Reset to Saved Layout. See if that works for you.

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Engaged ,
Nov 16, 2020

Copy link to clipboard

Copied

I've created a text layer with no issues whatsoever. I've uploaded the project here, check if you can at least edit the text layer i've added.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Community Beginner ,
Nov 16, 2020

Copy link to clipboard

Copied

Hi Kevin -

 

I followed your instructions, and still nothing happens.

 

As I mentioned to Neil...

I go to the Graphics, then I press T for the text shortcut, I click on the program monitor window to start typing, and the text doesn't appear, and if I hit a letter assigned to another command, that command gets triggered.

Also, the layers are not locked, but is there another way to prevent text from being added?

 

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Community Beginner ,
Nov 16, 2020

Copy link to clipboard

Copied

Hi Sami -

 

What did it take to create the text layer?

Was it automatically created when you start typing, or did you have to do something else?

 

I moved my play handle past your text layer to create another layer, and I couldn't do it.

Is there some other step that you are doing?

 

Thanks


Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Community Beginner ,
Nov 16, 2020

Copy link to clipboard

Copied

Kevin -

 

If I click on Graphics --> New Layer --> Text

Should it create a text layer for me?  If it should, it's not.

It does nothing for me.

 

Thanks


Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Engaged ,
Nov 16, 2020

Copy link to clipboard

Copied

Nope, nothing special. Just clicked the text tool and started typing on the program monitor.

It seems you have some weird bug on your system.

Anyway, if you can edit the text layer i sent you, just copy paste it and work from it, for the time being.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Adobe Community Professional ,
Nov 16, 2020

Copy link to clipboard

Copied

You should get a new graphics clip added to your timline at the playhead position.

 

At this point, please take a screen grab, drag/drop it into your text reply area so we can see what you're seeing.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Community Beginner ,
Nov 17, 2020

Copy link to clipboard

Copied

I added a link before and it looks like my comments were removed:

 

Here's a video showing what I am doing and what is happening with my Premiere Pro.

https://cloud.degoo.com/share/qbDrOe768rs9e7

 

Thanks


Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 17, 2020 0
Adobe Community Professional ,
Nov 16, 2020

Copy link to clipboard

Copied

Once you click on the T for text tool, you must at least click in the Program monitor before you begin typing. Again, you click once to simply set a point to start a line of text, or click/drag to create a text box for the text to "live" within.

 

If you click the T tool short, then the H, yes you will go immediately to the hand tool. In fact, I have no idea why you would go to the hand tool when you want to type text on the screen.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Community Beginner ,
Nov 16, 2020

Copy link to clipboard

Copied

Hi Neil -

 

I am clicking in the Program Monitor before I am typing.

I am trying to create text within the program monitor. When I press on the Text shortcut, click within the Program Monitor, and start typing... I wanted to start typing "How the system works"

So when I press H for How, the system fails to respond, and the Hand tool gets triggered.

 

So I press, T, click on the Program Monitor to start typing in Text, I press H, and the hand tool gets activated before PP is not accepting my text entry.

 

 

Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Community Beginner ,
Nov 17, 2020

Copy link to clipboard

Copied

To all:

 

For some reason Adobe is not letting me reply to this conversation.

 

I keep adding in a video link that shows my current set up, and what happens when I try to add text.

I have added in several times now, but for whatever reason, Adobe is removing my posts.

 

I'm not sure why, there's nothing in the video except my work environment. There's nothing offensive in it.

But Adobe keeps removing my posts..

 

What gives??

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 17, 2020 0
Community Beginner ,
Nov 17, 2020

Copy link to clipboard

Copied

I will be watching this post for a while and see what happens:

Here's the link to a video showing what I'm doing, and what Premiere Pro is NOT doing when I try and create a text layer.

 

Video of my Premiere Pro test file. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 17, 2020 0
Adobe Community Professional ,
Nov 17, 2020

Copy link to clipboard

Copied

I just watched your vid, though it took like six attempts to play it before it would go past 6 seconds.

 

That is bizarre, I've never had anything like that happen.

 

For anyone else poking into this thread, his video shows him creating two graphics clips on a sequence in the 'normal' way, hitting the T too, and both drag/drop to create a text box and simply drag/enter text to create a line of text. Successfully.

 

But when he goes down the sequence just past those clips, and hits the T for text tool, with no clips selected in the timline, Premiere immediately cuts to the Hand tool! So he can't enter text. Nor draw a text box even.

 

Question of Doug ... you didn't show going into the Essential Graphics panel, Edit tab, and selecting New Item/Text ... does that work or is that also not working for you?

 

And @TrentHappel and @DaciaSaenz  ... help please!

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 17, 2020 0
Community Beginner ,
Nov 17, 2020

Copy link to clipboard

Copied

Hi Neil -

 

I know what you mean about taking several attempts to get it to play properly... When I play the video locally, it's fine, when I use a free service there's issues.. but if it ultimately works, and it's free, who am I to complain too much?? 😉

 

Neil - When I try adding a New Item/Text - same thing. Nothing happens. It doesn't let me add anything, nor does it add a text layer.

 

It does nothing.  For me to get some kind of workaround, I have to drop in a title layer just so I have something to work with. But that takes away from having the ability to simply create a text layer.

 

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 17, 2020 0
Adobe Community Professional ,
Nov 17, 2020

Copy link to clipboard

Copied

That is just bizarre!

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 17, 2020 1
Community Beginner ,
Nov 17, 2020

Copy link to clipboard

Copied

Neil -

 

Welcome to my world!!  I consider myself a rather intelligent person, I can figure most things out.

I went to YouTube to watch a bunch of videos to make sure what I was doing was correct, and then trying out the process, watching more videos, and trying it again... it's frustrating when a simple feature doesn't work.

 

So that's why I'm here trying to figure out what's going on.

 

And let me say to everyone... Thank you for your help.

 

 

Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 17, 2020 1
Community Beginner ,
Nov 23, 2020

Copy link to clipboard

Copied

Hi Neil -

 

Have you heard anything from @TrentHappel and @DaciaSaenz ??

 

I'm curious about this problem and why it's happening. 

Maybe @Kevin-Monahan could help.

Kevin - there is a video which is listed above from Nov. 17th,  that shows what is happening on my system, and how I can't create text.

 

Any and all help would be appreciated.

 

Thanks


Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Adobe Community Professional ,
Nov 23, 2020

Copy link to clipboard

Copied

No I haven't. I know they had an Adobe-wide day or two off last week. Maybe now we'll get something.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Adobe Employee ,
Nov 23, 2020

Copy link to clipboard

Copied

@Doug_E_Fresh @R Neil Haugen Whoa! That is really weird. 

I cannot reproduce this on my end on either Windows or Mac, though. 
Doug, would you be willing to share the project that you demo the bug with in the video? Maybe there is a setting somewhere that is causing havoc.

 

Thanks! 

Dacia

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 1
Community Beginner ,
Nov 23, 2020

Copy link to clipboard

Copied

Hi @DaciaSaenz  -

 

Any project I use.. whether it's new or not has this problem.

 

If you check in the early parts of this message you will see links to other project files.

There should be one of mine that is a brand new project, which doesn't work for me,

 

The link above should give you access to the project in question.

 

Thanks

 

Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Adobe Employee ,
Nov 23, 2020

Copy link to clipboard

Copied

@Doug_E_Fresh 


Your test project doesn't have any text layers in it at all 😞 

I was hoping to get access to the project you use in the video, where you have successfully created a graphic track item and a few layers, and then can't make a text layer when you move the CTI. 

 

Getting a project in this state would be most helpful. 

 

Thanks,

Dacia

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Community Beginner ,
Nov 23, 2020

Copy link to clipboard

Copied

Hi @DaciaSaenz  -

 

The test project was provide by @Sami Succar.

Here's the link to that file:

https://drive.google.com/file/d/1R1HMX4EBDYr1iqXX2RkrNi5bbr9D3rRU/view?usp=sharing

 

So what happened to get you up to speed, I presented a file, Sami was able to make changes to it, and add a text layer, and then I made a movie about trying to use Sami's project, and even though it worked on his machine, the project he sent me wouldn't let me create a new text layer even though it's the same file.

 

Could there be a problem with Core-count on my PC?  I know I'm stretching things, but some program have problems with 18-core / 36 threads.

 

Thanks

 

Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Adobe Employee ,
Nov 23, 2020

Copy link to clipboard

Copied

Thanks @Doug_E_Fresh,

 

Unfortunately, not a single soul can reproduce this issue on our end. 😞

I don't think it's related to the core / thread count, though. 

So now for a few more questions to see what we might be missing.

 

  • Does this issue only occur in 14.6?
  • Are you able to get into this state in 14.5 or any earlier version? 
  • Dumb question but ... Does a re-start help? 
  • Are there any panels launching in the background or on a different monitor that might be stealing focus from the text tool? (I'm stretching too 😬)

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Community Beginner ,
Nov 23, 2020

Copy link to clipboard

Copied

Hi @DaciaSaenz -

 

Thanks for offering more ideas.

 

1) I don't know if it only happens in 14.6.  I don't use PP all the time, but I do update it when I am told to by CC.

2) I will reinstall PP and see if I can use an earlier version and see if I can figure out where the change took place.

3) I've done multiple restarts, and did it as thr first task of the day on my computer, and still had the same issue.

4) I've checked and I don't see any other panels popping up - whether on a different monitor, or behind the program. (Nothing wrong with stretching, I always appreciate any attempt).

 

I will change versions and let you know what happens.

 

Thanks

 

Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Adobe Employee ,
Nov 23, 2020

Copy link to clipboard

Copied

Doug,

Are you running dual monitors? Wondering...

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Adobe Employee ,
Nov 23, 2020

Copy link to clipboard

Copied

Thank you for reporting this to us, Doug_E_Fresh.

Myself and some others on the Graphics/MOGRTS team have been trying hard to repro this on a lot of different systems. I did get the test project you posted and tried it with that too. So far, none of us can repro the same problem you and others have described here, but we want very much to isolate the problem and get it fixed for you all. Is there anything else you (or anyone else on here) can tell me about how to repro this? If you have more than one system available, does it happen anywhere else for you? Does it happen in any other projects for you besides that test.prproj you sent us?

Also, which version of Pr are you currently using? https://community.adobe.com/t5/premiere-pro/faq-how-to-find-the-exact-version-of-premiere-pro-you-re...

Also, on the system where you are seeing the can't-create-text bug, do you have a second monitor set up there?

In the meantime, here are some strange behaviors I noticed with your test project:
(1) In the layer "Text Layer Test" The caret is out of sync with where new characters are actually added. So if you insert the caret between the x and the t in "Text" then add some characters, they will be added between the e and the x instead. There are also other problems with it, like:
-- 3x click in the text layer witht the type tool and only the last chracter is highlighted.
-- You can't insert the caret before the first T.
We are pretty sure this is happening because that text layer was being used woith the Right to Left paragraph direction on at some point. Is that the case as far as you can recall? This problem is probably not related to the can't-create-text problem but it's somethign you'd probably like to be free of. To work around it, highlight all the text in your layer, make a new blank layer, and paste in your text. To avoid it in the future, try not to mix LtR text with RtL paragraph direction. The paragraph direction pref is in Preferences > Graphics and can be turned on/off when the South Asian and Middle Eastern text engine pref is turned on.

(2) If you have a Text + Graphic selected, and if you move the playhead off of the Graphic and then click and drag with the type tool, you will not see the red box draw in while you drag. The red box will be there once you release the click + drag, you just won't see it while you are drawing it. This only happens when a layer is selected in a Graphic that is out of view, and it's not the same as what you reported, but it could look like a faliure to make a new text layer at first.

I hope that was not too much info to ingest at once. We're just really interested in finding an internal repro of this bug so that we can FIX IT already. 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Community Beginner ,
Nov 23, 2020

Copy link to clipboard

Copied

@jstrawn  -

 

Thank you for reaching out.

 

This is a very unique situation and I wish I could provide more infomation.

So let me add in more details.

I will admit it's got to be something on my system, what it is, I don't know.

I just went through uninstalling PP 14.6 and rolled back to 14.0.

I tested it with that version.   Same issue.

I rolled back to 13.15.1 (I think that was the other versiom number) and same thing happened. The text layer would not cooperate.

I opened up the test project, I went the text layer, and I was able to enter in text without any issues.

I moved the playhead to a blank area, and clicked on T to initiate the Type tool, click on the playback area, to start typing, and if I try to type "Hello World", The H is pressed and triggers the Hand tool.

One thing I did notice with the earlier versions (14.0 and before), after exiting the project, they would stay in the Task manager and not close.

 

I moved the PP window to both monitors to test location and to look for any other windows taking the focus.

No other window is there.

1) The text layer was provided for me from another community member who may be in another part of the world.

I am located in California, USA.

 

2) When I am editing the project, No matter what I do, or what layer is active, when I click on T, and then try to type anything, nothing happens.

 

If you want to know the different drivers I have running or you want to know more, please let me know, and I will help you.

If you want to have a Zoom call, and I could show you what happens, I would be happy to do that..

 

 

I have figured a work around, I have to use one of the Essential Graphics title bars to give me a text layer of some sort, and then make adjustments to it.

 

Thanks


Doug

 

 

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0