Premiere Pro 2020 Choppy / Stuttering Playback in Program Monitor ONLY

Explorer ,
Dec 06, 2019 Dec 06, 2019

Copy link to clipboard

Copied

First off, i'm using a Mac Mini (2018) running Mojave.... 3.2 GHz Intel Core i7 w/ 32 GB 2667 MHz DDR4 Memory and a Radeon RX Vega 64 8 GB which is running through a Razor Core X.

 

I've never had any issues editing or playing back footage using Premiere Pro 2019. Occasionally if playing back 6K footage i've had to knock the plaback quality down to 1/2, however this computer runs like a breeze.

 

I've upgraded to PP2020 and since updating I'm experiencing choppy playback when playing back the timeline. No effects. No changes to footage. Doesn't mattter if I playback at 1/8, 1/4 or 1/2....it stutters.

 

If I simply preview the clip from the project in the source monitor (not off the timeline) it plays back perfectly at FULL QUALITY. Once I drag that clip into the timeline and playback the program monitor i've got issues. It's simply unwatchable and impossible to edit with.

 

This is only 1920 x 1080 Pro Res 422 footage, nothing crazy. The project worked perfectly in Premiere Pro 2019 and still does without any stuttering.

 

I have attempted to simply update the project in 2020, as well as importing the legacy project and then finally starting a whole new project and importing the footage again to see if it was a migration issue.

 

Nothing is working.

 

I'll be using PP2019 until this gets sorted, however I'm wondering if anyone else is having similar issues? I've attached a download link to a screen capture of how the issue looks here >>> https://we.tl/t-4uFeLm1gl9Playback Issue - Screen Capture 

 

 

TOPICS
Hardware or GPU, Performance

Views

27.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Sep 10, 2020 Sep 10, 2020
--UPDATE-- FIX Ok so it's taken the better part of a year, endless hopeless conversations begging Adobe to help us only to be hit with the same "you don't have enough RAM" comments..... I seem to have found the fix for my problem which was quite a specific issue. I believe it had more to do with the settings of my LG 34" 5k2k monitor.  So....my normal setting (using EasyRes) was 3840 x 1620 (Retina 2x) which gave the screen a super crisp look with plenty of room in Premiere. Whenever on th...

Likes

Translate

Translate
replies 161 Replies 161
Engaged ,
Dec 06, 2019 Dec 06, 2019

Copy link to clipboard

Copied

Yes!!!!! OMG I Literally just posted about this same thing.PPCC2020 on Mac using "Metal" is horrible, I cant play anything on my timeline without extreme choppy playback. Same clip in source monitor plays perfect. When I switch to "Software Only it works fine. Did not have any of these issue with PPCC 2019 using "OpenCL" And im on a beefy iMac Pro 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2020 Feb 18, 2020

Copy link to clipboard

Copied

Yay! this worked perfectly. Thanks so much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 18, 2020 Feb 18, 2020

Copy link to clipboard

Copied

But keep in mind "Software Only" isn't solving your problem. When you use software Only it dosn't  use your graphics card to render or do any of the lifting. Adobe still needs to fix this ASAP 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 07, 2019 Dec 07, 2019

Copy link to clipboard

Copied

Even though I already Knew, but I have triple confirmed that the issue I am having along with so many others is 100% a PPCC2020 problem. I just installed PPCC2019 back on my machine and it works perfectly. So I really hope you guys at Adobe fix this issues asap because I edit for a living and this version is unusable for me

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 29, 2020 Jan 29, 2020

Copy link to clipboard

Copied

Adobe....it's 30th Jan 2020 - I'm still using PP2019 due to issus that are NOT BEING FIXED. There seems to be good reasons influential Adobe users such as Philip Bloom have openly decided to migrate to your competitors. What is going on with this issue? Or should I just cross my fingers for Premiere 2021? Pathetic.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 06, 2020 Feb 06, 2020

Copy link to clipboard

Copied

Exact same issues here, 2020 in general as a suite has been funky but these issues are literally inabling me to work. 

Did a fresh wipe on my system, used DDU to wipe my GPU and do a fresh install (GeForce 2080) , nothing solves.. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2020 Feb 07, 2020

Copy link to clipboard

Copied

Having the same issue.  Have a high end PC built for editing and even HD files are playing back choppy.  This is nuts, for what I have been paying for this program for years these buggs should not happen.  Especially when older versions worked fine.

Adobe, whats the fix?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2020 Feb 07, 2020

Copy link to clipboard

Copied

Also tested the 2019 version, same issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2020 Feb 07, 2020

Copy link to clipboard

Copied

Maybe not the fix for everyone, but after hours and hours of trying just about everything except for a clean OS install something FINALLY worked.

I changed the Audio Input to No Input.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 07, 2020 Feb 07, 2020

Copy link to clipboard

Copied

Are you just talking about under PREFERENCES and AUDIO? Mine is already selected as NO INPUT and doesn't even have any alternative click-down options.....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 19, 2020 Aug 19, 2020

Copy link to clipboard

Copied

Same here, no fix I've found so far...

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

THANK YOU!!!!!! Worked for me!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2020 Apr 26, 2020

Copy link to clipboard

Copied

THANK YOU SO MUCH!

 

Changing the audio input to no input fixed every issue I've been having with playback in PP 2020 on a Threadripper 3960X build with a 2070 Super.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2020 Jun 06, 2020

Copy link to clipboard

Copied

Same here with new macbook pro 64gig ram.  Jittery with 1280x720 even.  Audio input to none fixed it

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 16, 2020 May 16, 2020

Copy link to clipboard

Copied

Here in May and still had this issue (using windows) and this fix did the trick for me. 

Found under Preferences > Audio hardware

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 28, 2020 May 28, 2020

Copy link to clipboard

Copied

THANK YOU! This worked for me on a windows 10 PC as well. (preferences>audio hardware>no input. I had plugged in an USB HD camera and it changed this audio input setting automatically.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

This worked for me too, July 2020!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 07, 2020 Aug 07, 2020

Copy link to clipboard

Copied

THANK YOU!!!!!!!!!!!!!!!!

 

I did the clean install - what a nightmare - after nothing worked, reloaded sound and video drivers - still the issue.  THANK YOU - your solution worked for me. Wish I had found it sooner. 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 12, 2020 Aug 12, 2020

Copy link to clipboard

Copied

Wow... August 2020 and this fix seems to have worked for me.  Stunned this hasn't been fixed prior to this.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

Oh man, thank you! This worked for me. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 19, 2020 Aug 19, 2020

Copy link to clipboard

Copied

Hi - I have the same issue but it's already at 'No Input', so I can't fix the problem...

 

Was running fine prior to today but all of a sudden choppy playback.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 24, 2020 Aug 24, 2020

Copy link to clipboard

Copied

Where do you find audio input? Can´t see it under preferences>Audio og preference>Audio hardware? There is only output....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2020 Aug 24, 2020

Copy link to clipboard

Copied

On my mac it is under Preferences>Audio Hardware>Default Input  It is the second entry under "Device Class"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2020 Aug 25, 2020

Copy link to clipboard

Copied

ADOBE!!!! You REALLY NEED TO FIX THIS! Worked for me too, thank you very much!!!

 

EDIT: It actually did not after all.. I was having problems with the LUT i use and when applying it, the playback started to stutter. The problem is with the newest update in Premiere 2020, I installed the previous version and got the playback working now properly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines