Highlighted

Premiere Pro 2020 latest upgrade is full of bugs

New Here ,
Mar 30, 2020

Copy link to clipboard

Copied

In order to use Media Encoder 2020, I was forced to upgrade Premiere Pro to its 2020 version. It messed up all my 2019 projects, losing savings and libraries. Once I searched for every single file in my projects, I could go on with working on them. 
Premiere 2020 has too much problems, even with hard working machines. This is embarassing. Not only I'm paying my monthly rent for the suite, but also having continous breakdowns of a software that worked so well over the last months.
And, of course, creative cloud gives no more updates to fix this mess.

TOPICS
Billing, CC FAQ, Creative Cloud, Libraries

Views

298

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Pro 2020 latest upgrade is full of bugs

New Here ,
Mar 30, 2020

Copy link to clipboard

Copied

In order to use Media Encoder 2020, I was forced to upgrade Premiere Pro to its 2020 version. It messed up all my 2019 projects, losing savings and libraries. Once I searched for every single file in my projects, I could go on with working on them. 
Premiere 2020 has too much problems, even with hard working machines. This is embarassing. Not only I'm paying my monthly rent for the suite, but also having continous breakdowns of a software that worked so well over the last months.
And, of course, creative cloud gives no more updates to fix this mess.

TOPICS
Billing, CC FAQ, Creative Cloud, Libraries

Views

299

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 30, 2020 0
Most Valuable Participant ,
Mar 30, 2020

Copy link to clipboard

Copied

This is a public forum with "some" Adobe staff participation, use the links below to make a report or request
-for Video & Audio & Animator programs https://adobe-video.uservoice.com/
-https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 30, 2020 0
Adobe Community Professional ,
Mar 30, 2020

Copy link to clipboard

Copied

I have both 2020 and 2019 Premiere and AME installed so you could go back to 2019

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 30, 2020 0
Adobe Community Professional ,
Mar 30, 2020

Copy link to clipboard

Copied

Most of us didn't have such issues when starting out in 2020 ... so it's more accurate to say that on your machine, there are such issues.

 

First thing to suggest is ... never ever simply "open" a project from an older version into a newer one (major versions, 2019-2020, or 13.x to 14.x) ... not ever.

 

Always migrate forward by creating a new project in the new version, then in that project in the Media Browser panel, navigate to and import the previous project file's assets. This gets the meta from the older version into the newer one with far more consistency and accuracy. And probably would have reduced your woes significantly if that is not the process you used.

 

Besides the migration trouble, what other issues are you having? Give us the details, and we may well be able to help. There are some things that are problems of course, always will be ... but 2020 for many of us is rocking along pretty good.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 30, 2020 0
New Here ,
Nov 12, 2020

Copy link to clipboard

Copied

I completely agree, it's close to unusable.

Playback has always been completely fine for me, now as soon as I put a basic log to rec709 conversion LUT, everything lags.
Even if I create low-res proxies, everything lags like crazy.
If I try to open older projects, they don't open.
When I move around the menus, everything is slow AF.

 

I truly wonder what I'm paying a subscription for.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2020 0