Highlighted

Premiere Pro 2020 timeline lag on iMac Pro 27"

Community Beginner ,
Dec 02, 2019

Copy link to clipboard

Copied

Since the Premiere Pro CC 2020 update (version 14.0.0 (build 572)), timeline updates are much slower.

 

Scrubbing the timeline sticks and jumps. Doesn't matter if footage has no adjustment/ effects applied or not. Although, adding effects (lumetri color) makes the lag worse.

Adjusting scale and position on clips in timeline from effects panel takes 3 - 5 seconds to update new parameters. Before update, adjustments were in real-time.  Very frustrating when adjusting 4k in a 1080 timeline.

 

All premiere projects are being effected by the lag after the update.

 

Please advise.

 

iMac Pro (2017) 27"

OS: Mojave v10.14.6

CPU: 3.2GHz Intel Xeon W

RAM: 64 GB 2666 MHz DDR4

Startup: Mac HD

Graphics: Radeon Pro Vega 64 16368 MB

 

Media file type: mxf

Color Space: S-log3

Video Info: 3840 x 2160 (1.0)

FPS: 25fps

Footage Source: Sony FS5 & Sony A7iii

Topics

Error or problem, Freeze or hang, Performance

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Pro 2020 timeline lag on iMac Pro 27"

Community Beginner ,
Dec 02, 2019

Copy link to clipboard

Copied

Since the Premiere Pro CC 2020 update (version 14.0.0 (build 572)), timeline updates are much slower.

 

Scrubbing the timeline sticks and jumps. Doesn't matter if footage has no adjustment/ effects applied or not. Although, adding effects (lumetri color) makes the lag worse.

Adjusting scale and position on clips in timeline from effects panel takes 3 - 5 seconds to update new parameters. Before update, adjustments were in real-time.  Very frustrating when adjusting 4k in a 1080 timeline.

 

All premiere projects are being effected by the lag after the update.

 

Please advise.

 

iMac Pro (2017) 27"

OS: Mojave v10.14.6

CPU: 3.2GHz Intel Xeon W

RAM: 64 GB 2666 MHz DDR4

Startup: Mac HD

Graphics: Radeon Pro Vega 64 16368 MB

 

Media file type: mxf

Color Space: S-log3

Video Info: 3840 x 2160 (1.0)

FPS: 25fps

Footage Source: Sony FS5 & Sony A7iii

Topics

Error or problem, Freeze or hang, Performance

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Dec 02, 2019

Copy link to clipboard

Copied

Hi there!

Sorry for the frustrating experience.


Are you using any third-party plugins? If yes, remove them temporarily.

 

You may try to delete media cache files to resolve this issue. https://community.adobe.com/t5/premiere-pro/faq-how-to-clean-delete-or-trash-media-cache-files/td-p/...

 

Let us know if it works.

 

Thanks,

KRawat

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Ridaz LATEST
New Here ,
Jul 11, 2020

Copy link to clipboard

Copied

Adobe Premiere Pro 2020 est juste innutilisable!
C'est une mise a jour raté!!! Comment revenir à 2019????

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Dec 02, 2019

Copy link to clipboard

Copied

Hi!

 

Shot in the dark; try to deactivate 'composite Preview during trim' and 'Show Audio Waveform'

 

clicking on the little wrench in the timeline window. I've had issues with that lately. 

 

Also: Does this also happen if you have a timeline ONLY with one of the two codecs?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 06, 2019

Copy link to clipboard

Copied

Hi thanks for your reply, unchecking both of those make no difference. And it’s the same with whatever codec I’m using.

Anything in the timeline window be it swapping between sequences or clicking on different clips has around a 1-second delay between the click and the action occurring.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 06, 2019

Copy link to clipboard

Copied

I have three sequences open on mine, and the two B Roll sequences have minimal lag; however, my master sequence incorporating all three codecs (GH5 DCI 422, GH5 1080 422, and DJI Mavic Air) is virtually unusable.  This wasn't a problem a few days ago.  It just all of a sudden happened today.  Any thoughts?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Dec 06, 2019

Copy link to clipboard

Copied

Hey Ross,

Sorry for the issue. Your project sounds like it could be corrupt. It can happen when updating complex project from one version to the next. You may be able to fix it by creating a new project in 14. Then import your project created in version 13.x into it. Is it possible to try that? What happens then?

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 09, 2019

Copy link to clipboard

Copied

Hi Kevin,

 

Thanks for your reply. It was a new project I made in 14. I did try importing it into a new one anyway, but it didn't fix the issue.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 09, 2019

Copy link to clipboard

Copied

I think I've worked it out!

It seems to have been the fact that after intalling Premiere 2020, the Lumetri/Essential Graphics and Essential Sound windows were all open to the right of the workspace, so whenever I was clicking on the timeline or a clip, it was cycling through those windows and the lag was caused by loading the relevant settings for whatever I clicked on.

This didnt happen in Premiere pro 2019 so I guess that is something that has been changed? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...