Premiere Pro 2020 won't launch

Community Beginner ,
Dec 21, 2019

Copy link to clipboard

Copied

Premiere Pro 2020 is installed on my Dell laptop (Windows 10).  Recently, it has nearly stopped launching.  I say "nearly" because maybe 1/30 times it will launch -- it's completely unpredictable. 

 

When I launch I always make sure that a.) I am logged into CC and b) no other applications are running. 

 

I have tried different ways to launch Premiere:

  1. double click the .exe file in the directory
  2. clicking the icon in the start menu (see attached file)
  3. by opening a .prproj file
  4. by selecting a video file and "open with"


None of these has worked.  Is this operator error?  Is anyone experiencing this problem and/or know how to fix it?

TOPICS
Crash, Error or problem, Performance

Views

17.9K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Dec 21, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
May 10, 2020

Copy link to clipboard

Copied

i have the same issue

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jul 07, 2020

Copy link to clipboard

Copied

I was having the same/similiar problem. It was opening, then not opening. Once it opened, then closed when tried exporting, and then wouldn't open again. I tried uninstalling and reinstalling but no improvement. For me, what finally worked was when I opened Task manger and saw the Premiere Pro process was still running. I ended just that one process, closed Task manger and tried again- voila, Premiere Pro came right up. It's not a fix, but it's a suitable work around for now. Hope this helps...

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 06, 2020

Copy link to clipboard

Copied

Thank you, this worked for me as well!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Mar 04, 2021

Copy link to clipboard

Copied

I just had to make an account to this site just so I could like and reply to this comment. Thank you so much doing this completely fixed the problem

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jul 25, 2020

Copy link to clipboard

Copied

i have the same issue

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Sep 02, 2020

Copy link to clipboard

Copied

I have the same issue too!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 09, 2020

Copy link to clipboard

Copied

I got same issue after I reset windows 10, and installed the Adobe Premier, 2020 ver 14.4. Many time unstalled and installed, didn't work. Then via creative cloud I installed 13.x ver, afater I had the issue while opening the app, following, wmvcor.dll, insisting me to install, windows media player, and windows update, media feature pack for windows 10 n (may 2020) download, after all, I was able to open Adobe premvier 13.x, then via creative cloud, upgrade to 14.4 x, after the upgrade. Adobe premier is opened.

 

In short..

So, after windows 10 reset installing adobe premier freshly, will not open and will not throw any error. 13.x installation only gave error and clue..;

 

Hope this will give some clue to you....;

 

I am new to Adobe Premier..

 

Cheers

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Sep 04, 2020

Copy link to clipboard

Copied

I have the exact same issue please let me know if anyone finds out how to fix this

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 18, 2020

Copy link to clipboard

Copied

Same issue!  Running Windows 10. Adobe hasn't done crap about it. Why do I pay them so much each year?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Sep 21, 2020

Copy link to clipboard

Copied

I have the same issue. I am using it on a new machine that was issued to me (a Dell Windows 10 64-bit machine and have Premiere Pro version 14.4 installed).  When I open it, either from Creative Cloud or the shortcut icon, it starts to open but it gets hung up.  There is a message that says "Loading ImporterQuickTime.prm", but not sure if that's what is holding it up.  It gets hung up for at least 10 minutes before I kill the program via Task Manager.  Any idea what is going on?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 04, 2020

Copy link to clipboard

Copied

I have the exact same problem with Quicktimeloader loading indefinately. I havent been able to find a solution anywhere else. Glad to know I'm not entirely alone in this! 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 01, 2020

Copy link to clipboard

Copied

I also have the exact same issue where I am running Windows 10 Pro version 1909 OS Build 18363.1198 on a Dell Precision 7710 with 32 GB RAM and when I start up Adobe Premiere Pro 2020 it never completes the load and seems to hang on the "Loading Importer QuickTime.prm" and never completes loading. In the Task Manager, it says "Not Responding" and will never load. It looks like I will have to uninstall Premiere Pro and load a previous version as PP 2020 is having issues. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Oct 05, 2020

Copy link to clipboard

Copied

have the same problem here - as well with AE and ME. Please fix that in the next update Adobe!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Oct 05, 2020

Copy link to clipboard

Copied

Seems that the program won´t quit proper, because it´s still running in the task manager. So, please Adobe Dev Team: fix it!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 13, 2020

Copy link to clipboard

Copied

I was editing fine, then Premiere crashed last night. Tried openning it today and nothing is happening. My other Adobe programs are working fine but nothing when I attempt to open Premiere. Can't find a fix. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 18, 2020

Copy link to clipboard

Copied

Same issue!  Running Windows 10. Adobe hasn't done crap about it. Why do I pay them so much each year?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Oct 19, 2020

Copy link to clipboard

Copied

Omg so annoyed with Adobe.  So, so, so, sick and tired of the glitches, the daily updates that do nothing for the customer but install another bloat wear, the fonts that never work, and now this.  SO SICK OF YOU

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Oct 19, 2020

Copy link to clipboard

Copied

Notice how there are never any Adobe tech people on these forums. This is a place where they send us to vent and nothing ever gets resolved.  And to login to the forums I had to verify my identity by 2 factor authentication.

Oh really Adobe!  Because people frequently break into my Adobe account to make false reports about your glitchy software! That's why you have to stick yet another time wasting step to login to my account where I have to verify a code from my email just to be able to tell you how much you suck. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 02, 2020

Copy link to clipboard

Copied

There are adobe employees posting here, maybe not as often as we'd all like but they are definitely a consistent presence here. 

 

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 31, 2020

Copy link to clipboard

Copied

I have uninstalled re-installed, rebooted, opened as Admin. and had some serious prayer. I noticed when I end the task and then try to reinstall CC states Premiere Pro needs to "Save your work and close..." Years ago I had a simmular problem with Apple. Adobe Photoshop would hold on to RAM each time I closed the program. When I reported the problem Apple told me they were aware an would fix. Now on PC this challenge arrose after the 10/15 - 2020-10 Cumulative update fr Windos 10 Version 2004 for x64 (KB4579311). I've seen this has been an issue for a while. Premier trys to open but when it gets to the Dynamic Link it stops. I've also noticed some Dynamic Link issues between AE & ME. Can't import project into ME either thru link in AE menu or accessing the file within ME. To quote Mr. Spock "Facinating."  

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Oct 31, 2020

Copy link to clipboard

Copied

Please Give us detailed specs of your system, including your storage configuration

 

Also, do you have any plugins installed? if so, Premiere load screen will give you hint about which plugin is causing the freeze.

 

If Nothing works, Uninstall using the Adobe CC Cleaner: https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 31, 2020

Copy link to clipboard

Copied

I do not have any plug-ins and everything has been operating fine until last week when the Windows 10 update referenced in my previous post loaded. After writing my post I tried to uninstall PR and the error screen stated PR was still running. Under the Task Mgr Processes tab there was no PR icon. I clicked the Details tab in the Task Manage and saw PR was stopped. I right clicked the PR icon and ended the task. I completed the uninstall and reinstalled PR. Click on the PR icon in the program list and it failed. I then tried to open it as Admin. Again failed. I went back to the Task Mgr. Processes tab no PR, Details tab PR stopped. Ended the task in Details. Opened the program as Admin and SUCCESS!!!!! Weird. 2019 works fine and have been using the same system for over year.  

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Nov 02, 2020

Copy link to clipboard

Copied

I also discovered that this could happen with PS and AE. When PS would not open I found four Photoshop.exe files open under the Details tab. Once I ended them PS opened. HUH!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more