Premiere Pro CC 2019 not exporting Alpha channel that is connected directly to After Effects CC 2019. Problem with dynamic link?

Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Hi all,

I am currently working on a project on Premiere that has a few graphical elements linked to After Effects via the dynamic link. I've been working on the project in Premiere CC 2018 for the last few days without any issues during export but yesterday I decided to update to the new 2019 and since then Premiere is not exporting the Alpha channel on the dynamic linked files.

The weirdest thing is that it looks fine on the preview monitor and also when I pre-render it but it is wrong when it is exported. Check this out -

Screen Shot 2018-10-18 at 09.39.58.png - pre-rendered Preview on Premiere CC 2019 where the footage on the sides and the separation lines are from After Effects; the footage in the middle, the logo and the circular graphical elements are in Premiere.

And this is how it exports it -

Screen Shot 2018-10-18 at 09.41.58.png - for some reason it removes the footage which is in my Premiere timeline but leaves the graphical elements.

I tried exporting in few different formats and only the QuickTime actually exported it correctly, however as we know the .mov files are really big, so this doesn't work for me. I tried h.264 and h.265 but both exported it wrong.

I found a few work arounds like exporting my files in After Effects first and that import them in Premiere. This seems to work but I wanted to report this glitch as (at least to me) it doesn't make any sense. I hope the guys in adobe can work on this and fix it with the next update. Let me know if you need more info!

Cheers!

Views

3.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Oct 18, 2018 Oct 18, 2018
if render max depth is selected in export settings and/or sequence settings. uncheck it and see if that works... Appears to be a glitch

Likes

Translate

Translate
Adobe Employee ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Hi valentinv,

Sorry to hear this. I understand that you are getting a black background with your alpha channel files in Adobe Premiere Pro.

We're investigating this issue. Until then, you can try this workaround.

FAQ: How to change the Video Renderer in Premiere Pro?

I regret the inconvenience caused.

Thanks,

Shivangi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 25, 2021 Feb 25, 2021

Copy link to clipboard

Copied

Almost three years later and the problem still exists. What have you guys been doing in the meantime?! I have a rendered file from AE here, made some sound design and adjustments and try to re-export it via Premiere. Whatever I do, the Alpha channel is always lost. Tried the workaround unchecking max depth - no good. MXF, ProRes4444, 8 or 16bpc + Alpha. Always solid black. I'm more than annoyed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

if render max depth is selected in export settings and/or sequence settings. uncheck it and see if that works... Appears to be a glitch

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 19, 2018 Oct 19, 2018

Copy link to clipboard

Copied

adobe100000000,  I just tested it and you are actually right! I always sellect the max depth render and just tried it without it and it worked perfectly!

Thanks for the response and I hope this gives a clue to the adobe team (shivangi gupta) on where the problem actually sits. Cheers!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 19, 2018 Oct 19, 2018

Copy link to clipboard

Copied

Hi Mike,

Thanks for sharing this solution.

Shivangi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 25, 2021 Feb 25, 2021

Copy link to clipboard

Copied

LATEST

A workaround is NOT a solution! Plus it doesn't work for me. Two and a half years later Adobe was still unable to fix this major problem. Shame on you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines