Premiere Pro CC 2021 Playback Issues

New Here ,
Jul 14, 2021 Jul 14, 2021

Copy link to clipboard

Copied

Hey everyone, I've started editing videos again on Premiere Pro and I am getting serious playback/display lag. (Similar to the situation depicted in this forum: https://community.adobe.com/t5/premiere-pro/premiere-usuably-slow-response-time/td-p/12030167) 

 

However, even after following these steps and many others including

Global FX Mute

Thumbnail View > List View

Disabling Hardware Decoding

Full Preview > 1/4 Quality

Cache Purge

Max RAM allowance

Optimizing rendering for performance

(No difference with these^)

 

The footage I am trying to edit is 1920x1080 at 30 fps with a codec of H.264

 

Specs:

MacBook Pro 2019

6 Core i7

16GB RAM

AMD Radeon Pro 5500M 8 GB

OS: Big Sur 11.3.1

 

Any help would be greatly appreciated

TOPICS
Crash, Editing, Error or problem, Formats, Freeze or hang, Hardware or GPU, Performance, User interface or workspaces

Views

79

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Explorer , Jul 14, 2021 Jul 14, 2021
I don't necessarily have a fix to the age-old "why is my performance bad" question, but, try converting your source footage to ProRes and re-import. Since the machine will no longer have to create P or B frames, should play back nice and smooth. If that is the case, I'd recommend proceeding with a proxy workflow when you edit on that machine (or just transcoding before starting your projects). If you still get lousy playback, then definitely revisit your software/hardware settings, etc. As an a...

Likes

Translate

Translate
Explorer , Jul 14, 2021 Jul 14, 2021
Glad that helped! Honestly its a question of filesize - if you can tolerate lower-res stuff I'd go with that in order to maximize your HD space. Check out Adobe's article on ingest/proxy workflows here: https://helpx.adobe.com/premiere-pro/using/ingest-proxy-workflow.htmlAnd honestly, if that doesn't make sense to you, just look around on YouTube - there's a billion free tutorials that all approach and explain a bit differently, I'm sure you can find one that clicks with you. But if you set it u...

Likes

Translate

Translate
New Here ,
Jul 14, 2021 Jul 14, 2021

Copy link to clipboard

Copied

Update, I updated macOS to the latest version, still no change 😞

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 14, 2021 Jul 14, 2021

Copy link to clipboard

Copied

I don't necessarily have a fix to the age-old "why is my performance bad" question, but, try converting your source footage to ProRes and re-import. Since the machine will no longer have to create P or B frames, should play back nice and smooth. If that is the case, I'd recommend proceeding with a proxy workflow when you edit on that machine (or just transcoding before starting your projects).
If you still get lousy playback, then definitely revisit your software/hardware settings, etc.

As an aside, looks like trashing the Adobe preferences worked as a solution in the thread you linked - have you tried that?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2021 Jul 14, 2021

Copy link to clipboard

Copied

Hi, trashing preferences didn't work at all. I'll try to transcode to ProRes and I'll see how that works. It's strange cause I used this exact workstation before and I had 0 issues (even editing 4K was working well). By chance, do you have a guide that you know of for automatic transcode to prores on ingest? I've never really done it before.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2021 Jul 14, 2021

Copy link to clipboard

Copied

ProRes worked! Even though it was a long transcode, I can still finally scrub through the footage. I have a question now, between the proxy presets of ProRes Medium v ProRes Low, what do you recommend. Sorry for asking this but I really have no experience with proxies.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 14, 2021 Jul 14, 2021

Copy link to clipboard

Copied

Glad that helped! Honestly its a question of filesize - if you can tolerate lower-res stuff I'd go with that in order to maximize your HD space.
Check out Adobe's article on ingest/proxy workflows here: https://helpx.adobe.com/premiere-pro/using/ingest-proxy-workflow.html

And honestly, if that doesn't make sense to you, just look around on YouTube - there's a billion free tutorials that all approach and explain a bit differently, I'm sure you can find one that clicks with you. But if you set it up right it's a fairly painless process, outside of waiting for the actual transcodes to finish.

 

Only other thought to your current situation would be to try a completely fresh install of Premiere (uninstall, restart, reinstall). Can't guarantee that'll help, but I had a 2018 MBP that went from a bit sluggish with 4K footage to completely unbearable... only thing that helped there was a fresh install of MacOS and then reinstalling Premiere, which obviously is a huge pain. Hopefully you don't get to that point!

 

As a last thought... should've said it before, but I made the assumption - you've tried restarting your machine? If not, before doing anything else, definitely try a complete shutdown and then power your machine back on. If it asks if you'd like to open programs up on restart, click No/Ignore or whatever the option is.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2021 Jul 14, 2021

Copy link to clipboard

Copied

LATEST

As of now, the proxies are working great, ProRes has made it so much better. However, if it gets way worse, I will definitely try the reinstall.

Thank you so much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines