Highlighted

Premiere Pro Display Error/Glitch

New Here ,
Aug 13, 2020

Copy link to clipboard

Copied

glitch that appears in all my footageglitch that appears in all my footagegeneral settingsgeneral settings

I am having an issue with the playback video on Premiere, I have High Res 4k Footage with Proxies and still get this glitchy effect and if I switch to Software only, forget about it there is a delay with everything. From playback, to throwing an effect on the footage, to even adding an overlay. I haven't had an issue at all with Premiere in the past 5 years of using it and now after an update this happens. Makes absolutely no sense whatsoever to me and it feels like Adobe has no fix to the issue. I don't want to leave Adobe for DaVinci Resolve but this is ridiculous, here are my specs:

 

MOBO: X399 Phantom Gaming 6

CPU: Threadripper 2950x

GPU: Rx 5700 xt

RAM: 64gb DDR4-3600mhz

PSU: 850w 

 

Before anyone starts their "did you check this thread" or "this was already answered here" read below.

- Already tried uninstalling/reinstalling

- Already tried reverting back to previous versions

- Already tried using Premiere BETA and same issue

- Already tried switching from OpenCL to Mercury Playback Engine Software Only

 

Topics

Editing, Error or problem, Hardware or GPU, User interface or workspaces

Views

27

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Pro Display Error/Glitch

New Here ,
Aug 13, 2020

Copy link to clipboard

Copied

glitch that appears in all my footageglitch that appears in all my footagegeneral settingsgeneral settings

I am having an issue with the playback video on Premiere, I have High Res 4k Footage with Proxies and still get this glitchy effect and if I switch to Software only, forget about it there is a delay with everything. From playback, to throwing an effect on the footage, to even adding an overlay. I haven't had an issue at all with Premiere in the past 5 years of using it and now after an update this happens. Makes absolutely no sense whatsoever to me and it feels like Adobe has no fix to the issue. I don't want to leave Adobe for DaVinci Resolve but this is ridiculous, here are my specs:

 

MOBO: X399 Phantom Gaming 6

CPU: Threadripper 2950x

GPU: Rx 5700 xt

RAM: 64gb DDR4-3600mhz

PSU: 850w 

 

Before anyone starts their "did you check this thread" or "this was already answered here" read below.

- Already tried uninstalling/reinstalling

- Already tried reverting back to previous versions

- Already tried using Premiere BETA and same issue

- Already tried switching from OpenCL to Mercury Playback Engine Software Only

 

Topics

Editing, Error or problem, Hardware or GPU, User interface or workspaces

Views

28

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 13, 2020

Copy link to clipboard

Copied

That is nearly always a GPU issue, either the GPU is not working (or usable for Premiere) or the driver has a problem.

 

As it's allowing you to select the OpenCL, the GPU is probably working ... have you tried changing drivers?

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 13, 2020

Copy link to clipboard

Copied

Yes, I have changed the drivers back and forth, I might have to order an NVidia GPU I guess which is absurd that this GPU just stopped working with Premiere after the 14.2 update.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 13, 2020

Copy link to clipboard

Copied

Hey, that's a right pain in the tushie. Dang. Don't suppose that Metal is an option? (Not that familiar with the AMD GPUs.)

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...