Premiere Pro Glitches after adding a certain number of clips

New Here ,
Feb 02, 2021

Copy link to clipboard

Copied

So several of my most recent projects have been plagued with glitches, I can't switch to different tabs, the playheads wont move, the in and out points wont show, the lag makes it almost impossible to edit. When I press something either it takes forever to function or nothing happens at all. I have to constantly minimize and maximize the window in order for any of my commands to process, and I'm not sure why. 

 

I just started a new project and everything was running smoothly until I imported another video clip and then everything went downhill from there. All of the glitches listed above happpened immeditaely aftwards, when i remove the clip from the project everything returns to normal immediately. I tested out what would happen if I added an ajustment layer and the exact same thing happened.

 

I really don't know what to do at this point becasue I tried clearing the media cache, uninstalling and reinstalling, it has 13 gigs of memory allocated just to Preimere. 

TOPICS
Editing, Error or problem, Freeze or hang, Performance

Views

90

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 02, 2021

Copy link to clipboard

Copied

What are the complete computer specs, including hard drives (how many, what kind, what is on each, what capacity, and how full)?

If NVIDIA, make sure to use the latest Studio Driver from NVIDIA (NOT the Game Driver).

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
BenDavid5EF8 AUTHOR LATEST
New Here ,
Feb 02, 2021

Copy link to clipboard

Copied

Let me know if you need anything else, thanks in advance.

 

------------------
System Information
------------------
Time of this report: 2/2/2021, 20:32:59
Machine name: LAPTOP-G9K5V207
Machine Id: {9ECF737C-9926-408C-9F9E-35B2DEEE4704}
Operating System: Windows 10 Home 64-bit (10.0, Build 19041) (19041.vb_release.191206-1406)
Language: English (Regional Setting: English)
System Manufacturer: Razer
System Model: Blade
BIOS: 1.05 (type: UEFI)
Processor: Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz (12 CPUs), ~2.6GHz
Memory: 16384MB RAM
Available OS Memory: 16282MB RAM
Page File: 10170MB used, 9696MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 192 DPI (200 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Supported
DirectX Database Version: 1.1.9
DxDiag Version: 10.00.19041.0546 64bit Unicode

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more