Highlighted

Premiere Pro Glitching Videos in Preview and Export - Source Footage Fine

New Here ,
Aug 06, 2019

Copy link to clipboard

Copied

After being sat on 'thank you for your patience' all day on the Adobe live chat, I thought I'd try my luck here.

 

I'm having a recurring issue with Premiere Pro where it randomly decides to glitch my footage. The raw footage has no issues at all with it, completely smooth and no glitching, but when I try to put them into Premiere to edit random glitches start to occur.

 

There is no pattern to the glitches, but once it decides that this part of my footage is going to have a glitch there is no way to stop it, even deleting and re-inserting the footage.

 

I have had a look around online to try and find some form of answer or reason as to why this is happening, and that brought me to two resolutions: delete the media cache files and update Premiere Pro. Well, the cache files are gone and the software is all up to date, but the glitches remain.

 

Now, the oddest thing is that sometimes, in the playback editor, the glitches are gone, and I think the problem is solved. But as soon as i export the glitches are back, right where they randomly showed up. This is hugely frustrating and, after having lost nearly 24 hours on this stupid problem I'd really like some form of answer, solution, or just someone online who can help me sort this out.

 

To clarify: Premiere is up-to-date on my computer, the RAW files are clean, the media cache has been deleted, sometimes I can get rid of the glitches in preview playback, but they are always present in the exported file.

 

Any help on this would be gratefully appreciated.

 

[title edited by mod, raw files are a different format to iphone footage]

 

 

Moderator: Moved from Adobe Creative Cloud to Premiere Pro

So after speaking with the Adobe team I finally got this sorted out. I, like you, am using iPhone footage and it is this that is causing the glitches.

I was told that the format of the HEVC footage (iPhone footage) causes Premiere Pro to drop frames and put those glitches into the footage even though the raw footage is fine. These glitches, although you may be able to temporarily remove them from the timeline, remain in the export.

Luckily the fix is simple. All you need to do is take all iPhone footage (HEVC) into Adobe Media Encoder and export the file format to H.264 and preset to "Match Source - High Bitrate". The new .mp4 H.264 file should remove/avoid any glitches and solve your issue.

For a project that you've already built, you don't need to go through and redo the whole edit as you can replace the HEVC with the H.264 within Premiere Pro. Follow the steps below to do that:

In the project media panel:

Double click on the HEVC footage so it opens in the source preview panel.

Right click, and select replace footage.

Find the new H.264 .mp4 version of the video and press open.

The source HEVC file has now been replaced with the H.246 file.

In the timeline:

Select the clip(s) of the file that you have used in the edit and highlight them.

Right click, and select Render and Replace.

Don't change any of the settings and press OK.

Leave this for however long it takes (the longer the clips or the more effect editing you have done, the longer this will take).

This should relieve the issue. It worked for me on the one project I tried it on, so hopefully it's a permanent fix.

Another thing the Adobe team suggested I do is change the project settings so that Premiere does the encoding as soon as you load in HEVC files. To do that:

Go File > Project Settings > Ingest Settings

Click the tick box to activate Ingest

On the drop down, select Transcode.

Change the preset to Match Source - H.264 High Bitrate.

Then click OK.

From my experience of starting new projects, this doesn't look like a new setting so make sure you change it every time you start a new project. If that doesn't work, just go back through the steps above to encode the footage before you import it into the project. A bit long winded, but saves time doing it at the start rather than having to go back through at the end and render and replace all the footage post edit.

Hope this helps!

TOPICS
Export, Import

Views

20.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Pro Glitching Videos in Preview and Export - Source Footage Fine

New Here ,
Aug 06, 2019

Copy link to clipboard

Copied

After being sat on 'thank you for your patience' all day on the Adobe live chat, I thought I'd try my luck here.

 

I'm having a recurring issue with Premiere Pro where it randomly decides to glitch my footage. The raw footage has no issues at all with it, completely smooth and no glitching, but when I try to put them into Premiere to edit random glitches start to occur.

 

There is no pattern to the glitches, but once it decides that this part of my footage is going to have a glitch there is no way to stop it, even deleting and re-inserting the footage.

 

I have had a look around online to try and find some form of answer or reason as to why this is happening, and that brought me to two resolutions: delete the media cache files and update Premiere Pro. Well, the cache files are gone and the software is all up to date, but the glitches remain.

 

Now, the oddest thing is that sometimes, in the playback editor, the glitches are gone, and I think the problem is solved. But as soon as i export the glitches are back, right where they randomly showed up. This is hugely frustrating and, after having lost nearly 24 hours on this stupid problem I'd really like some form of answer, solution, or just someone online who can help me sort this out.

 

To clarify: Premiere is up-to-date on my computer, the RAW files are clean, the media cache has been deleted, sometimes I can get rid of the glitches in preview playback, but they are always present in the exported file.

 

Any help on this would be gratefully appreciated.

 

[title edited by mod, raw files are a different format to iphone footage]

 

 

Moderator: Moved from Adobe Creative Cloud to Premiere Pro

So after speaking with the Adobe team I finally got this sorted out. I, like you, am using iPhone footage and it is this that is causing the glitches.

I was told that the format of the HEVC footage (iPhone footage) causes Premiere Pro to drop frames and put those glitches into the footage even though the raw footage is fine. These glitches, although you may be able to temporarily remove them from the timeline, remain in the export.

Luckily the fix is simple. All you need to do is take all iPhone footage (HEVC) into Adobe Media Encoder and export the file format to H.264 and preset to "Match Source - High Bitrate". The new .mp4 H.264 file should remove/avoid any glitches and solve your issue.

For a project that you've already built, you don't need to go through and redo the whole edit as you can replace the HEVC with the H.264 within Premiere Pro. Follow the steps below to do that:

In the project media panel:

Double click on the HEVC footage so it opens in the source preview panel.

Right click, and select replace footage.

Find the new H.264 .mp4 version of the video and press open.

The source HEVC file has now been replaced with the H.246 file.

In the timeline:

Select the clip(s) of the file that you have used in the edit and highlight them.

Right click, and select Render and Replace.

Don't change any of the settings and press OK.

Leave this for however long it takes (the longer the clips or the more effect editing you have done, the longer this will take).

This should relieve the issue. It worked for me on the one project I tried it on, so hopefully it's a permanent fix.

Another thing the Adobe team suggested I do is change the project settings so that Premiere does the encoding as soon as you load in HEVC files. To do that:

Go File > Project Settings > Ingest Settings

Click the tick box to activate Ingest

On the drop down, select Transcode.

Change the preset to Match Source - H.264 High Bitrate.

Then click OK.

From my experience of starting new projects, this doesn't look like a new setting so make sure you change it every time you start a new project. If that doesn't work, just go back through the steps above to encode the footage before you import it into the project. A bit long winded, but saves time doing it at the start rather than having to go back through at the end and render and replace all the footage post edit.

Hope this helps!

TOPICS
Export, Import

Views

20.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 06, 2019 11
LEGEND ,
Aug 06, 2019

Copy link to clipboard

Copied

Try Step 2B below.  Report back.

Unofficial Premiere Pro Troubleshooting Guide

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2019 0
New Here ,
Aug 07, 2019

Copy link to clipboard

Copied

I'm having the same issue, except that I still the glitches on the playback and also as I exported the media out. What type of format are you video files?? .mpg, .mp4?? I still haven't solve my issue... I'm working with an .mov (iphone x footage) and converted to all kinds of formats and still glitching, not and idea what it may be I have also clean the media cache and I'm running the latest Premiere Pro software, restarted my computer and closed all the tabs I had open and nothing..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2019 0
New Here ,
Aug 08, 2019

Copy link to clipboard

Copied

So after speaking with the Adobe team I finally got this sorted out. I, like you, am using iPhone footage and it is this that is causing the glitches.

I was told that the format of the HEVC footage (iPhone footage) causes Premiere Pro to drop frames and put those glitches into the footage even though the raw footage is fine. These glitches, although you may be able to temporarily remove them from the timeline, remain in the export.

Luckily the fix is simple. All you need to do is take all iPhone footage (HEVC) into Adobe Media Encoder and export the file format to H.264 and preset to "Match Source - High Bitrate". The new .mp4 H.264 file should remove/avoid any glitches and solve your issue.

For a project that you've already built, you don't need to go through and redo the whole edit as you can replace the HEVC with the H.264 within Premiere Pro. Follow the steps below to do that:

In the project media panel:

Double click on the HEVC footage so it opens in the source preview panel.

Right click, and select replace footage.

Find the new H.264 .mp4 version of the video and press open.

The source HEVC file has now been replaced with the H.246 file.

In the timeline:

Select the clip(s) of the file that you have used in the edit and highlight them.

Right click, and select Render and Replace.

Don't change any of the settings and press OK.

Leave this for however long it takes (the longer the clips or the more effect editing you have done, the longer this will take).

This should relieve the issue. It worked for me on the one project I tried it on, so hopefully it's a permanent fix.

Another thing the Adobe team suggested I do is change the project settings so that Premiere does the encoding as soon as you load in HEVC files. To do that:

Go File > Project Settings > Ingest Settings

Click the tick box to activate Ingest

On the drop down, select Transcode.

Change the preset to Match Source - H.264 High Bitrate.

Then click OK.

From my experience of starting new projects, this doesn't look like a new setting so make sure you change it every time you start a new project. If that doesn't work, just go back through the steps above to encode the footage before you import it into the project. A bit long winded, but saves time doing it at the start rather than having to go back through at the end and render and replace all the footage post edit.

Hope this helps!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2019 2
New Here ,
Sep 17, 2019

Copy link to clipboard

Copied

I think you just saved a considerable amount of my bacon. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2019 0
Adobe Community Professional ,
May 18, 2020

Copy link to clipboard

Copied

As mrgrenadier pointed out. This issue is related to variable framerate (and the horrid editing codec h265). Getting it out of h265 is great, but with a general transcode you run the risk of burning your variable framerate desync issues into the new file. If you don't need audio sync or if the clips are short it may not be a big deal or that noticeable, but if you are getting desync you're going to need to get your media into a constant framerate prior to any transcoding.

 

More info: https://www.reddit.com/r/VideoEditing/wiki/faq/vfr

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2020 0
New Here ,
Apr 14, 2020

Copy link to clipboard

Copied

THANK YOU SO MUCH! I have spent the past 4 days trying to fix this issue and nothing else worked. It was incredibly frustrating. Thank you x100! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2020 0
Adobe Community Professional ,
Apr 14, 2020

Copy link to clipboard

Copied

the danger with this solution is that the transcode will sometimes (if not always) screw up the audio.  Use Handbrake to convert from variable frame rate to constant frame rate while maintaining audio synch.  Hankdbrake's for free.  

https://handbrake.fr

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2020 1
New Here ,
Jul 23, 2020

Copy link to clipboard

Copied

Just a question about this as I had a similar problem and it was solved by transcoding it through media encoder.. What settings do i use in Handbrake to do this? Media encoder took around an hour to transcode just over an hours iphone footage in 4k, handbrake took a couple of hours.. But if there's less likely loss using handbrake, i'm happy to forgo the time.. Can I use one of the presets to transcode? I was thinking the 'production max' one?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
Adobe Community Professional ,
Jul 24, 2020

Copy link to clipboard

Copied

Me doesn't always convert VFR to CFR, weirdly enough. So for that I always use Handbrake.

 

In the video tab in Handbrake, check the CFR circle and set a specific number in the frame-rate box. Then in the compression settings, set them pretty high until it's showing "near placebo".

 

That should do it. And as you can batch things in Handbrake, I typically set it running when I'm leaving the shop for the day or gonna be off the computer for a couple hours.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2020 0
New Here ,
Apr 27, 2020

Copy link to clipboard

Copied

I tried all of this but the glitching only got worse

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2020 0
dewald85 LATEST
New Here ,
Oct 09, 2020

Copy link to clipboard

Copied

I had a similar issue. No glitches in Premier when editing, but whenever I export, I would double check the file that was exported and it would have random glitches. Finaly, whenever I export, I used Que, to let it be exported via media encoder, which solved the problem. Was working with Canon EOSR files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2020 0