Highlighted

Premiere pro input lag / latency in custom workspaces

Explorer ,
Dec 18, 2018

Copy link to clipboard

Copied

Hi Folks,

I have a problem that's been driving me nuts. Whenever I use a custom workspace, Premiere develops a huge lag, a 1-2 second delay between any mouse click and the action registering in the program (specifically the timeline). Keyboard delay is a little better, but it's still there.

The thing that's super frustrating is this only happens in custom workspaces. The lag disappears in the default "editing" workspace. I edit with two monitors, so I tend to use a workspace I've set up for that. Resetting the workspace doesn't help, the lag persists. If I delete the workspace and re-create it, I'll have no problems for 2 or 3 days, but then the lag returns. This is dumb. How do I fix this?

Windows 10 1803

Intel i9-9900k 8 core

64GB RAM

NVIDIA 980 Ti

Premiere is installed and running off an Intel NVME SSD.

I don't, I have two separate windows, one on each screen.

I actually just solved this, and it is dumb. It actually has nothing to do with multiple monitors. I want to stress this has been driving me nuts for about 4 months, and it's ridiculous that this is an issue. I rebuilt my 2-window workspace bit by bit testing each step of the way, and I found out what's happening.

It's the Essential Graphics panel.

One of the things my 2-monitor setup includes is adding the Essential Graphics panel to the layout, and giving it its own section. If the Essential Graphics panel is visible, AND it's switched to the "browse" tab, it slows everything to a crawl. If I switch it to "Edit" everything runs fine. The issue is that panel seems to really like to default to "browse" whenever I open the program. I just swapped Essential Graphics from having it's own space to being a tab with Effects, with Effects open over Essential Graphics by default. Now it works fine.

TL:DR having the "browse" tab of Essential Graphics open in a custom workspace was causing huge slowdowns

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere pro input lag / latency in custom workspaces

Explorer ,
Dec 18, 2018

Copy link to clipboard

Copied

Hi Folks,

I have a problem that's been driving me nuts. Whenever I use a custom workspace, Premiere develops a huge lag, a 1-2 second delay between any mouse click and the action registering in the program (specifically the timeline). Keyboard delay is a little better, but it's still there.

The thing that's super frustrating is this only happens in custom workspaces. The lag disappears in the default "editing" workspace. I edit with two monitors, so I tend to use a workspace I've set up for that. Resetting the workspace doesn't help, the lag persists. If I delete the workspace and re-create it, I'll have no problems for 2 or 3 days, but then the lag returns. This is dumb. How do I fix this?

Windows 10 1803

Intel i9-9900k 8 core

64GB RAM

NVIDIA 980 Ti

Premiere is installed and running off an Intel NVME SSD.

I don't, I have two separate windows, one on each screen.

I actually just solved this, and it is dumb. It actually has nothing to do with multiple monitors. I want to stress this has been driving me nuts for about 4 months, and it's ridiculous that this is an issue. I rebuilt my 2-window workspace bit by bit testing each step of the way, and I found out what's happening.

It's the Essential Graphics panel.

One of the things my 2-monitor setup includes is adding the Essential Graphics panel to the layout, and giving it its own section. If the Essential Graphics panel is visible, AND it's switched to the "browse" tab, it slows everything to a crawl. If I switch it to "Edit" everything runs fine. The issue is that panel seems to really like to default to "browse" whenever I open the program. I just swapped Essential Graphics from having it's own space to being a tab with Effects, with Effects open over Essential Graphics by default. Now it works fine.

TL:DR having the "browse" tab of Essential Graphics open in a custom workspace was causing huge slowdowns

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 18, 2018 1
Adobe Community Professional ,
Dec 18, 2018

Copy link to clipboard

Copied

I'm working on the mac, but do you have the latest drivers for your graphics card? 

I use 2 monitors, and send my video out to the second monitor using the playback preferences rather than using a custom workspace for that. 

You might also try switching the connections to the 2 monitors.   Also wondering if there's an issue with the resolution settings for the 2nd monitor.   Might try changing this and see if it makes a difference.  I'd start with lowering the resolution of the second monitor. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2018 0
Explorer ,
Dec 18, 2018

Copy link to clipboard

Copied

I've got the most recent drivers, and switching the cables didn't do anything. Both monitors are the same resolution, and running at their native resolutions. All I'm moving to the second monitor is project, media browser, effects, essential graphics, and history.

If I'm in the default editing workspace it doesn't matter what monitor I move Premiere to, it works fine, but as soon as I switch back to a workspace that spans the monitors it gets laggy. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2018 0
Adobe Community Professional ,
Dec 18, 2018

Copy link to clipboard

Copied

do you have any windows that actually spread across both monitors?  That might be a problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2018 0
Explorer ,
Dec 19, 2018

Copy link to clipboard

Copied

I don't, I have two separate windows, one on each screen.

I actually just solved this, and it is dumb. It actually has nothing to do with multiple monitors. I want to stress this has been driving me nuts for about 4 months, and it's ridiculous that this is an issue. I rebuilt my 2-window workspace bit by bit testing each step of the way, and I found out what's happening.

It's the Essential Graphics panel.

One of the things my 2-monitor setup includes is adding the Essential Graphics panel to the layout, and giving it its own section. If the Essential Graphics panel is visible, AND it's switched to the "browse" tab, it slows everything to a crawl. If I switch it to "Edit" everything runs fine. The issue is that panel seems to really like to default to "browse" whenever I open the program. I just swapped Essential Graphics from having it's own space to being a tab with Effects, with Effects open over Essential Graphics by default. Now it works fine.

TL:DR having the "browse" tab of Essential Graphics open in a custom workspace was causing huge slowdowns

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 1
New Here ,
Mar 21, 2020

Copy link to clipboard

Copied

I know this has been a while since it was posted, but I've had this issue for a while and this is always the first thread that pops up when I search for it. For me, it turns out it was an issue with Windows. Disabling Palm Check in the mouse settings wasn't sufficient, but changing the AAPThreshold setting in the registry from 2 to 0 did the trick, as described here on superuser. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 21, 2020 0
New Here ,
Sep 22, 2020

Copy link to clipboard

Copied

THIS SOLVED MY PROBLEM OH MY GOD.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 1
New Here ,
Sep 22, 2020

Copy link to clipboard

Copied

@jp80298018 and @cschodt48, sorry to hear you are having this trouble. I was not able to reproduce this on my Win machine. So are you saying that the Essential Graphics Panel, no matter whether using a dual monitor setup or single, slows down the UI as long as it it is visible? What version of Premiere Pro are you using? Does this happen specifically after you open a project (at this time the mogrts get loaded in the Essential Graphics Panel) or is this also an issue later into the edit? Do you have a lot of mogrts in the Essential Graphics Panel, especially in libraries or hooked to a network drive?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0
New Here ,
Sep 22, 2020

Copy link to clipboard

Copied

Hey there! Thanks for replying - I only have one or two graphics presets, I
barely use the panel at all. I'm on an iMac Pro but another iMac Pro hooked
to the same QNAP doesn't reproduce the issue. Two out of four IMac pros on
the network do, however. No issues with Mac Pro

--
John Pouliot
(978)-869-9135

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0
Adobe Employee ,
Sep 22, 2020

Copy link to clipboard

Copied

Well now this is getting really interesting, isn't it? What is the difference between those iMac Pros? Do they have different configurations? Which version of Premiere Pro?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0
Attlas LATEST
New Here ,
Oct 28, 2020

Copy link to clipboard

Copied

Just popping in to say that this fix worked for me on the Windows 10 version of Adobde Premiere Pro v13.1.5 with my three-screen workspace. Thank you so much for going through each and every panel to figure this out!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2020 0