Premiere Pro Monitor Lag

New Here ,
May 15, 2017

Copy link to clipboard

Copied

Hello all! Recently I have started editing on an external monitor connected to my laptop. I have noticed a very common issue that when I playback the video from the timeline, the video is very glitchy, not like the normal lag/glitch when it isn't rendered. I have played FHD 60fps video on this monitor and it works great but when I am watching or scrolling through the timeline, the video playback it is still glitchy. Premiere runs perfectly on my laptop however. I am running on a XPS 15 i7-7700HQ, 16GBs of Ram, GTX 1050ti and my monitor is an LG 29um57-p. My current version is cc 2017 Anything helps!!

Thank you,

Matt

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Pro Monitor Lag

New Here ,
May 15, 2017

Copy link to clipboard

Copied

Hello all! Recently I have started editing on an external monitor connected to my laptop. I have noticed a very common issue that when I playback the video from the timeline, the video is very glitchy, not like the normal lag/glitch when it isn't rendered. I have played FHD 60fps video on this monitor and it works great but when I am watching or scrolling through the timeline, the video playback it is still glitchy. Premiere runs perfectly on my laptop however. I am running on a XPS 15 i7-7700HQ, 16GBs of Ram, GTX 1050ti and my monitor is an LG 29um57-p. My current version is cc 2017 Anything helps!!

Thank you,

Matt

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 15, 2017 0
Enthusiast ,
May 15, 2017

Copy link to clipboard

Copied

Two things come to mind - either the video card is lagging driving two monitors (unlikely for a 1050ti) or perhaps the monitor is running at 30hz instead of 60hz.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2017 1
New Here ,
May 15, 2017

Copy link to clipboard

Copied

thanks for the response, however the monitor is running 60hz

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2017 0
Enthusiast ,
May 15, 2017

Copy link to clipboard

Copied

I just remembered I had laggy performance with certain apps on my 9550 as well (haven't run Premiere on it yet). I figured out it was because the notebook was not always using the discrete graphics vs the slower integrated graphics. As a quick check to see if that's what is happening for you, right-click on the desktop and run the NVIDIA Control Panel. Go to "Manage 3D settings" and in the Global Settings tab change it from "Auto-select" to "High-performance NVIDIA processor".

If this fixes your issue you can refine the resolution by switching the global setting back to "Auto-select" and then using the "Program Settings" tab to make the change specific to Premiere. That way you wont waste power when on the battery when not running Premiere.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2017 1
New Here ,
May 15, 2017

Copy link to clipboard

Copied

I just tried this, didn't work, restarted my laptop just in case and still didn't work /:

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2017 0
Enthusiast ,
May 15, 2017

Copy link to clipboard

Copied

Try disabling the laptop's internal display (F1/Fn+F1 I think), running just the external monitor, and see if that makes any difference.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2017 0
New Here ,
May 15, 2017

Copy link to clipboard

Copied

Didn't work, however, when I duplicate the displays it does work but that's not what I'm going for, and it doesn't fill up the entire monitor screen. I hope this info can help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2017 0
Enthusiast ,
May 15, 2017

Copy link to clipboard

Copied

Ok. Try reducing the resolution of the external display to the lowest resolution possible and see if the lag disappears.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2017 0
New Here ,
May 15, 2017

Copy link to clipboard

Copied

it gets to be a little less noticeable but still there

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2017 0
Enthusiast ,
May 16, 2017

Copy link to clipboard

Copied

I have to think it's down to the 2D processing power of the GPU then, in combination with potential inefficiencies of Premiere's screen drawing logic.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 16, 2017 0
New Here ,
Sep 16, 2020

Copy link to clipboard

Copied

I am having the same problem

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2020 0
Adobe Community Professional ,
Sep 16, 2020

Copy link to clipboard

Copied

It could be the drivers. Some work some don't.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2020 0