premiere pro not opening properly. blank white pop-up.

New Here ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

I just downloaded premiere pro on my windows 10 computer and cannot seem to use it. When I open it, it goes through the loading/launching window and take me to (as pictured) what looks like some form of login pop-up over a grey background. I am unable to use anything at the top left and the only thing I can interact with is the exit button on the white pop-up which closes the program enteirly. I tried following a solution from a year-old reddit post but that got me nowhere. Any help would be greatly apreaciated. 

TOPICS
Crash, Error or problem

Views

231

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 13, 2021 May 13, 2021

Copy link to clipboard

Copied

Hi there!

We're sorry for that. Can you let us know your system details (OS, CPU, RAM, GPU)? Also, which version of Premiere Pro are you using? https://community.adobe.com/t5/premiere-pro/faq-how-to-find-the-exact-version-of-premiere-pro-you-re...

 

Let us know.

Thanks,

Kartika

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 18, 2021 May 18, 2021

Copy link to clipboard

Copied

Didnt see the response but thank you for responding. Here is my pc info.

OS: windows 10 Home, build:19041.985

CPU: I7-6700k

ram: 16 GB

GPU: GTX 1080

I am not able you open the software so I cannot check the way your link says to but I believe it is Premiere Pro 15.2

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

LATEST

Thanks for the details. Can you try resetting the preferences? https://community.adobe.com/t5/premiere-pro/faq-how-to-reset-trash-preferences-in-premiere-pro/td-p/...

Also, could you check if it's working properly after launching "Run as administrator? Right-click on the app icon > Run as administrator. 

Let us know.

Kartika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines