Premiere Pro performance is low

New Here ,
Jan 28, 2021 Jan 28, 2021

Copy link to clipboard

Copied

Hi Kevin,

 

I'm a Sony-Premiere user and have been editing my A7sii footage for the past 5 years without any real problem.

I did update my workstation 3 years ago when starting to include more 4K footage. So I'm now using a Win 10 Pro 64 PC config with AMD Ryzen 7 1700 8 cores / 32 GB of RAM and a GTX 1660.

 

Then I upgraded to the A7Siii and started filming in 4K 4.2.2....

 

Even though my CPU + RAM are pushed further, they never really hit the wall.

Still, I feel like thumbnails in Premiere take AGES to be created, both in the project pannels as in the Timeline...

 

So I'm wondering if it's only a matter of computing power ? Or some settings in Premiere ? (I have looked at many tutos about that, and did not fiond any answer...)

 

I was also interested in looking at the "Dave Helmly computer platforms DOC" you mentionned in this post, but the link is dead...

 

Any good advice ?

Many thanks !

TOPICS
Performance

Views

298

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

GTX 1660 is an older card, this would be my guess as to the culprit as you have more than enough RAM. Hope this helps you!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

@r4ri15460812  Why propose wild guesses if you was asked about good advice?

None of the current dGPUs support hardware decoding of 4:2:2 videos. Hence no use of upgrading GPU. But better CPU likely will add to speed. 'Better' in terms of per core performance, not number of cores. That's assuming there are no storage bottlenecks.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Thank you both for your answers.

I came to the point that I could update my CPU and work from SSD only (which I already do with App + scratch disks on internal SSD / Footage on external SSD via USB3)

But I also realized that Première does not put thumbnails in a cache. So anytime I reopen a project, they have to be recreated... and with 4:2:2 footage it takes much longer.

Or use proxies..... 

Anyway, I'm still trying out different approachs until I will have to build myself a new PC 🙂

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

@Buena Onda Films Another solution is just to turn off 'Continuous video thumbnails' :

 

2021-03-15_23-27-05.jpg

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines