Highlighted

Premiere pro refuses to use my nvidia graphics card (desktop)

Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

Hi there

No matter what I do the usage on the GPU stays at 0-1% and will only use the onboard intel graphics instead of my dedicated GPU. I've been having this issue on my laptop as well but since I updated to 14.0 it is on my desktop too. I have hardware acceleration on and still nothing. I have updated all my drivers for the GPU and my pc. I have the media encoder installed and up to date. 

I have also disabled the integrated gpu now and even that has not helped. 

I'm going crazy because I can't have even come close to smooth playback in my timeline. 

 

Please someone help!

Topics

Error or problem, Hardware or GPU, Performance

Views

115

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere pro refuses to use my nvidia graphics card (desktop)

Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

Hi there

No matter what I do the usage on the GPU stays at 0-1% and will only use the onboard intel graphics instead of my dedicated GPU. I've been having this issue on my laptop as well but since I updated to 14.0 it is on my desktop too. I have hardware acceleration on and still nothing. I have updated all my drivers for the GPU and my pc. I have the media encoder installed and up to date. 

I have also disabled the integrated gpu now and even that has not helped. 

I'm going crazy because I can't have even come close to smooth playback in my timeline. 

 

Please someone help!

Topics

Error or problem, Hardware or GPU, Performance

Views

116

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 26, 2020 0
Adobe Community Professional ,
Aug 26, 2020

Copy link to clipboard

Copied

This is an issue very specific to the hardware ... both the CPU and the GPU, plus the GPU drivers.

 

And you left that crucial information out of your post, so ... until you provide that, we can only make wild guesses.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

Im using a rtx 2080 and i7 8700k 

the drivers on the gpu are version 452.06

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Adobe Community Professional ,
Aug 26, 2020

Copy link to clipboard

Copied

For many things, playback does not use the GPU much, that's a CPU-centric process. What media are you using, any effects applied? Does it change if say you have Lumetri color changes applied?

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

I have applied the reverse speed effect and have now just adjusted the colours and still nothing. when I go to export it still will not use the dedicated gpu so it is not a problem affecting only the playback performance 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Adobe Employee ,
Aug 26, 2020

Copy link to clipboard

Copied

Todd,

Sorry for the issue. The root of your GPU issue is actually a misunderstanding how Premiere Pro works with your specific computer system and H.264 footage. 

 

If you are working with H.264 footage, and you have Hardware Encoding enabled, you will be using the power of your Intel iGPU for standard editing, and exporting. The NVIDIA discrete GPU should only kick in for GPU accelerated processes, like GPU accelerated effects (Lumetri Color, Warp Stabilizer) and a few other things, like scaling. 

If you are not applying any effects, or do not have any scaling going on, your discrete GPU will remain relatively idle. 

What causes this misunderstanding is that you make a computer purchase thinking the discrete GPU will cause a performance enhancement for your workflow, when it's the iGPU that makes more of a difference if your wokflow is primarily with H.264 footage. 

 

If you are experiencing poor playback, something else is afoot. First thing, make sure the GPU is enabled in Project Settings. Next, place your media on a high speed media drive. Most editors use a separate SSD for all footage, as a rule. Try deleting media cache and trashing preferences if those steps still do not help.

 

I hope this helps.

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

Thanks for the advice

 

I do have it on an ssd and I have applied some lumetric effects and nothing

My gpu is enabled like I said and I just deleted any cache I had and still nothing

 

thanks again for the reply

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Adobe Employee ,
Aug 26, 2020

Copy link to clipboard

Copied

Drop a 4K clip into a 1080 sequence. Does the GPU engage then?

 

Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

nothing happened that time either 

still just bumping around 0-2% usage

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

the playback was smoother though even with some fxs but the issue is that I'm working with 4k footage and I need that 4k sequence

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

I am curious why would it use the iGPU over the dGPU for anything especially on a desktop pc?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
LEGEND ,
Aug 26, 2020

Copy link to clipboard

Copied

Sorry, but 14.0 was the very first release of the 2020 versions. As such, it does not natively support NVENC for hardware encoding. Only Intel QuickSync is supported for hardware encoding in this and all other versions of Premiere Pro up to and including 14.1. In these versions, if you are using the discrete GPU only, then only software encoding is available in those older versions.

 

Beginning with version 14.2, Nvidia's NVENC and AMD's VCE or VCN are supported for hardware encoding. And in your setup, then QuickSync will be used for decoding video while NVENC will be used for encoding to certain formats and codecs.

 

The current version (released, as opposed to beta) is 14.3.2.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

Sorry i misread the wrong part. I am currently running version 14.3.2 (build 42)

 

I updated earlier today

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
LEGEND ,
Aug 26, 2020

Copy link to clipboard

Copied

Then what is the Renderer set at (in the Project settings)? CUDA? OpenCL?

 

If that were set to OpenCL, then only the integrated Intel GPU is used. All of Nvidia's drivers artificially restrict OpenCL support to OpenCL 1.2 - below the OpenCL 2.0 that's required.

 

If set to CUDA, then it is likely that the Intel integrated GPU is being heavily used for QuickSync decoding (not encoding). Even so, there should be some usage of the discrete GPU. And just how much of the iGPU is utilized depends on the performance balance between the CPU and the iGPU. More than likely, however, the iGPU is relatively weaker than the CPU, so the iGPU still gets heavily used.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

It's set to cuda because I'm running an nvidia card 

I've already disabled the iGPU in device manager and still nothing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
LEGEND ,
Aug 26, 2020

Copy link to clipboard

Copied

Oh, then you likely have a GPU that's quite overqualified for the CPU that you're using. Why get an RTX 2080 for only a three-year-old 6-core/12-thread CPU? The performance balance between the CPU and the GPU is a bit lopsided here. You either need to upgrade your CPU to an i9-9900K or downgrade your GPU to something like an RTX 2060 KO or a GTX 1660 Super in order for your system to be relatively balanced.

 

And disabling the iGPU in the Device Manager will do absolutely nothing since Windows will still load the driver for the iGPU. The ONLY way to truly disable the iGPU is via the BIOS/UEFI setup. The procedure and labeling of that setting depends on the manufacturer of your motherboard (for example, ASUS has this setting labeled as "iGPU Multi-Monitor").

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

I'm using an itx build and the i9 was running too hot.

why would that matter in the first place though? The i7 8700k is still very powerful for what editing I'm doing. 

I would understand where you are coming from if I was running like an i7 4790k but man this combination isn't that wacky and should not be causing this issue

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

I just checked in the BIOS and the iGPU is disabled there too

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
LEGEND ,
Aug 26, 2020

Copy link to clipboard

Copied

Okay, fair enough for the CPU. But that does not excuse the GPU choice. Unlike gaming, video editing demands a relatively close balance between the CPU and the GPU. In fact, for video editing a quad-core i7-4790K does not deserve anything that's higher than a GeForce GTX 1660 (non-Super) for optimal performance balance.

 

In other words, in your instance your CPU is bottlenecking the GPU significantly, preventing the GPU from being utilized much even during heavy computational workloads.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

okay but im not just getting small hitching here and there

the program is so glitchy that as soon as I put a simple effect like reverse speed on, it cant play the video at more than 1fps. 

I can "render effects" as many times as I want and it doesn't get any better

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
LEGEND ,
Aug 26, 2020

Copy link to clipboard

Copied

Next thing to check is your CPU temperatures under load. Software readings are NOT 100% accurate. Not even close.

 

In fact, your CPU may be throttling down its clock speed under a heavy load such as exporting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

It gets up to about 81C but I haven't spotted it throttling

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
LEGEND ,
Aug 26, 2020

Copy link to clipboard

Copied

Check the clock speed in the Windows Task Manager when you're renmdering out that 4k project. It should not be below the CPU's base speed of 3.7 GHz. If it is, then either your CPU cooler is mounted incorrectly or you have a lousy CPU cooler.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

I ran a bunch of stress test when I first built the pc

no thermal throttling

I just rendered a small clip with the reverse speed effect on it and had steady 4.3ghz the whole time (took a good 10 mins 

I think this whole theory that there's a problem with my hardware whether it be what I picked or how I put it together is a dead end man

there has to be another solution out there

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

I just want to edit my video and the studdering is really getting to me 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 1
LEGEND ,
Aug 26, 2020

Copy link to clipboard

Copied

The problem is the software itself getting pickier and pickier with regards to the CPU power and performance. You really, really need an 8-core/16-thread or better CPU with any newer version of Premiere Pro just to handle 4k well. You see, Adobe keeps adding more new features that inevitably eat up more and more CPU power.

 

And there is absolutely no free lunch whatsoever, in this case: Older versions of Premiere Pro (like the 13.1.5 version) may work better with your system, but may not properly support newer hardware as time progresses.

 

In other words, you're stuck (literally) between a rock and a hard place.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

pretty grim man

You dont think there is anything else that can be done? Just editing some footage from my dji mavic pro man. So my i7 8700k is completely useless? 

again I could understand if I was sorely underpowered but man people are editing on their laptops. Getting as crazy picky as you are talking is bad for business. 

Thank you very much for trying to help me 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 1
LEGEND ,
Aug 27, 2020

Copy link to clipboard

Copied

And Premiere Pro performs even worse on even a top-of-the-line laptop than it does on your desktop. And there are a slew of laptops whose CPU performance falls far below the minimum recommended specifications for any recent version of Premiere Pro.

 

What this all means is that one might need a huge, monster-sized PC with a Godlike CPU and tons of RAM in order for Premiere Pro to run anywhere near its best.

 

Finally, many of those laptop users are not running professional-level editing software at all - but are actually running cheapo amateur/consumer-level software that do not take anywhere close to full advantage of even a 14-year-old dual-core CPU, let alone a modern multi-core CPU. As such, these software always perform sluggishly no matter what, and are unsuitable for anything above 288-pixel resolution (352x288p50).

 

At any rate, not all mini-ITX cases are created equal. In fact, ultra-slim towers will have a much, much tougher time accommodating a decent-sized CPU cooler than a shoebox-shaped case.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2020 0
Adobe Employee ,
Aug 31, 2020

Copy link to clipboard

Copied

Sometimes, hitching like this can be audio related, as weird as that sounds. Screenshot your Audio Hardware Preferences so we can inspect that too.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2020 0