Highlighted

Premiere Pro will not use GPU for Timeline editing and playback

New Here ,
Sep 06, 2020

Copy link to clipboard

Copied

I want Premiere Pro to use my GPU for Timeline Editing and Playback but it does not. I have Mercury Playback Engine GPU Acceleratoin (Cuda) Selected and I also have Enable hardware accelerated encoding and decoding selected in settings. When trying to edit the timeline or just play the video in the time line my CPU goes to MAX usage and GPU stays under 5%. I have the latest version of Premiere Pro CC and the latest version of Nvidia drivers. I have also tried rolling back Premiere Pro and Nvidia driver versions to see if this will fix it but it will not. Is there a setting I am missing? The other video editing software I have used did not have this problem. It used my GPU in all aspects smoothly. By the way I can use Hardware Acceleration for EXPORTING my videos not problem. My problem is editing and playback withing the timeline. I have an i7-6700, RTX2080 with 16gb of ram. I know my hardware is not the issue. The program just will not utilize my GPU, that is the problem. Please tell me how to fix this!

TOPICS
Editing, Hardware or GPU, Performance

Views

15

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Pro will not use GPU for Timeline editing and playback

New Here ,
Sep 06, 2020

Copy link to clipboard

Copied

I want Premiere Pro to use my GPU for Timeline Editing and Playback but it does not. I have Mercury Playback Engine GPU Acceleratoin (Cuda) Selected and I also have Enable hardware accelerated encoding and decoding selected in settings. When trying to edit the timeline or just play the video in the time line my CPU goes to MAX usage and GPU stays under 5%. I have the latest version of Premiere Pro CC and the latest version of Nvidia drivers. I have also tried rolling back Premiere Pro and Nvidia driver versions to see if this will fix it but it will not. Is there a setting I am missing? The other video editing software I have used did not have this problem. It used my GPU in all aspects smoothly. By the way I can use Hardware Acceleration for EXPORTING my videos not problem. My problem is editing and playback withing the timeline. I have an i7-6700, RTX2080 with 16gb of ram. I know my hardware is not the issue. The program just will not utilize my GPU, that is the problem. Please tell me how to fix this!

TOPICS
Editing, Hardware or GPU, Performance

Views

16

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 06, 2020 0

Have something to add?

Join the conversation