Premiere Won't Open, Creative Cloud Cleaner did nothing.

New Here ,
Jul 17, 2021 Jul 17, 2021

Copy link to clipboard

Copied

After not using Premiere for a few months, I decided to reopen a project I had put off for a little bit. To my surprise, however, I launched it and said I was missing a .dll file. Which, made no sense as I haven't made any changes to my computer nor have I removed any files within anything. I wouldn't know how to do that if I tried. With a lot of guidance I resorted to reinstalling the C+++ as I was told to do so. And... lo and behold, it didn't help. Nothing changed. 

So upon further investigations, I resorted to adding the .dll file to the System32 folder, as prompted. Doing everything I could in hopes of figuring out the problem. As, this is the only program in the Adobe CC that I could not open. Which, I did test and everything I had installed (Photoshop and After Affects) worked perfectly fine and opened with zero issue. After doing so however, I now had a new issue! I get the application error of:

"The application was unable to start correctly (0x00000ba). Click OK to close the application."

So I did more digging and my options recommended that I uninstall and reinstall that program specifically and I did so as a means of a new start.

Nothing improved.

For two hours, I was at a loss for what to do. I was presented with two new options. Not using the program and finding a free program, despite paying for the one I wanted to use intentionally and knew how to use, OR reinstall windows as a whole. I got as far as being stuck in reset mode, where nothing happened with Windows. I had to manually power down and turn the PC back on. I got impatient and reached out to someone whom was better at this stuff than I. Who said, I wouldn't need to do that. I just needed to uninstall and reinstall creative cloud as a whole. And I did. Still nothing.

I then resorted to using the creative cloud cleaner, following the steps down to a T. But again, even after all that progress, nothing. I still cannot open the program. We're now on hour 4 of this insanity and I still cannot open the program. It as much shows me a loading wheel when I hit open but that is as far as it gets. 

Is the only option to reinstall windows as a whole? Because if so, that's incredibly awful. This shouldn't have to come to that. I'm extremely unhappy and would just like a proper answer, one simplified if possible with a step by step on what to do with this. I have no idea what I should even do and I'm struggling. 

If needed, specs.
AMD Ryzen 7 2700 Eight-Core Processor 3.20 GHz
32 GB Ram
Gigabyte 1660Ti

Not sure what else would be needed for this information but. I just want help. Please and thank you.

TOPICS
Error or problem, FAQ, How to

Views

39

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation