Highlighted

Premiere Won't Play Video

New Here ,
Jul 31, 2020

Copy link to clipboard

Copied

Hi all!

 

I just downloaded a fresh install of Premiere Pro 2020 after performing a wipe and fresh install of Windows 10. The problem is that Premiere won't play anything now! I'm able to open the project and do things like move clips around and save the project, but if I hit the spacebar or the play button the program preview just stays black or gray. Even when I move the playhead around without playing anything, all I ever get is black or gray. I've checked my resource usage while trying to play things and it doesn't appear to be tapping into my memory or graphics card at all. Memory usage hovers around 2gb and the graphics usage stays at 0% no matter what I do.

 

I've also noticed that whenever I try to close the program it freezes and I have to end the task manually.

 

I've already tried everything suggested in this post: https://community.adobe.com/t5/premiere-pro/premiere-pro-won-t-play-preview-video-footage/td-p/10328...

And in this article: https://www.stellarinfo.com/blog/fix-premiere-pro-wont-play-videos/

 

Any help would be much appreciated!

 

Specs: Windows 10 64bit || Intel Core i5 4590 Haswell || 8gb ram || ASRock H97M Anniversary motherboard || AMD Radeon R9 270 with latest drivers installed

Topics

Error or problem, Freeze or hang

Views

21

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Won't Play Video

New Here ,
Jul 31, 2020

Copy link to clipboard

Copied

Hi all!

 

I just downloaded a fresh install of Premiere Pro 2020 after performing a wipe and fresh install of Windows 10. The problem is that Premiere won't play anything now! I'm able to open the project and do things like move clips around and save the project, but if I hit the spacebar or the play button the program preview just stays black or gray. Even when I move the playhead around without playing anything, all I ever get is black or gray. I've checked my resource usage while trying to play things and it doesn't appear to be tapping into my memory or graphics card at all. Memory usage hovers around 2gb and the graphics usage stays at 0% no matter what I do.

 

I've also noticed that whenever I try to close the program it freezes and I have to end the task manually.

 

I've already tried everything suggested in this post: https://community.adobe.com/t5/premiere-pro/premiere-pro-won-t-play-preview-video-footage/td-p/10328...

And in this article: https://www.stellarinfo.com/blog/fix-premiere-pro-wont-play-videos/

 

Any help would be much appreciated!

 

Specs: Windows 10 64bit || Intel Core i5 4590 Haswell || 8gb ram || ASRock H97M Anniversary motherboard || AMD Radeon R9 270 with latest drivers installed

Topics

Error or problem, Freeze or hang

Views

22

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation