Highlighted

PremierePro poor performance

New Here ,
Apr 23, 2019

Copy link to clipboard

Copied

Hello,

having issues with Premiere Pro for having very poor performance after upgrading my pc (and complete clean install). No matter what version of PP i try but i can't just play even on 1/4quality single RED raw or Sony .mp4 video track WITHOUT any effects adjus. layer or anything - i've got like 60-70 dropped frames after 10seconds .. overall its very hard to work with any videotrack.

- I know that i was able to play like 2-3video tracks of red raw with colorgrading and effects without significant drops before pc upgrade

- I already tried different apps for videoedit and there is everything ok like before and in premiere i've got better performance in my second (backup) pc which is like 5 times chaper and slower than my main working pc

- Adobe support not helped me - they told me that this is NORMAL .. no it just not, its very hard to work in PP now ..

sys spec:

windows 10 home 64bit

cpu: amd threadripper 2950x

mobo: asrock fatality x399 professional gaming

gpu: rtx2080ti

ram: 48gb

2x samsung evo850 ssd 250gb - in raid for main project video files

1x samsung evo850 ssd 250gb for os

1x hp ssd 120gb for main apps

3x sata hdd (WD black/red)- for temp/scratch files

thanks for any help

Views

243

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PremierePro poor performance

New Here ,
Apr 23, 2019

Copy link to clipboard

Copied

Hello,

having issues with Premiere Pro for having very poor performance after upgrading my pc (and complete clean install). No matter what version of PP i try but i can't just play even on 1/4quality single RED raw or Sony .mp4 video track WITHOUT any effects adjus. layer or anything - i've got like 60-70 dropped frames after 10seconds .. overall its very hard to work with any videotrack.

- I know that i was able to play like 2-3video tracks of red raw with colorgrading and effects without significant drops before pc upgrade

- I already tried different apps for videoedit and there is everything ok like before and in premiere i've got better performance in my second (backup) pc which is like 5 times chaper and slower than my main working pc

- Adobe support not helped me - they told me that this is NORMAL .. no it just not, its very hard to work in PP now ..

sys spec:

windows 10 home 64bit

cpu: amd threadripper 2950x

mobo: asrock fatality x399 professional gaming

gpu: rtx2080ti

ram: 48gb

2x samsung evo850 ssd 250gb - in raid for main project video files

1x samsung evo850 ssd 250gb for os

1x hp ssd 120gb for main apps

3x sata hdd (WD black/red)- for temp/scratch files

thanks for any help

Views

244

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 23, 2019 0
Adobe Community Professional ,
Apr 23, 2019

Copy link to clipboard

Copied

Sorry to read this. Seems like you've got a pretty beefy system.

Not sure if PPro already takes full advantage of the GPU, though: https://www.pugetsystems.com/labs/articles/Premiere-Pro-CC-2018-NVIDIA-GeForce-RTX-2080-2080-Ti-Perf...

My advice is still to get in touch with Adobe support. There should be something that is holding your system back.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 23, 2019 0
New Here ,
Apr 23, 2019

Copy link to clipboard

Copied

yeah thanks ...  i did it twice and everytime i was asking them about compatibility of RTX gpu too and in both cases they told me that there is no problem with this gpu series

but i can try it one more time so

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 23, 2019 0
AjS_VB LATEST
Explorer ,
Sep 30, 2020

Copy link to clipboard

Copied

It's the horrible render engine Premiere uses.  Any footage I put into premiere lags for a few seconds and then seems to catch up.  I watch the CPU spike and then settle to simply scrub real time.  ANY and I mean any other software works faster and better.  I'm invested and hating every minute of waiting 70% of the time, render in/out just to work.  6800k, 64GB, nvme, all SSD caches, etc.  Adobe support is a joke.  Even worse than the paid 'help' that answers these posts with most useless "check this" or that nonsense wasting even more of your time.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2020 0