Highlighted

Proxies lag when attached. Playback fine on their own.

Community Beginner ,
Jun 12, 2020

Copy link to clipboard

Copied

I've been using Premiere for years and never had a great experience with proxies. I thought it was my system but now after doing some experimenting, it looks like a software issue.

 

I've used both Prores and Gopro proxies. Similar results. Only slightly better performance than trying to play 4k footage on it's own.

 

I experimented by importing the proxy file directly into the session and on to the timeline. Plays perfectly. I added Lumetri, a camera LUT, and HSL. Still plays back perfectly.

 

When using the attached proxy version (as opposed to putting the proxy file directly on the timeline), not only does the playback suffer, but the performance of my entire computer suffers. Trying to adjust setting and sliders in effects panels is painfully slow. When using the proxy file directly on the timeline, all of this is super smooth.

 

This leads me to believe it is a software issue, not a hardware issue. I came across this post from December that was never solved, but experienced the same exact issue. It seems like in some instances Premiere doesn't work well with attached proxies - even though it can play & manipulate the actual proxy file just fine on its own.

 

Any insight on how to address this?

 

Computer specs:

Premiere Pro 13.1.5 (Seeing same issues in 14.2)

macOS Mojave

Mid 2015 Macbook Pro

16 GB RAM

Graphics Intel Iris Pro 1536 MB (not the ideal card, but pls remember that the proxy file plays back fine on its own)

 

Hi Brian,

Thanks for the message. Basically, your hardware is the problem. It's too old and too slow for a 4K editing session.

Your laptop doesn't meet minimum specs for HD, much less 4K. That is probably why your sub-HD proxies are doing fine playing on their own. System Requirements are here. Note that your laptop has a Gen 4 CPU. The minimum for HD is a Gen 6 CPU. You need a 2 GB VRAM for HD, a 4GB VRAM for 4K. Your GPU has less than both of those requirements.

 

Secondly, you didn't mention your media drive. If you do not have one of those, your system's hardware is not configured properly.

  • A properly configured NLE system includes a media drive, either internally mounted, or in the case of a laptop, connected via Thunderbolt or USB 3 at a minimum. Drives must be similar in speed to a SSD or a 7200RPM HD, or faster.
  • If you want even better performance, a second media drive can be used for media cache.

 

You might consider your original idea and edit using the Ol' Skool "offline/online" proxy method. Chin Fat describes it well in this video. 

 

 

My only difference from CF is that I like to use ProRes Proxy instead of H.264 for proxies. It is more performant over H.264. Hope this helps.

 

Otherwise, I think you are going to have to bite the bullet and get a new computer if you want to travel down the road of 4K editing. I have a new MacBook Pro with a 4TB Thunderbolt 3 drive. It's awesome!

 

Thanks,

Kevin

TOPICS
Freeze or hang, Performance

Views

218

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Proxies lag when attached. Playback fine on their own.

Community Beginner ,
Jun 12, 2020

Copy link to clipboard

Copied

I've been using Premiere for years and never had a great experience with proxies. I thought it was my system but now after doing some experimenting, it looks like a software issue.

 

I've used both Prores and Gopro proxies. Similar results. Only slightly better performance than trying to play 4k footage on it's own.

 

I experimented by importing the proxy file directly into the session and on to the timeline. Plays perfectly. I added Lumetri, a camera LUT, and HSL. Still plays back perfectly.

 

When using the attached proxy version (as opposed to putting the proxy file directly on the timeline), not only does the playback suffer, but the performance of my entire computer suffers. Trying to adjust setting and sliders in effects panels is painfully slow. When using the proxy file directly on the timeline, all of this is super smooth.

 

This leads me to believe it is a software issue, not a hardware issue. I came across this post from December that was never solved, but experienced the same exact issue. It seems like in some instances Premiere doesn't work well with attached proxies - even though it can play & manipulate the actual proxy file just fine on its own.

 

Any insight on how to address this?

 

Computer specs:

Premiere Pro 13.1.5 (Seeing same issues in 14.2)

macOS Mojave

Mid 2015 Macbook Pro

16 GB RAM

Graphics Intel Iris Pro 1536 MB (not the ideal card, but pls remember that the proxy file plays back fine on its own)

 

Hi Brian,

Thanks for the message. Basically, your hardware is the problem. It's too old and too slow for a 4K editing session.

Your laptop doesn't meet minimum specs for HD, much less 4K. That is probably why your sub-HD proxies are doing fine playing on their own. System Requirements are here. Note that your laptop has a Gen 4 CPU. The minimum for HD is a Gen 6 CPU. You need a 2 GB VRAM for HD, a 4GB VRAM for 4K. Your GPU has less than both of those requirements.

 

Secondly, you didn't mention your media drive. If you do not have one of those, your system's hardware is not configured properly.

  • A properly configured NLE system includes a media drive, either internally mounted, or in the case of a laptop, connected via Thunderbolt or USB 3 at a minimum. Drives must be similar in speed to a SSD or a 7200RPM HD, or faster.
  • If you want even better performance, a second media drive can be used for media cache.

 

You might consider your original idea and edit using the Ol' Skool "offline/online" proxy method. Chin Fat describes it well in this video. 

 

 

My only difference from CF is that I like to use ProRes Proxy instead of H.264 for proxies. It is more performant over H.264. Hope this helps.

 

Otherwise, I think you are going to have to bite the bullet and get a new computer if you want to travel down the road of 4K editing. I have a new MacBook Pro with a 4TB Thunderbolt 3 drive. It's awesome!

 

Thanks,

Kevin

TOPICS
Freeze or hang, Performance

Views

219

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 12, 2020 0
Community Beginner ,
Jun 12, 2020

Copy link to clipboard

Copied

UPDATED: Still experimenting. Here's something else I've noticed.

 

The proxy file plays back perfectly and computer operates fine on a timeline created using "New Sequence From Clip" so the settings match the file.

 

If I take that same proxy file and drop it on the 4K timeline intended for the original files then the whole system lags. Could it be something about the sequence settings?

 

Here are the sequence settings. The only thing I see different are the dimensions.

Screen Shot 2020-06-12 at 12.37.01 PM.pngScreen Shot 2020-06-12 at 12.37.18 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Adobe Employee ,
Jun 12, 2020

Copy link to clipboard

Copied

Hi brians898896,

 

Sorry about the poor experience. This sounds so weird. Is this behavior specific to the Attach Proxies workflow (where you are attaching the low res files manually) or is it also happening with the Create Proxies workflow (where Premiere Pro creates proxies in the background and links to the original media itself)? Let us know, we're here to help.

 

Thanks,

Sumeet

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Community Beginner ,
Jun 12, 2020

Copy link to clipboard

Copied

Hi Sumeet - Thanks for the reply. I always use the "Create Proxies" workflow where it uses Media Encoder to create the proxies.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Adobe Employee ,
Jun 12, 2020

Copy link to clipboard

Copied

Hi Sumeet, 

Thanks for assisting! I think what's going on here is lack of system performance combined with the choice of a non-performant codec for use as a proxy.

The Mac is underpowered in the CPU and GPU department. The proxy is being scaled up for playback using the GPU, according to the Mercury Playback Engine. Brian's GPU is less than 2 GB VRAM and is scaling up a 1K sized proxy clip to 4K size. Furthermore, it's likely the proxy is H.264 format, which is less performant than other codecs. That is my theory, anyway.

Regards,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Adobe Employee ,
Jun 12, 2020

Copy link to clipboard

Copied

Hi Brian,

Thanks for the message. Basically, your hardware is the problem. It's too old and too slow for a 4K editing session.

Your laptop doesn't meet minimum specs for HD, much less 4K. That is probably why your sub-HD proxies are doing fine playing on their own. System Requirements are here. Note that your laptop has a Gen 4 CPU. The minimum for HD is a Gen 6 CPU. You need a 2 GB VRAM for HD, a 4GB VRAM for 4K. Your GPU has less than both of those requirements.

 

Secondly, you didn't mention your media drive. If you do not have one of those, your system's hardware is not configured properly.

  • A properly configured NLE system includes a media drive, either internally mounted, or in the case of a laptop, connected via Thunderbolt or USB 3 at a minimum. Drives must be similar in speed to a SSD or a 7200RPM HD, or faster.
  • If you want even better performance, a second media drive can be used for media cache.

 

You might consider your original idea and edit using the Ol' Skool "offline/online" proxy method. Chin Fat describes it well in this video. 

 

 

My only difference from CF is that I like to use ProRes Proxy instead of H.264 for proxies. It is more performant over H.264. Hope this helps.

 

Otherwise, I think you are going to have to bite the bullet and get a new computer if you want to travel down the road of 4K editing. I have a new MacBook Pro with a 4TB Thunderbolt 3 drive. It's awesome!

 

Thanks,

Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Community Beginner ,
Jun 23, 2020

Copy link to clipboard

Copied

I did not consider the proxy itself being scaled up for playback. That makes sense as to why it still lags.

 

Btw, the media drive is a Samsung T5 SSD, but that seems irrelevant at this point.

 

Thanks for pointing me towards the old school method. Seems like it's probably the best workaround until I can afford a new computer or an external GPU

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2020 1
samkhpak LATEST
New Here ,
Jul 14, 2020

Copy link to clipboard

Copied

I am having similar issue with the new updates, when I edit on time line and press spacebar to play back on Program monitor it's super laggy, but if I just click on Source monitor once and then click on Program monitor again and press space bar it plays smoothly without any frame drop. This is for sure a software issue and not hardware. Please adobe, check this issue, I can send you a video and don't find an easy answer for a problem and spend time in investagating the issue and solve it. I was blaming myself for starting this project on Premiere when I could use Avid? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 14, 2020 0