Proxy Files do not detach

Participant ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

I have never used proxies in my workflow because my system can easily handle 4K.  I had time to experiment on a big project with a generous deadline.  Turning proxies "on" for ingest actually created more work for my system.  So I detached the proxies and now they won’t go away.   

 

  1. Detached all proxies - NG
  2. Moved all proxies to a new folder - NG
  3. Imported sequences to a new project - NG
  4. Selected Ignore all on project opening crashes the app

 

I know how this story ends - I will end up trashing all of my preferences and doing a clean install.  If anyone has an easier way to solve this problem, please let me know.  

 

Oh and by the way, PP 15’s mercury transmit sucks.  Always flickering, especially when slipping tracks.

 

Premiere Pro CC 15.2.0 (build 35)

MacOS 11.2.3

Mac Pro 7,1 with AMD Radeon Pro Vega II

TOPICS
Crash, Editing, Error or problem, Freeze or hang, Performance

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

What exactly do you mean 'they won't go away'? You are still seeing the proxy version? Even if you've moved the files?

Have you enabled the proxy columns in the metadata display? Does the proxy path not disappear when you 'detach'. It does for me (just tested a couple of clips in v15.2).

Screenshot 2021-05-11 at 23.59.11.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

They won't go away as in the subject of my post "proxy files do not detach."  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

Just close your eyes then. That will make them go away.

 

But seriously, you have to explain exactly what is happening. Have you enabled the columns as I've described? Help us so we can help you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

I enabled proxy metadata and it file path is blank.  Even though the camera original clip has no proxy file attached to it, the project will not load without the proxy files.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

and what is the problem if you have proxies toggled off in either the program or source monitors?   Please be more specific as to what issues you're experiencing.  And I strongly suggest you back up your startup drive to a bootable clone using something like carbon copy cloner when you have a stable system so if you have an issue, you can quickly restore your system to it's previous state.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

The problem is that I now cannot work with the project when the proxies are offline.  I'm stuck with 200GB of proxy files that I don't need or use. 

Missing_media.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

something is wrong here.  this is not normal behavior.  try this.  Create a new project and import the old one and see if that allows you to successfully detach the proxies.   You might also try resetting your preferences...  Or post the project file and I'll see if I can detach the proxies, save it and send it back to you.  I know the media will be offline, but worth a shot.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

I agree.  Something is wrong here and I appreciate your attention.  As I mentioned in my original post, step 3 was to import the sequence into a new project.  I saved the new project with the imported sequence, quit the application, launched and opened the new project file.  I got the offline media dialog box (see screen capture above).  If I "ignore all" sometimes it hangs, sometimes it loads.  If I save the project with proxy files offline, the next time I open it, it asks to connect all those files again.  If I connect all the offline media, save and relaunch, it still asks for all those files.  If I take one clip that shows no proxy attached either in the right click proxy options or the metadata file info -- if I take that one clip and create a new sequence and try to import that sequence into a new project it also asks for a missing offline proxy file.  I can workaround this, but it's frustrating to have to reconnect constantly for files that I don't use or want.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

It seems like the simple answer to my question about proxy files having a life of their own is that the proxy workflow is a background operation.  You can choose not to view them or use them, but they will always be associated with whatever clips were ingested with the proxies turned on.  Sequences that use clips that have proxies are forever associated with those proxies.  I've deleted media cache, cache database, reinstalled apps and imported sequences into pristine projects and still the proxy relationship exists.  I can watch the software generate .pek files for the proxies in the background.  The "detach proxies" function looks as if it works, but it doesn't and if I offline the proxies upon opening a project, the app will hang.  

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Proxies need a serious overhaul. I have read nearly every proxy related post on the community and far too many end up being abandonded because no one had an answer. The overused fall back of 'just start all over' is not an answer. It's not the fault of those who try to help, it's the fault of how the entire proxy system is constructed. It's on Adobe.

 

For those who will predictably say that 'proxies work just fine' or 'Well I've never had a problem': in 2030, proxies will function much better and do less unexplainable things. They may even be utterly flawless. Most likely also by 2025. So Adobe should do their level best to achieve that kind of performance and reliability by 2022. We'd love an update where they are addressed this summer.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

for what it's worth, took me a while to get my head around the proxy workflow.  The most important lesson I learned was to test your proxy ingest preset on one clip before doing them all.  And if you have a variety of source formats, do a test for each format.  When I've done that, I haven't had any issues.  In my experience, the equivalent workflow in davinci resolve was no better than premiere's when I worked in it last and Avid Media Composer didn't seem any better lthough it's been 3 or 4 years since I worked in Avid (so maybe they've fixed it).   

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

LATEST

Here, here!  (nice handle by the way Tarzanofmars - Sir Arthur would be proud)

I agree.  If a feature doesn't work well, don't release a new feature without fixing the old feature.  Frankly, PP makes proxies by default, always has - they are called previews, and they are easy to trash.  If you need to work "lo rez," just downgrade the playback quality.  You could even downgrade the sequence settings.  Every one of my projects has hundreds of clips and I regularly import older projects to search for stock shots.  When I tried that with proxies turned on, it was a mess.  I might consider revisiting proxies if I get a job with only 40 clips of 8K video.  I'll let you know when that happens.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines