"Replace with After Effects Composition" greyed out using CC - WHY??

New Here ,
Nov 19, 2013 Nov 19, 2013

Copy link to clipboard

Copied

Hi All,

I am doing a project in Premiere Pro CC but need to dynamic link to After Effects CC.  The "replace with After Effects Composition" button is greyed out and I can't understand why, both are installed!

I still have Premiere Pro CS6 and AE CS6 installed, because they contain plug-ins I use regularly, could this be causing an issue? I can't think why it would.

Any help would be greatly appreciated.

Many thanks,

Rick

TOPICS
Error or problem, User interface or workspaces

Views

68.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Nov 30, 2020 Nov 30, 2020
We created a visual walkthrough of this issue and how to fix it! Hope it helps! Caroline

Likes

Translate

Translate
Participant ,
Nov 19, 2013 Nov 19, 2013

Copy link to clipboard

Copied

Just confirming, You do have after effects CC installed? If not, that's why.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2013 Nov 19, 2013

Copy link to clipboard

Copied

Yes, Premiere Pro and After Effects CC are both installed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 19, 2013 Nov 19, 2013

Copy link to clipboard

Copied

Hi rickjcksn,

Please mention the opertaing system that you are using and whether the products are updated or not.

Regards,

Vinay

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2013 Nov 19, 2013

Copy link to clipboard

Copied

Hi Vinay,

PC - Win 7 Professional

32gb RAM

GTX 760

All programmes are fully updated.

Thanks,

Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 19, 2013 Nov 19, 2013

Copy link to clipboard

Copied

Hi,

Thanks for the reply now please navigate to C:\Program Files (x86)\Common Files\Adobe\dynamiclink and check whether you have folders 7.0 for cc, CS6 and AfterFX and Premiere. It may happen that AfterFX and Premiere might be missing or one of them might be missing.

Regards,

Vinay

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2013 Nov 19, 2013

Copy link to clipboard

Copied

Hi Vinay,

Thank you for your help with this. 

I have navigated to that folder and I can confirm that I have two folders "7.0" and "CS6" also two exe files "AfterFX" and "Premiere".

Thanks,

Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 19, 2013 Nov 19, 2013

Copy link to clipboard

Copied

Hi,

Please navigate to C:\Program Files (x86)\Common Files\Adobe\dynamiclinkmediaserver\1.0 and rename 1.0 as old1.0 and also C:\Program Files\Common Files\Adobe\dynamiclinkmediaserver\7.0 and rename it as old7.0.

Reset the preferences of After effects and Premiere pro from :

C:\Users\username\AppData\Roaming\Adobe\After Effects and rename 12.0 and 12.1 as old12.0 and old12.1. In the same location C:\Users\username\AppData\Roaming\Adobe\Premiere Pro and rename 7.0 as old7.0.

Restart the machine after these steps and then try to use dynamic link

Regards,

Vinay

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 25, 2013 Nov 25, 2013

Copy link to clipboard

Copied

Hi Vinay,

Sorry for the slow reply.

I have made all those changes you have suggested and it has still not helped.  I went and checked that premiere CS6 dynamic link worked, and it does.  I don't understand why CC dynamic link still isn't functioning!

Any other suggestions?

Regards,

Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 25, 2013 Nov 25, 2013

Copy link to clipboard

Copied

I'm assuming that you've selected a clip in the timeline!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 25, 2013 Nov 25, 2013

Copy link to clipboard

Copied

Yes.  I right click the clip and go down to "replace after effects composition" like i would do normally and on Premiere Pro CC and it is greyed out.  This is a function i used regularly on CS6 without any issues.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 25, 2013 Nov 25, 2013

Copy link to clipboard

Copied

Hi rickjcksn,

Are you able to launch premiere pro cc from after effects, please try and check what happens when you go to after effects file menu>dynamic link.

Regards,

Vinay

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 31, 2014 Mar 31, 2014

Copy link to clipboard

Copied

I have the same problem

I am running Windows 8.1 and adobe CC with all products up to date. I tried the steps above, and can launch premiere from After Effects but not use the "replace with after effects compoisitin" feature

I noticed this issue appear when I uninstalled CS6 Suite

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 31, 2014 Mar 31, 2014

Copy link to clipboard

Copied

This is not the first problem that's occurred when removing an old version after installing the new, which is why the recommendation is to not do that.

If you want to remove an old version, do that before installing the new one.

You may have to reinstall CC to get this working again.

http://helpx.adobe.com/creative-suite/kb/cs5-cleaner-tool-installation-problems.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2015 Oct 04, 2015

Copy link to clipboard

Copied

Question.  Did you upgrade to a new operating system on your computer?    

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2017 Jun 14, 2017

Copy link to clipboard

Copied

Hey vinay,

It seems like i have the same issue here..

my Specs:

Schermafbeelding 2017-06-14 om 19.46.52.png

everything is up to date:

Schermafbeelding 2017-06-14 om 19.48.03.png

screenshot of current project (animating lyrics for a music video so i've made cuts in a "matte layer")

Schermafbeelding 2017-06-14 om 19.50.10.png

Any Advice on the matter?

Cheers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 07, 2017 Oct 07, 2017

Copy link to clipboard

Copied

HI. I have the same problem.

Were you able to find a solution for this?

Thanks a lot!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2015 Jul 15, 2015

Copy link to clipboard

Copied

hello vinay,

I navigated to this path: C:\Program Files (x86)\Common Files\Adobe\dynamiclinkh. But unfortunatley i got only the cs 6 folder with the ".exe" in there.

I already have a newer version of after effects but it doesn`t show up in the folder. The same problem with premiere cc...

How can I get these folders ?

Thx for your help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 11, 2017 Dec 11, 2017

Copy link to clipboard

Copied

I am also having the exact same issue with same exact screen shot as above mac.  i only have cc2018 installed of photoshop, premiere and after effects.  iMac 2017 4.2Ghz Intel Core i7 - Ram: 32 GB 2400 MHz DDR4 / Graphics Card: Radeon Pro 580 8192 MB.  When I select the clip to go out to photoshop or after effects all of those options are greyed out. (Exact same screen as above user)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2017 Dec 14, 2017

Copy link to clipboard

Copied

I have the same problem here. I just tried to update both Premier and After Effects but still the same problem. Any solution?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 21, 2017 Dec 21, 2017

Copy link to clipboard

Copied

I have the same problem with my mac and I have all the updated versions

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 01, 2018 Mar 01, 2018

Copy link to clipboard

Copied

Having the same issue, both fully up to date on CC 2018. I'm on a mac running OSX 10.11.6

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 01, 2018 Mar 01, 2018

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 01, 2018 Mar 01, 2018

Copy link to clipboard

Copied

So just so I'm clear, try using the CC manager to uninstall then reinstall Premiere and AE, and use the cleaner tool only if I have installation problems?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 01, 2018 Mar 01, 2018

Copy link to clipboard

Copied

Use the cc app to deinstall

run cleaner tool to clean everything out.

install from cc app.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines