"Replace With Clip" not working

Explorer ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

I just upgraded to Premiere Pro CC 2017. Much to my dismay, the "Replace With Clip" functionality is not working.

I've restarted Premiere and restarted my computer with no results. I'm certain I have the clip selected in the bin and the clip selected in the timeline.

I'm working on a PC running Windows 7 with plenty of RAM (16GB). I've never had this problem until I upgraded to 2017.

Here's a screenshot. The "Replace With Clip" item is greyed out in the contextual menu. My keyboard shortcut to "Replace With Clip from Bin" does not work either.

I use this function all the time and need to find a solution pronto!

Premiere Pro 2017 - replace clip unavailable.jpg

Views

18.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Nov 20, 2017 Nov 20, 2017
thxapproved2: You are right; Replace With Clip works only if you select the clip in the main Project panel, not if that same clip is in a floating panel.This bug is not new to Premiere Pro 12.0 (2018), however. This problem existed also in ver. 2017.1. The last time it worked was in ver. 2015.1. Please file a bug report: Feature Request/Bug Report Form Here it works in 2015.1:Here it does not work in 12.0 (same problem in 2017.1):

Likes

Translate

Translate
LEGEND ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

I can't recreate this problem. also tried Ai files. have you tested if this happens with all clips? video? other?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

It happens on all types of clips.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

could be corrupted preferences? try resetting it: FAQ: How to reset preferences in Premiere Pro? in the meantime you can Alt drag the new over the old I suppose.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

Alt-drag works. I never knew about that method.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2019 Jul 26, 2019

Copy link to clipboard

Copied

thank you thank you! Alt(Option)-Drag is the only thing that worked for me!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 01, 2017 May 01, 2017

Copy link to clipboard

Copied

Got 3 hours into my template for work, only to realize this function no longer works with the latest update. Please, Pretty Please Adobe, fix this RIGHT NOW

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

patricke23597635  wrote

Got 3 hours into my template for work, only to realize this function no longer works with the latest update. Please, Pretty Please Adobe, fix this RIGHT NOW

what exactly does not work? what kind of clip do you have there? what assets are you trying to replace? I have not being able to reproduce Op's issue and Ai files can be replace as expected. please specify the exact nature of the problem with screenshots/video capture if possible

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

The whole "Replace Clip" drop down and tooltip options are grayed out. I'm trying to replace a png, with another png from my bin. The issue is across the board with all types of content and clips affected (stills, audio, video). It's like the latest update completely broke the coding for this kind of behavior. The Alt Drag method works (and bailed me out yesterday, thanks) but is tedious. Screenshots of the Greyed out tooltips attached. Nuking all of my preferences just to MAYBE fix this issue isnt really an option either.

Screen Shot 2017-05-02 at 8.56.52 AM.png

Screen Shot 2017-05-02 at 8.58.51 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 09, 2017 May 09, 2017

Copy link to clipboard

Copied

I'm having the exact problem.  I can't access the Replace from Bin option because Replace With Clip is greyed out. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 12, 2017 May 12, 2017

Copy link to clipboard

Copied

Exactly the same synthoms.  Have used this function since day one on all other versions through time, but after last update (may 2017) this option is "grayed out" but not the other options.  (Replace With Clip --> From Bin)

0000aaaa.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 13, 2017 May 13, 2017

Copy link to clipboard

Copied

Can you upload a file that does this problem? Maybe a project file too? If we cab reproduce it we might find a workaround or accurately report it

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 13, 2017 May 13, 2017

Copy link to clipboard

Copied

Make new project, import old one and try again.

See how that will work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 15, 2017 May 15, 2017

Copy link to clipboard

Copied

The Plot thickens, I managed to get Replace with Clip from Bin functionality working again by closing out ALL Project panel tabs except for one. I have a dual monitor setup, and Premiere was sneakily opening up another project tab, causing there to be two project tabs open (one on each monitor). Premiere get's extremely confused trying to figure out with project pane get's priority when two are open.

TLDR; Make sure only ONE instance of the Project Pane is open, that seemed to fix the issue for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

LATEST

This worked for me closing all the other project panels. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2017 May 24, 2017

Copy link to clipboard

Copied

I'm having the same issue with all my projects both old (prior to update) and new (created after update). It is very frustrating as I have several weekly clients that require simply the replacement of pics and fonts on the timeline with other pre-made  pics and fonts stored in the bins. Alt-drag works but the point is that there has been a heavily used "Replace Clip" option in the past and that there is still a tease of it being there.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2017 May 24, 2017

Copy link to clipboard

Copied

Did you try my fix by Hunting down and closing any copies of your project bin?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 19, 2017 Jun 19, 2017

Copy link to clipboard

Copied

I've been experiencing the same issue. Here's my write-up:

Description of Bug: When multiple bin panels are open, PPro 2017 will only allow the “Replace Clip from Bin” command from the most recent open bin. Previous versions allowed this command from any bin panel.

Steps to reproduce bug:

  • Open project.
  • Open a second bin panel.
  • Select a clip in the original bin panel.
  • Select a clip in an open sequence.
  • Right click the selected clip and navigate to the “Replace With Clip” menu. Observe the submenu, the “From Bin” option is not selectable.

Expected behavior: In previous versions of PPro, the replace with clip from bin command was available from any open bin panel. This made for simple navigation for large projects with multiple replaceable elements. In it’s current state in 2017, one can only have one bin panel open, which requires a LOT of scrolling to locate replaceable elements.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2017 Jun 27, 2017

Copy link to clipboard

Copied

I found this to work:

1. copy clip to desktop (just to make sure you have a backup).

2. select "Make offline" from the control-click menu and choose the "Media files are deleted" option.  (I got an error that it could not delete but still took it offline and did not delete the media)

3. Select replace footage. 

Step 2 was never necessary before but I guess they have a bug in the system?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 17, 2017 Jul 17, 2017

Copy link to clipboard

Copied

Add me to the list of people this bug is giving trouble to. Trying to replace an MP4 clip on the timeline with a different MP4 from the bin, only to have the items greyed out on the list. I am used to doing this all the time. ADOBE!!! Seriously. Help here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 21, 2017 Jul 21, 2017

Copy link to clipboard

Copied

Bill et al.: Does isaakwit's workaround work for you?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 21, 2017 Jul 21, 2017

Copy link to clipboard

Copied

Same here, I experienced this bug after the last update (for me it was yesterday).

I got it to work by closing every bin-window except one. If you have multiple open, you can only replace with clips from source monitor.

Please fix this quick, i am also relying on this function.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 21, 2017 Jul 21, 2017

Copy link to clipboard

Copied

Everyone on this thread should post their experience here so the product team sees it: Feature Request/Bug Report Form

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 01, 2017 Sep 01, 2017

Copy link to clipboard

Copied

I'm having the same issue.  Replace from bin is randomly available or not available, and even when available, it often does nothing.  Previous version of PP worked just fine.  I often have to load the replacement clip/item into the source monitor and then do a replace clip from source monitor.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 18, 2017 Sep 18, 2017

Copy link to clipboard

Copied

Having the same problem here. In my workflow with previous versions, I could have ANY number of project windows open, displaying the contents of multiple bins. Premiere would remember the MOST RECENT clip i had selected in any bin, and allow me to perform a Replace With Clip > From Bin using that most recent selection.

Now, this no longer works. The "from bin" option remains greyed out unless a clip is selected in whichever bin window Premiere believes to be the "canonical" or "official" or "primary" project window. Even more frustrating, so long as any clip is selected in that "canonical" project window, this action will ignore ANY more recent selection in another bin.

This effectively makes is so that the Replace With Clip > From Bin ONLY works with one *SPECIFIC* bin. (which, BTW, premiere does not visually distinguish from all the other bins that are open...). As others have stated, this is a humongous pain when working with complex projects where we actually ORGANIZE our stuff.

This is even worse for me, as I work on highly templatized projects where I stay sane by automating as much tedium as possible using keyboard macros, so this change in behavior has caused me to go from a 2-click solution to a "multi-screen, scroll around and waste a bunch of time" approach. I really like it better when things just work

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines