"Software Only" encode option and no GPU usage in Premiere Pro CC 2019 and Media Encoder CC 2019

Explorer ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

Hi,

I've an issue with CC 2019. When I export a h.264 video, in the encoding options->performance there is "software only" with no other options.

- I've enabled CUDA acceleration in the project settings

- in the NVdia control panel i've enabled the CUDA settings in the specific software (Premiere and Media Encoder)

- in Media Encoder I selected the CUDA option

- the OS/Drivers/Premiere are up to date

- OS is fresh. I formatted tonight because I had another issue with premiere pro.

but, the GPU remains in idle, only CPU burns.

Can you help me?

Thanks

My PC:

i7 3770K 4.6ghz

16GB DDR3 2400mhz

1080Ti

Win 10 PRO 1809 with all updates

CC 2019 updated to 13.0.3 build 9, the latest

Driver 419.35

1.png

Views

7.2K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Mar 18, 2019 Mar 18, 2019
There's two completely different issues here.The first is a CPU issue. Even though the i7 3770K officially has QuickSync 'available', in showing the software only in the Summary section it means that either Pr isn't recognizing that Quicksync is available and operable ... or your computer isn't. I don't know what you have set in your Pr's Preferences for H.264 encoding, but go check to make sure you have that set to enable hardware encoding.Next ... the GPU is NOT at all linked to the "software ...

Likes

translate

Translate

Translate
Adobe Community Professional ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

How much VRAM on the 1080Ti?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

11GB

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

There's two completely different issues here.

The first is a CPU issue. Even though the i7 3770K officially has QuickSync 'available', in showing the software only in the Summary section it means that either Pr isn't recognizing that Quicksync is available and operable ... or your computer isn't. I don't know what you have set in your Pr's Preferences for H.264 encoding, but go check to make sure you have that set to enable hardware encoding.

Next ... the GPU is NOT at all linked to the "software encoding" in the summary section of the Export dialog. That is purely about Intel's QuickSync being 1) available on the CPU and 2) used.

If you are just doing a "straight" export without frame-size changes going on, no color say Lumetri or stuff like Warp, then the GPU won't be used much by Pr to begin with. Here's a link to the GPU Accelerated Effects list. What is on here gets GPU use, what isn't ... doesn't.

Neil

GPU Accelerated Effects: https://helpx.adobe.com/premiere-pro/using/effects.html

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

H264 hardware acceleration is enabled in the preference settings. I would like to cut and downsize (4K to FHD) a simple clip in h264. In this case the GPU is useless and it doesn't contribute at all in the exporting phase?

Senza titolo.png

Kevin-Monahan

1) I cleaned the video driver with DDU (Display Driver Uninstaller) and I installed a cleaned version of 419.35, but the GPU remains in idle.

2) I tried to create a new project but the issue remains

3) I tried to change to "software only" and then in "cuda" as suggested in the FAQs, but the GPU remains in indle.

I'll try to downgrade to 416.78

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

Yes, downgrade and report back. I'm running 416.78. It's running both the current an upcoming version of Premiere Pro perfectly, as well.

Kevin

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

Now seems to works well! The rendering time is halved even though the GPU remains in idle in task manager. 20min -> 9min with the same settings!

Steps:

1) Download 416.81 (I have not found 416.78) from here https://www.nvidia.com/drivers/beta

2) Go offline

3) Use Display Driver Uninstaller

4) Restart PC

5) Install the Nvidia Driver 416.81

6) Restart PC

7) Launch PP and now the rendering time is halved

The "software only remains"

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

I do not believe the GPU is doing any significant work in that case ... Kevin could confirm, though.

Neil

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

Hi Korra88,

Sorry about your issue. I'm running an earlier driver, 416.78 and it's running great on the most recent version of Premiere Pro. Can you try rolling back? Another thing you could try is a "clean reinstallation" of those GPU drivers: FAQ: Why is my GPU not available for Mercury Playback Engine GPU acceleration?

Thanks,
Kevin

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

Although Neil has the "correct" answer, I would like to add that the integrated Intel HD graphics MUST be enabled in order for the hardware H.264 acceleration to work at all. If you have the integrated on-CPU Intel graphics disabled, or if your Intel CPU lacks integrated graphics whatsoever, or if you're using any AMD CPU, you cannot have hardware acceleration at all because Adobe neither officially supports nor includes a hardware encoder specifically for NVIDIA GPUs, which is REQUIRED for the GPU to even accelerate H.264 encodes at all.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

Yes, my HD graphic card is disabled. I'll try to enable it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

I enabled my HD 4000 and now it's possible to select "hardware accelerated" option. The rendering time now is 8min instead of 20

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 03, 2021 Apr 03, 2021

Copy link to clipboard

Copied

Hi Korea, how do you enable the HD4000?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Sorry, Patrick, but you posted to a thread that had sat dormant for over two years. Intel had officially ceased all support for the 3rd-Gen CPUs (that means all models with the HD Graphics 4000 and HD Graphics 2500) in late 2020. The very last security-patched driver release for the Ivy Bridge CPUs was made available in October 2020. No further security patches will be made to these 3rd-Gen CPUs after October 2020 - ever.

 

Security patches, however, will continue for the 4th-Gen (Haswell) and 5th-Gen (Broadwell) CPUs until a future date to be determined; the most recent security patch came out this past February. Unfortunately, you cannot install this driver on your system at all.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

sooooo, I updated the GPU driver with the latest 419.35 with a clean installation (as previously), but now everything works well. I don't know why this time it works, but doesn't matter

Thanks for all your support

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines