Highlighted

Render and Replace Export

Community Beginner ,
May 17, 2020

Copy link to clipboard

Copied

Hello everybody!
Does Premiere take "Render and Replaced" clips as .mov files, as I replaced them, or is it using original Dynamic Link composition during export? There is a slight color banding in replaced clips and I don't want it in final export. I'm wondering if its using original AE compositions automatically (as it does with proxies) or should I do "Restore unrendered" by hand for all replaced clips?

Thanks.

I think banding comes from 10bit Rerendering.

 

Most likely. I'm trying to think of what codec has the best bit-depth that you could use to render and replace? ProRes 4444 or 4444 XQ? If you enable Render at Maximum depth you can get a 16bpc render with one of those.

 

Keep in mind at the end of the day this might be going down to an 8-bit final (or at least sub-32-bit) export right? Not that I don't stress that maintaining maximum quality for as much as the process as possible isn't a good thing (it is), but you still may be unable to avoid some poor gradiation when all is said and done.

 

That said, or you could just Render and Replace temporarily as a means to have a smooth preview, and then revert back to the AE Dyanmic Link on export, enable render at max depth for your final, and if the comp is 32-bit it should render off of that for your final. Although like I said, your final export may get similar gradiation.

Topics

Export, Performance

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Render and Replace Export

Community Beginner ,
May 17, 2020

Copy link to clipboard

Copied

Hello everybody!
Does Premiere take "Render and Replaced" clips as .mov files, as I replaced them, or is it using original Dynamic Link composition during export? There is a slight color banding in replaced clips and I don't want it in final export. I'm wondering if its using original AE compositions automatically (as it does with proxies) or should I do "Restore unrendered" by hand for all replaced clips?

Thanks.

I think banding comes from 10bit Rerendering.

 

Most likely. I'm trying to think of what codec has the best bit-depth that you could use to render and replace? ProRes 4444 or 4444 XQ? If you enable Render at Maximum depth you can get a 16bpc render with one of those.

 

Keep in mind at the end of the day this might be going down to an 8-bit final (or at least sub-32-bit) export right? Not that I don't stress that maintaining maximum quality for as much as the process as possible isn't a good thing (it is), but you still may be unable to avoid some poor gradiation when all is said and done.

 

That said, or you could just Render and Replace temporarily as a means to have a smooth preview, and then revert back to the AE Dyanmic Link on export, enable render at max depth for your final, and if the comp is 32-bit it should render off of that for your final. Although like I said, your final export may get similar gradiation.

Topics

Export, Performance

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Enthusiast ,
May 17, 2020

Copy link to clipboard

Copied

From my understanding, when you do a render and replace, the new render essentially becomes your new master clip for all uses. Other than keeping track of what the original clip or AE comp was, everything else is ignored, including changes made to the source (unless of course, you restore unrendered)

 

Becuase of that, I'm pretty sure it doesn't behave like proxies where the master footage gets used for an export regardless of  if proxies are enabled currently.

 

For any clips causing you trouble, you may need to restore unrendered and export with the Dynamic Link comp, or export a master copy out of AE that is to your liking and put that in your edit instead.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 17, 2020

Copy link to clipboard

Copied

I'm wondering if you have a color management mismatch between Premiere and AfterEffects.

 

I would also uncheck "composite in Linear color" in the Sequence settings and see if the banding goes away. You may need to uncheck that, then Render/Replace again.

 

I'd test that first.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 18, 2020

Copy link to clipboard

Copied

There is no bandig when I'm editing ae compositions on my Premiere timeline, but after Render and replacing it with GoPro Cineform 10bit .mov, it appears. I need to export video with aep composition's original quality so it looks like I should  restore unredered all ae clips after edit is done.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 18, 2020

Copy link to clipboard

Copied

What are you color management settings in AE?

 

And again, is Composite in Linear Color checked in either place? That is often a problem child.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 18, 2020

Copy link to clipboard

Copied

bogdanr19131401_0-1589828819333.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 18, 2020

Copy link to clipboard

Copied

Just went to the Premiere "bible", Jarle Leirpoll's massive tome on all things in Premiere. And I do mean massive ... 1254 pages, 4 lbs in the printed version. But it's pretty comprehensive.

 

His recommendations: In AE, set color to:

Depth: 32 bit float

Working space: HDTV (Rec.709)

The Linearize Working Space should be checked. (To match with Premiere's base setting of Composite in Linear color.)

 

This tends to work with the Premiere 'base' settings for most people. With these settings, if there is an issue in Premiere, then one would say start by unchecking the "composite in linear color" option in Premiere.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 18, 2020

Copy link to clipboard

Copied

Unchecked Composite in Linear Color, renrendered and banding is still present.

bogdanr19131401_5-1589830247804.png

 

bogdanr19131401_4-1589830217230.png

Not sure if it will be visible, it is a very dark part of the video. On the first picture is Render and replaced 10bit cineform clip, and on second is aep composition. I think banding comes from 10bit Rerendering. In AE my composition is 32bit and there is a vignette effect. Probably 10bit rerender loses some of that 32bit vignette information?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Enthusiast ,
May 18, 2020

Copy link to clipboard

Copied

I think banding comes from 10bit Rerendering.

 

Most likely. I'm trying to think of what codec has the best bit-depth that you could use to render and replace? ProRes 4444 or 4444 XQ? If you enable Render at Maximum depth you can get a 16bpc render with one of those.

 

Keep in mind at the end of the day this might be going down to an 8-bit final (or at least sub-32-bit) export right? Not that I don't stress that maintaining maximum quality for as much as the process as possible isn't a good thing (it is), but you still may be unable to avoid some poor gradiation when all is said and done.

 

That said, or you could just Render and Replace temporarily as a means to have a smooth preview, and then revert back to the AE Dyanmic Link on export, enable render at max depth for your final, and if the comp is 32-bit it should render off of that for your final. Although like I said, your final export may get similar gradiation.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...