Highlighted

Ripple-shifting captions works inconsistently

Most Valuable Participant ,
Jun 08, 2020

Copy link to clipboard

Copied

I'm working on subtitles for some videos in many languages, and I'm at a loss to figure out the cause. In some projects, I can ripple-shift captions by holding down Control and dragging one of the caption-handles: 

WillRipple.gif

 

However, in other files, attempts to ripple-shift cause the shifted sub to glitch out:

WontRipple.gif

ReallyWont.gif

 

I really have no explanation as to why it's happening. I'm importing .srt files, and I'm making them exactly the same way with the same tools (just SubtitleEdit, although doing it in Aegisub doesn't work any differently). I'm processing them identically once they're in Premiere (anchoring them all at once, messing with the vertical position, adding hard returns to break the subs into two or three lines). . It's not langugage-based, either - one set of Somali subs can be ripple-shifted without issue, but in a second video it glitches out like the Romanian above. IS this a Known Issue? My casual reading of the Premiere forums indicates that maybe captioning issues are common in Premiere. 

 

They're all  in .srt format at import

They're all Open Captions format in Premiere

Changing the Import Options doesn't alter this behavior

 

Any ideas?

 

Topics

Error or problem

Views

325

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Ripple-shifting captions works inconsistently

Most Valuable Participant ,
Jun 08, 2020

Copy link to clipboard

Copied

I'm working on subtitles for some videos in many languages, and I'm at a loss to figure out the cause. In some projects, I can ripple-shift captions by holding down Control and dragging one of the caption-handles: 

WillRipple.gif

 

However, in other files, attempts to ripple-shift cause the shifted sub to glitch out:

WontRipple.gif

ReallyWont.gif

 

I really have no explanation as to why it's happening. I'm importing .srt files, and I'm making them exactly the same way with the same tools (just SubtitleEdit, although doing it in Aegisub doesn't work any differently). I'm processing them identically once they're in Premiere (anchoring them all at once, messing with the vertical position, adding hard returns to break the subs into two or three lines). . It's not langugage-based, either - one set of Somali subs can be ripple-shifted without issue, but in a second video it glitches out like the Romanian above. IS this a Known Issue? My casual reading of the Premiere forums indicates that maybe captioning issues are common in Premiere. 

 

They're all  in .srt format at import

They're all Open Captions format in Premiere

Changing the Import Options doesn't alter this behavior

 

Any ideas?

 

Topics

Error or problem

Views

326

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 09, 2020

Copy link to clipboard

Copied

That is odd. And apparently random misbahavior is always the toughest to sort.

 

Just FYI, here is a post I made re how the ripple update worked going right and left.

https://community.adobe.com/t5/premiere-pro/how-to-move-all-captions-at-once/m-p/11163048#M273792

 

But it looks to me like you are totally on track with your method.

 

The glitch appears to be the caption being extended snapping to a very long duration. In the middle screenshot, we cannot see the end of the caption stream, and the caption end snaps off screen. In the third screenshot, we can see the end of the caption stream, and it snaps to that location.

 

But I couldn't get any odd behaviors based on caption stream length or relationship to the end of the video track etc.

 

I wonder about the new snap to CTI behaviors, but that did not seem to effect it either.

 

Malfunctioning/over-sensitive mouse might do something like this. And it is hard to check, since there's no definite indication that the ripple behavior is enabled/where it will end.

 

Let us know what you learn.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Jun 10, 2020

Copy link to clipboard

Copied

Well, one thing I learned is that if you continually delete the subs from the Media Browser, edit the .srt file with an external app, and then re-import the edited .srt file  repeatedly, then eventually you will find that you are able to ripple-shift subs. Sometimes it clicks after a single delete-edit-reimport cycle, other times it will continue glitching until I'm twenty or thirty delete-edit-reimport cycles into a project, at which point the power of ripple-shifting subs will suddenly reappear. Certainly a time-waster, but much faster than trying to retime every single caption by hand in ten languages. 

 

Can I assume that, if I wanted to report this as a Premiere captions bug, that the appropriate place is adobe-video.uservoice.com? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 10, 2020

Copy link to clipboard

Copied

Yes, that is the correct place to report the bug.

 

From your screenshot, you have one caption stream in the sequence? And you delete the stream when finished and add another one? Or you are duplicating the sequence and working with many caption streams at once? Or what?

 

They'll have trouble with this if they can't replicate the bug. But definitely file it.

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Jun 13, 2020

Copy link to clipboard

Copied

Well, each language gets its own project, to make it easier for me to hand off a language to a third party, if necessary. So each project gets a single caption stream. The only time I need to delete & re-import the captions is if I need to edit it in an external application. If I use "Edit Original", I can't save the edited .srt file because I get an "Error: Access is Denied" message. 

 

Once I actually finish the project, I'll write up a bug report. I am honestly not that worried about reproducibility, as it's obvious from a quick glance at all of the many captions-related bug reports and feature requests that the whole captioning codebase needs some sustained attention. However, I just verified the portability of this issue - I started a new project on my desktop, moved the project to my laptop, and was still unable to ripple-shift the captions without glitching out,. So I should be able to give them a properly glitched project to examine. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 03, 2020

Copy link to clipboard

Copied

I encounter the same glitch while trying to ripple shift captions in Premiere 14.3. It used to work (I don't remember if the problem started after 14.0 or later). Now holding down command while dragging the end handle of a caption makes it about 1min30 longer, with no option to trim it down.

But I found a workaround: firstly, I drag the end handle of the entire caption effect to the desired position of the end of the subtitle line that I need to make longer, then hold down command while dragging the black segment end handle. This way, it sticks to the end of the effect. Last step is to drag back the effect end handle to its original length.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 23, 2020

Copy link to clipboard

Copied

Hey Folks,

 

Just wanted to jump in and say that I ran into this same problem, but I found that if I de-toggle track output and lock the video tracks I'm working on, I am able to ripple shift with no problem. I know this is far from ideal, but it has helped me out tremendously, as I am working on a project that requires multiple translations and captions and I was losing my mind over having to re-do subtitles every time. Hope this helps someone out! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 23, 2020

Copy link to clipboard

Copied

UPDATE: So, I noticed you don't even have to de-toggle the track output. Just lock the video tracks you're working on and ripple shift works.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...