Sample plugins(SDK_CrossDissolve and Vignette) is not working without CUDA installed on MAC

Explorer ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

Hi, everyone!.

I checked sample plugins for gpu acceleration on MAC. (SDK_CrossDissolve and Vignett)

On Premiere Pro CC( or higher version) It is working correctly if CUDA are installed. but it is not working without CUDA.

What is the reason? (I think it is very basic question because I am beginner on plugin.... )

Looking forward to hearing back.

Regards,

Igor.

TOPICS
Premiere Pro SDK, SDK

Views

618

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Jan 22, 2018 Jan 22, 2018
The ProcAmp sample isn't dependent on CUDA and doesn't use CUDA for acceleration.  The other two samples as they are in the SDK need CUDA installed to load.  I hope to improve on this in a future release, but I haven't done it yet.

Likes

Translate

Translate
Adobe Employee ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

If those plug-ins demonstrate GPU acceleration, and if there is no GPU present, they will have a tough time working.

[I'm unfamiliar with those samples.]

What are you building?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

Hi, Bruce.

Thanks for your replay.

I'd like to make gpu accelerated some plugins like Vignette and SDK_CrossDisolve.

But the sample plugins are not working without CUDA installed on Premiere Pro CC.

(I am not sure if it is my mistake when compiling).

Most peoples are going to use plugins without CUDA installed.

I want to know if it is my mistake or it's impossible.

Regards,

Igor.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

I'm unsure whether those samples _require_ a GPU, or simply _support_ GPUs.

If it's the former, what you're describing is correct behavior. If the latter; yeah, that's a sample code bug. I've asked Zac (API Engineer in charge of PPro's C++ APIs) to investigate.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

Okay, thanks.

I am looking forward to hearing back.

Regards,

Igor.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 20, 2018 Jan 20, 2018

Copy link to clipboard

Copied

Hi, Zac.

I hope you are doing well.

I hope to know about this problem correctly.

Regards,

Igor.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 22, 2018 Jan 22, 2018

Copy link to clipboard

Copied

Hi Igor,

This is something that I would like to demonstrate in the sample plug-in in a future release.  Basically the plug-in needs to weak link against CUDA and query for its existence at run-time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 22, 2018 Jan 22, 2018

Copy link to clipboard

Copied

Thanks for your replay.

So you mean the sample plugins are not working without CUDA installed on current SDK version.

Right?

And are you going to solve the problem in the version 12 or another?

Regards,

Igor.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 22, 2018 Jan 22, 2018

Copy link to clipboard

Copied

The ProcAmp sample isn't dependent on CUDA and doesn't use CUDA for acceleration.  The other two samples as they are in the SDK need CUDA installed to load.  I hope to improve on this in a future release, but I haven't done it yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2021 Apr 25, 2021

Copy link to clipboard

Copied

Please let me know if you are able to compile the project without using CUDA.

I have installed CUDA toolkit 11.x but could able to compile the reference code.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2021 Apr 26, 2021

Copy link to clipboard

Copied

LATEST

Hi All, 

I am able to compile all other sdk examples except SDK_CrossDissolve, SDK_ProcAmp and Vignette.

I have installed

CUDA toolkit 11.3,

Boost

Python

Premiere Pro Plug-in SDK CC2019

After Effects SDK

IDE : Visual Studio 2017

 

Regards,

Irfan

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines