Highlighted

SLOW - Essential Graphics Lagging PPro - ver. 14.4

Community Beginner ,
Oct 02, 2020

Copy link to clipboard

Copied

I haven't had any issues with Premiere until they added the Essential Graphics.  I am using them on my timeline and they slow down the computer terribly.  It doesn't matter how many layers of graphics I have on the timeline, it slows down everything and the program is lagging and sluggish.

 

When I delete the Essential Graphics from the timeline the project gets stable.  The original Titler in Premiere worked much better.

 

Is there a solution for this?

 

Thanks for you help!
Larry

 

MAC Pro,

OS Catalina ver 10.15.7

Dual AMD FirePro D700 6GB

16GB RAM

3GHz 8-Core Intel Xeon E5

TOPICS
Editing, Effects and Titles, Freeze or hang, Performance

Views

48

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

SLOW - Essential Graphics Lagging PPro - ver. 14.4

Community Beginner ,
Oct 02, 2020

Copy link to clipboard

Copied

I haven't had any issues with Premiere until they added the Essential Graphics.  I am using them on my timeline and they slow down the computer terribly.  It doesn't matter how many layers of graphics I have on the timeline, it slows down everything and the program is lagging and sluggish.

 

When I delete the Essential Graphics from the timeline the project gets stable.  The original Titler in Premiere worked much better.

 

Is there a solution for this?

 

Thanks for you help!
Larry

 

MAC Pro,

OS Catalina ver 10.15.7

Dual AMD FirePro D700 6GB

16GB RAM

3GHz 8-Core Intel Xeon E5

TOPICS
Editing, Effects and Titles, Freeze or hang, Performance

Views

49

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 02, 2020 1
Adobe Community Professional ,
Oct 02, 2020

Copy link to clipboard

Copied

Hello larry

 

Please try to switch the renderer 

  1. In Premiere Pro, choose File > Project Settings > General>renderer
  2. Under the Video Rendering and Playback section, select the Renderer as Mercury Playback Engine GPU Acceleration or Mercury Playback Engine Software Only if you already have the gpu acceleration as an old option

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2020 0