Specific Font Displaying Incorrectly

Community Beginner ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Hello!

 

I'm currently working on a project that requires text in a different language to follow voice in a video (Telugu specifically), and I'm having an issue with the font displaying correctly.

 

I'm using "Adobe Telugu", and copying over text from Word (as I do not know the language). It appears that the text copies/pastes fine, and when looking at the essential graphics panel, it displays correctly. However, when viewing over the footage, certain symbols are changed, symbols are added, etc.

 

I have attached a screen shot of the session (please excuse the hideous timeline). If you look at the three text areas, you'll notice on screen that an extra symbol is added, and one has been completely altered. This has been a reoccuring issue within this project. I am using a stock Adobe essential graphic, and I've tried others I have, but all seem to have the same issue.

formatting issue.png

 

2018 MacBook Pro (10.14.6)

2.9 Ghz Intel Core i9

32 GB 2400 MHz DDR4

Radeon Pro Vega 20 4 GB

1TB SSD Internal; Read/Write 2TB TB3 Glyph NVMe

Premiere Pro 2020 14.3.1

 

Thanks!

TOPICS
Editing, Effects and Titles, Error or problem, Formats

Views

26

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation