Highlighted

.srt import and editing not working in Premiere CC 2019

Explorer ,
Jan 08, 2019

Copy link to clipboard

Copied

Hello,

I have a big issue with .srt files. I used to import .srt and add them to a sequence, then I used to edit size etc.... It is ok in Premiere CC 2018 but, it seems that all edit settings are doing nothing to the text . To reproduce the issue you just have to open Premiere CC 2019, load a .srt file and place it on the timeline, and try to edit captions settings (font size, font etc...). In my case I can see modification in the preview thumbnail of each caption in the "Captions" tab but, nothing is visible on the monitor, the text remains the same (very small and... that's it ).

Can you help me with this bug ? Thank you !

Views

10.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

.srt import and editing not working in Premiere CC 2019

Explorer ,
Jan 08, 2019

Copy link to clipboard

Copied

Hello,

I have a big issue with .srt files. I used to import .srt and add them to a sequence, then I used to edit size etc.... It is ok in Premiere CC 2018 but, it seems that all edit settings are doing nothing to the text . To reproduce the issue you just have to open Premiere CC 2019, load a .srt file and place it on the timeline, and try to edit captions settings (font size, font etc...). In my case I can see modification in the preview thumbnail of each caption in the "Captions" tab but, nothing is visible on the monitor, the text remains the same (very small and... that's it ).

Can you help me with this bug ? Thank you !

Views

10.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 08, 2019 4
Adobe Community Professional ,
Jan 08, 2019

Copy link to clipboard

Copied

I am not having problems with this basic functionality in 2019. There has been an issue that I have see on occasion (and other users complain of it also occurring randomly), where the appearance in the program monitor is not in sync with changes made - but the changes are usually visible in the captions panel.

That is similar to what you describe, but I do not recall it happening from the beginning of editing.

First, more info: what OS, exact dot version of PR, a screenshot of your captions panel.

If you can post the srt you are importing, I can take a look.

Relatively new is the ability to change the import characteristics. Look in the Captions Panel in the lower left for "Import Settings." If you know you need to change the font style, size, etc for all your captions, this does the trick.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2019 0
Explorer ,
Jan 11, 2019

Copy link to clipboard

Copied

Thank you for your feedback !!!! After some tests I finally find out how to make .srt works in Premiere, but.... for me that is a bug !

1 - Start Adobe Premiere CC 2019.
2 - Load the video on the timeline.3 - Import .srt files and add it to the timeline. From now I can't edit the .srt layout (only have the preview in the Captions tab).

4 - SAVE AS the project
5 - Close Adobe Premiere CC 2019, start the software again.

6 - Load the project and now you can edit captions layout.

If you import other .srt, edit won't be possible until you save the project and restart the app....

To sum up.... when you import .srt you have to save the project before any edit of the captions layout..... (sic)....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 11, 2019 9
Adobe Community Professional ,
Jan 11, 2019

Copy link to clipboard

Copied

Glad you found a way. I do not have to take those steps to get a caption stream to edit. BUT, when I do occasionally get this bug, it is steps like yours that may get it working again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 11, 2019 0
New Here ,
Mar 21, 2019

Copy link to clipboard

Copied

Thank you! I was having same issue and now using this method I can edit the captions. 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 21, 2019 0
Community Beginner ,
Dec 11, 2019

Copy link to clipboard

Copied

Thank you very much! I was stuck for one hour until I read your post.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019 0
New Here ,
Jan 08, 2020

Copy link to clipboard

Copied

This worked for me! Had the same issue and messed around with settings for literally hours..couldn't figure it out.

Once again, Premiere being unreliable. Classic. Thanks for finding a solution to this bug.

 

T

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2020 0
New Here ,
May 26, 2020

Copy link to clipboard

Copied

This has helped so much. Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 26, 2020 0
Jewra LATEST
New Here ,
Sep 30, 2020

Copy link to clipboard

Copied

Thank you! Works for me as well! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2020 0
New Here ,
Mar 30, 2019

Copy link to clipboard

Copied

The Import Settings for captions looks like a great feature but is not affecting the import. SRT captions still appear very small, apparently set for 720x480. I'm working in ProResHQ, 1920x1080, 29.97 DF. Any suggestions? SCC files are sized correctly but they're just too ugly. Manually adjusting font and size is not an option on long shows.  Thanks for any tips.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 30, 2019 0
Adobe Community Professional ,
Mar 30, 2019

Copy link to clipboard

Copied

Please post a screenshot of the caption import settings you are using.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 30, 2019 0
New Here ,
Mar 30, 2019

Copy link to clipboard

Copied

caption settings.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 30, 2019 0
Adobe Community Professional ,
Mar 31, 2019

Copy link to clipboard

Copied

It is working as expected for me. Check the pixel size of the caption stream - several ways, but look in the caption window.

But I think your problem is that the default for font size is "18" - pixels! For testing in a 1920x1080 sequence, I am using 40-50.

Even if the import does not go as planned, just select all the captions and change. In 2019 (don't remember when it changed), shift click or right click -> select all works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2019 0
New Here ,
Mar 31, 2019

Copy link to clipboard

Copied

Thanks for the suggestions, Stan. I've tried both but with no change to the captions. I changed the import settings to 50-point font but they imported at 18. I "selected all" within the caption window, changed to 50, but the captions on screen remain small. I'll try relaunching program and see if this makes a difference. Also, working in High Sierra, 10.13.6.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2019 0
New Here ,
Mar 31, 2019

Copy link to clipboard

Copied

I don't know if this matters but the .SRT file was created by rev.com.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2019 0
Adobe Community Professional ,
Mar 31, 2019

Copy link to clipboard

Copied

I can't look till later today. Odd.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2019 0
New Here ,
Mar 31, 2019

Copy link to clipboard

Copied

I have as a new project, closed and reopened, and the caption feature works correctly. Thank you, Stan.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2019 0
New Here ,
Mar 31, 2019

Copy link to clipboard

Copied

meant to write "saved as" a new project.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2019 0
Adobe Community Professional ,
Mar 31, 2019

Copy link to clipboard

Copied

Not the first time something like that has captions working again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2019 0
New Here ,
Mar 31, 2019

Copy link to clipboard

Copied

Strangely, the captions returned to micro size when I changed workspace view, but they returned to 50-point font this time with the "select all" in the caption window. Very buggy, but it seems to have worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2019 0
New Here ,
Apr 06, 2019

Copy link to clipboard

Copied

The "Save As" trick worked for me.  THANK YOU!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2019 0
Participant ,
Apr 20, 2019

Copy link to clipboard

Copied

If anyone could shed some light in the following issue I'd be grateful..

Working in PP with the captions track editing, finessing timings, duration...
Realizing they are open captions, where closed captions are needed.
Cannot find way to convert open captions to closed captions.So as a workaround I export captions as srt from PP.
I Set import Settings to CEA 708.

Then I Import the previously exported captions.
They come in as closed captions. Nice!

However their length is severely chopped.
Not even half of the exported captions make it back in.
I tested exported captions and are full length, but for some reason, when I import them not even a minute comes in...
Any suggestions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2019 0
Adobe Community Professional ,
Apr 20, 2019

Copy link to clipboard

Copied

Look at the exported file and examine the first caption that does not come in.

Maybe paste here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2019 0
Participant ,
Apr 21, 2019

Copy link to clipboard

Copied

https://forums.adobe.com/people/Stan+Jones  wrote

Look at the exported file and examine the first caption that does not come in.

Maybe paste here.

nothing different found in the format.
here is the first caption missing:

11

00:00:44,146 --> 00:00:47,249

by the surrounding circumstances

or influences

Pehaps the generated xml has issues?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2019 0
Adobe Community Professional ,
Apr 21, 2019

Copy link to clipboard

Copied

An exported .srt is not xml, it's plain text. And even a blank line can break a reimport.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2019 0
Explorer ,
Jun 20, 2019

Copy link to clipboard

Copied

First off, the entire captions handling in Premiere Pro is buggy as hell. Adobe knows this, and has been saying for 18 months that they're going to fix the problems. They still have not corrected any of the issues.

I've also experienced the failure of Premiere to update captions on the timeline in response to my changes. My typical workflow is to import .srt, select all the individual captions using the "Captions" window and change the font size to 55. About one time out of every four, nothing will happen on the timeline, but the captions in the preview window will show the change. I have to quit Premiere and then restart it for the timeline to update. Half the time Premiere won't restart properly, so I have to restart my machine.

You might be saying, "But Bill, just change your caption import settings to import .srt files at 55 point font size, and you'll never have to change the size in the 'Captions' window again." Yes, in theory that is how it should work. But my caption import setting have NO EFFECT AT ALL on the .srt files I import. I have my font size set to 55, but every .srt I import comes in at 18 points. I can change settings all day, and Premiere just ignores them.

I submitted another post about the acknowledged bug that bottom-justifies all text against the caption background:

Re: Open caption files are bottom justified against background

The response I received was to up-vote the bug fix at the link below, and maybe try a third-party captioning tool. There is no such tool for Premiere, so essentially we're just out of luck. The functions don't work reliably, and there's little chance Adobe is going to fix them anytime soon. Vertically align Open captions text against background box. – Adobe video & audio apps

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2019 0
Explorer ,
Jun 21, 2019

Copy link to clipboard

Copied

OK, I need to respond to my own post to 1) admit that I was doing something wrong, and 2) offer some guidance:

The steps below show the process for changing your import settings. The changes to the settings were actually working for me, but I was getting confused by the height/width setting under "Video Settings." Every other frame-size setting in Premiere Pro is width/height, so I wasn't reading the settings labels correctly and was transposing the values. That's on me.

That said, I can't guarantee that these settings will work for everybody, but Here are some tips for changing the default caption import settings and minimizing the caption alignment bug - an acknowledge bug that you can up-vote here - Vertically align Open captions text against background box. – Adobe video & audio apps

To modify import settings:

- Go to "Window", and open the "Captions" window

- Click the "Import Settings" button

Caption settings.png

- Under "Video Settings", enter 1080 into the "Height" value and 1920 into the "Width" value

- CAUTION, the values are shown as height/width instead of width/height.

Caption import size setting.png

To minimize the caption alignment bug:

Under "Alignment Settings" and change the "Line Spacing" value from 50% to 100%. This will move your text up against the background color instead of bottom-justifying the text to the background color.

Caption import serttings 100%.png

Here are two examples of the text alignment. The first shows the default 50% line spacing, the second shows 100% line spacing. Not perfect, but better...

Caption import serttings 50%.png

Open caption 100% line spacing.png

To modify the default text size for captions:

Under "Style Settings", uncheck the "Proportional" box to the right of "Font Size", and enter your desired font size instead. A font size of 48 to 52 usually works well for a 1920 x 1080 frame size.

Caption import font setting.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2019 1
New Here ,
Oct 20, 2019

Copy link to clipboard

Copied

Thank you! You've saved me from a world of pain!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2019 0
Explorer ,
Jun 21, 2019

Copy link to clipboard

Copied

More observations from working with captions in Premiere.

If you import a .srt file, then change your import settings, then delete the .srt file and re-import it, Premiere will apply the settings that were in effect when you originally imported the .srt. It doesn't seem to matter how many times you delete and import, Premiere stores the original settings someplace, ignores your current settings and applies the original settings instead.

I found that I had to change the .srt filename - EG adding a "2" to the filename - before Premiere would finally "forget" the original import settings and apply my current import settings. This behavior is the reason I thought changing my import settings had no effect at all on importing .srt files - because it doesn't if you try re-importing a file that Premiere has already imported. 

I also just experienced the "no-changes-take-effect" issue - wherein changes I make in the "Captions" window - EG font size, background opacity, etc. - aren't reflected on the timeline until after I quit Premiere and restart.

So if you're pulling your hair out with frustration, please know that you it isn't you, it is in fact the application. Maybe some of these tips and workarounds will help alleviate your frustration. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2019 2
New Here ,
Dec 27, 2019

Copy link to clipboard

Copied

Slightly renaming the file name worked! I was reimporting files all evening long, trying to make the import settings take effect. 

I thank thee!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 27, 2019 1