System Compatibility Report

New Here ,
Jan 03, 2021

Copy link to clipboard

Copied

Hi... I’m trying to work on my premiere pro (window 10) and constantly get System Compatibility Report. Tried to download but got this... what should I do?

522CE17F-DF9E-4664-9423-B19AC8F95479.jpeg

BE2A6D77-9BA2-46A6-8E56-C3DC263B0436.jpeg

TOPICS
Error or problem

Views

23

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

System Compatibility Report

New Here ,
Jan 03, 2021

Copy link to clipboard

Copied

Hi... I’m trying to work on my premiere pro (window 10) and constantly get System Compatibility Report. Tried to download but got this... what should I do?

522CE17F-DF9E-4664-9423-B19AC8F95479.jpeg

BE2A6D77-9BA2-46A6-8E56-C3DC263B0436.jpeg

TOPICS
Error or problem

Views

24

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 03, 2021 0
Adobe Community Professional ,
Jan 03, 2021

Copy link to clipboard

Copied

Time to upgrade. Though a direct replacement is available on NewEgg.com for $26.99!! 🙂

 

Your gpu is too underpowered to run the latest version of PP. And the nvidia driver will not install because your gpu is too old for the new (and required by PP) drivers.

 

Time to get out the wallet. And if the rest of your system is equally powered as that piece, time for a new machine.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 03, 2021 0
MyerPj LATEST
Adobe Community Professional ,
Jan 03, 2021

Copy link to clipboard

Copied

Check the system requirements here:

https://helpx.adobe.com/mena_en/premiere-pro/user-guide.html/mena_en/premiere-pro/system-requirement...

 

Check out the NOTE towards the top:

Upcoming changes to operating system support

Effective in January 2021, new releases of the Creative Cloud video and audio applications will require macOS 10.14 (or later) or Windows 10 v1903 (or later).

This is in keeping with our policy to support the current and the most recent previous version of each operating system, which allows us to focus our resources on modern architectures. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 03, 2021 0