Highlighted

Timecode Export Bug when using GPU Acceleration

New Here ,
Aug 16, 2020

Copy link to clipboard

Copied

Hello everyone, 

 

Thanks in advance for any support provided. 

 

I have a 20 minute long sequence, during which I have a countdown time that cross-fades in and out every so often. 

 

Now - here's the problem:

  • If I export this asset out using GPU Acceleration CUDA...
    • The asset will export within 1 hour or so (Great!)
    • Every timecode transition within the final Export Media file with additionally show a second, full timecode timestamp for the duration of the cross-fade. (Bad!)
    • Here's a screenshot of what that looks like:
      • PP Timecode Bug.png
    • This makes the entire asset unusable. 
  • If I export this asset without using GPU Acceleration CUDA...
    • This asset will export out over 12 Hours or so (AWFUL)
    • But it will NOT have the above mentioned Timecode display issue - However, the export time is simply not sustainable. 

 

Does someone know why GPU acceleration might be displaying rogue timecodes during cross-fade transitions? I really don't want to have to rely on my CPU to do the heavy lifting for exports as big as this...

 

Export Settings:

- H.264 .mp4

- 1080p

- VBR 2Pass @ 6Mbps Bitrate

- Final File Size is only 1GB. 

 

Hardware specs:

  • GPU is NVidia 2070
  • Intel i7-6700k @4.00 GHz
  • RAM: 16GB

 

Note: Have reposted this since the previous topic was marked as spam - I'm guessing because it had a hyperlink in it to an example vid. 

TOPICS
Effects and Titles, Error or problem, Export, Hardware or GPU

Views

70

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Timecode Export Bug when using GPU Acceleration

New Here ,
Aug 16, 2020

Copy link to clipboard

Copied

Hello everyone, 

 

Thanks in advance for any support provided. 

 

I have a 20 minute long sequence, during which I have a countdown time that cross-fades in and out every so often. 

 

Now - here's the problem:

  • If I export this asset out using GPU Acceleration CUDA...
    • The asset will export within 1 hour or so (Great!)
    • Every timecode transition within the final Export Media file with additionally show a second, full timecode timestamp for the duration of the cross-fade. (Bad!)
    • Here's a screenshot of what that looks like:
      • PP Timecode Bug.png
    • This makes the entire asset unusable. 
  • If I export this asset without using GPU Acceleration CUDA...
    • This asset will export out over 12 Hours or so (AWFUL)
    • But it will NOT have the above mentioned Timecode display issue - However, the export time is simply not sustainable. 

 

Does someone know why GPU acceleration might be displaying rogue timecodes during cross-fade transitions? I really don't want to have to rely on my CPU to do the heavy lifting for exports as big as this...

 

Export Settings:

- H.264 .mp4

- 1080p

- VBR 2Pass @ 6Mbps Bitrate

- Final File Size is only 1GB. 

 

Hardware specs:

  • GPU is NVidia 2070
  • Intel i7-6700k @4.00 GHz
  • RAM: 16GB

 

Note: Have reposted this since the previous topic was marked as spam - I'm guessing because it had a hyperlink in it to an example vid. 

TOPICS
Effects and Titles, Error or problem, Export, Hardware or GPU

Views

71

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 16, 2020 0
Adobe Community Professional ,
Aug 16, 2020

Copy link to clipboard

Copied

Try using a 1-pass export. Not sure why you'd use 2-pass with ony a 6Mbps bitrate ...

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 16, 2020 0
New Here ,
Aug 16, 2020

Copy link to clipboard

Copied

Thanks for the reply.

 

Bitrate is set to 6Mbps Max as that's the maximum bitrate the ingest server will take when playing this file. Any higher and there will be playback issues. 

 

However, it is a file for marketing on a large scale, so quality is still paramount. Hence the 2-pass export, which according to my research and general opinion results in better file sizes, higher quality compression and generally less render issues. 

 

Changing to 1-pass would lower the quality and likely only improve the non-GPU-assisted export time.

 

I'm not looking so much to improve my non-GPU-assisted export times - I know they will always be garbage when relying solely on the CPU. Rather, I want to address the problem at hand in order to be able to use the GPU-assisted exported as intended and is optimal.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 16, 2020 0
Adobe Community Professional ,
Aug 16, 2020

Copy link to clipboard

Copied

Do a 2-pass and a 1-pass export. View them in the Transmit Out to see if you see any differences.

 

Also ... put one on V1, the other on V2, set the blending mode on V2 to "difference", and see how many pixels show with anything other than black. Any black areas are identical. Different program material may or may not even benefit from 2-pass, as this is not the same as 1 vs 2 pass from say a decade back. They've so upped the capability of the encoding in both CPUs and software that the differences are a lot less than they were.

 

2-pass encodes are a different beast, I think in many cases (especially with H.264/5) more CPU-centric than 1-pass. For instance, 2-pass encodes cannot be 'hardware accelerated' on any app. It isn't possible.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 16, 2020 0
New Here ,
Aug 17, 2020

Copy link to clipboard

Copied

Thanks for the insight - I did what you said.

 

Overlaying the two versions with difference Blending Mode did indeed show up mostly black pixels (i.e. no difference) - the main difference that was actually visible was around the timecode. Still, it seemed acceptable enough for most of the shots. Good to know!

 

Unfortuantely I ran the 1 Pass with GPU Acceleration enabled (and it was done in 15 minutes), but the same issue as described in the OP cropped up (rogue timecode showing).

 

Is it a bug? Is there a setting im missing during edit that could fix that?

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 0
Adobe Community Professional ,
Aug 17, 2020

Copy link to clipboard

Copied

That "rogue timecode" issue is something that would be maddening ... and I wish I had a better idea what's causing that. Never seen it before though ...

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 0