Type Tool Interferes With Keyboard Shortcuts

Community Beginner ,
May 16, 2018 May 16, 2018

Copy link to clipboard

Copied

So I love the new Type Tool. However, when I click on the Program Monitor and start typing my desired text, I'll end up hitting a key that relates to some keyboard shortcut in my settings. For instance, whenever I hit the letter I or O, it sets my In and Out points on my timeline. Or the spacebar starts playing my video. Obviously I sometimes need to use I, O, or space when creating my title. What am I doing wrong? Is there any way to use the Type Tool without triggering my keyboard shortcuts?

Views

644

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

LEGEND , May 20, 2018 May 20, 2018
Typing text will not trigger shortcuts.  If it is for you, my first guess is operator error.  You're not doing it right.It's impossible to know that without seeing you work, though.

Likes

translate

Translate

Translate
Adobe Community Professional ,
May 16, 2018 May 16, 2018

Copy link to clipboard

Copied

Be sure to click on the Program Monitor after you select the Type Tool.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 20, 2018 May 20, 2018

Copy link to clipboard

Copied

Even when I have the program monitor selected, it still triggers keyboard shortcuts sometimes. 😕

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 20, 2018 May 20, 2018

Copy link to clipboard

Copied

Typing text will not trigger shortcuts.  If it is for you, my first guess is operator error.  You're not doing it right.

It's impossible to know that without seeing you work, though.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 20, 2018 May 20, 2018

Copy link to clipboard

Copied

jjkm102  wrote

Even when I have the program monitor selected, it still triggers keyboard shortcuts sometimes. 😕

You must be purposefully trying to do that. Click somewhere in your actual video picture and enjoy the Type tool. Yes, you can click around the edges of your program monitor and your hot keys still work, but it's pretty clear when you have a text box to type in.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 20, 2018 May 20, 2018

Copy link to clipboard

Copied

I feel like if I was purposely trying to do that, I wouldn't be in a forum trying to fix it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 20, 2018 May 20, 2018

Copy link to clipboard

Copied

I don't believe there is anything to fix here. From the timeline you can select the Text tool with a T, you are not adding text yet. You can select the program monitor and play, set in/out, etc with the (V) Selection tool, Pen tool or even the Text tool, the interface is consistent, but with the Text tool selected, once you click the monitor and have the thin red bounding box, then you are entering text and you are not setting in/out, play etc by the various keys you type.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 07, 2018 Nov 07, 2018

Copy link to clipboard

Copied

How do you still use keyboard shortcuts while using the type tool?  I find it cumbersome to have to switch back to mouse to get out of the type tool and into the V tool for eexample.  Is there a keyboard shortcut for "commit type" or somthing like that?  To get out of the type tool with a keyboard shortcut?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 07, 2018 Nov 07, 2018

Copy link to clipboard

Copied

Is there a keyboard shortcut for "commit type" or somthing like that?

When you are done typing, press the ESC-key on the keyboard.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 25, 2021 Jan 25, 2021

Copy link to clipboard

Copied

Yo I've come back 2 years later to say you were completely unhelpful. Thanks for nothing.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2018 Nov 20, 2018

Copy link to clipboard

Copied

Wow! That was some answers!

I have the same problem. Sometimes while typing normally, the letters I type triggers the shortcuts instead of entering the text in the red bounding box with the red line between characters.

For example, trying to insert a space character plays the timeline, while still editing the text.

And I still don't know what to do to recover the usual behavior. It comes back eventually 😕

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

I have the same problem and it is driving me insane. Every time I'm in the type tool and click the SPACEBAR I don't get a space, the timeline just starts playing. 

 

Can't understand how the only answer here is user error!!!!!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

when someone works extensively in premiere pro and never sees this behavior, it's not inconceivable that they think that it is operator error.    Not saying it is, just saying that it's possible.  And sometimes in the process of trying to solve the problem, after an enormous amount of back and forth, we find that it was something obvious that we should have asked at the beginning. 

It's not always easy to troubleshoot from a distance, but maybe we should start with:

Please tell us your system specs: OS version, Premiere version, amount of RAM, Hardware specs including graphics card

acallens1, you say that everytime you hit the space bar when in the text entry mode, you see this behavior?  Just wondering if there's something wonky in your keyboard.  Can you try use another keyboard?    Do you have any kind of macro program installed on your computer or key remapping utility?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

The "Correct answer" on this post does not answer, or even attempt to answer the issue.

I am experiencing the same issue and it's driving me crazy.

 

Here's the problem: When I select on a pre-existing text clip in my timeline and the playhead is on that clip, then select the text tool, then click on the text in the program monitor, I can put the cursor in the text where I want to edit the text, but then when I hit the spacebar, the program monitor begins to play the video. The reason why this is a glitch is that the program monitor appears to the user as if you're allowed to start typing. You can even move the cursor around to a different spot, and the behavior is the same.

 

Here's the workaround: When I select on the pre-existing text clip in my timeline and the playhead is over that clip, then select the text tool, then select the program monitor tab, then select the text and place the cursor where I want to begin editing, when I hit the spacebar it adds a space to the text. The only difference is the added step of selecting the program monitor tab.

 

If that's user error, tell me what the benefit is to Premiere allowing me to select text in the program monitor, appearing as if I can edit text, and then not doing it? I think this is something Adobe needs to fix.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

Brendan, when you post to a pre-existing thread, you need to give us the information we've asked other people with the same problem.  Please tell us your system specs: OS version, Premiere version, amount of RAM, Hardware specs including graphics card.  Have you tried resetting your preferences?  Changing your keyboard preset?    I am not seeing this behavior on my system.    Do you have "selection follows playhead" turned on in the sequence settings.  shouldn't change this behavior (and it doesn't create this problem on my system), but worth turning it off...  You might also restart premiere, create a new project and then importing the old project rather than opening it...   could be something wonky in your original project.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

This is NOT user error - I had the same issue, and I'm not an idiot, nor is whoever posted this issue I'm sure. For me, it persisted until I bought a new computer, then the type function worked properly. I have a thought though... maybe it has to do with using multiple monitors, with my old system I had the option "Displays have multiple spaces" checked under mission control so that there was a menu bar on all my screens, I've turned that option off since I got the new system - maybe that has something to do with it? Like if you're still active on Monitor #1 but click into the type box on Monitor #2? I dunno, worth a try - good luck, two years later haha sorry

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 30, 2021 Jan 30, 2021

Copy link to clipboard

Copied

This is interesting. I was using dual monitors. I'm not able to replicate the issue in my current project, so it's possible an update fixed it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines