Highlighted

Unbelievably slow audio render times!

Explorer ,
Aug 05, 2013

Copy link to clipboard

Copied

I've been dealing with his for a while now on this documentary I've been working on. When I export my timeline which is right around an hour, it takes around 2 HOURS just to render audio previews before it will export! The bulk of my timeline is a single track with no effects at all. Video renders faster than the audio! The only thing unusual about my project is it is largely composed of longish multi-cam sequences - about 30 sequences ranging from 30 mins to 90 mins. It's appears PP is rendering audio for every bit of my source sequences even though only a few seconds or minutes of each one is actually being used. I don't know what else could be happening.

I was thinking that since some of the audio was recorded at 44.1K maybe that was a problem and some of the sequences had several tracks of audio so to solve this I went through every sequence and rendered out a stereo mix at 48/16 and deleted the old audio. That seemed to help for a while as with CS6 I was getting a very annoying "rendering required audio files" message every time I hit play until I rendered the audio which as I said takes a really long time. Also I can render this but if I close Premiere and re-open I have to render it all over again. It is not keeping the audio render files. Premiere CC is better about playing back without the render message but it still needs to render for export. I have no idea why it would need to render audio from 48/16 source files.

I have reported this to Adobe but just thought I'd put this here to see if anybody else is having issues. If any audio rendering should ever be required in this day and age it should be extremely fast. This problem has really brought exporting to a crawl for this project.

screenshot2013-07-28at12.24.29pm.png

Adobe CC, OSX 10.8.4 on a 12 core Mac Pro with a GTX 570 32GB ram, and BM Studio. My RAID is a 3 disk internal raid with 3 3TB disks in RAID 0. The video renders reload properly. The situation would be better if the audio renders reloaded at least but why it needs to render "audio previews" for such simple audio is beyond me. And as I mentioned I went through quite a bit of trouble to make it as easy on Premiere as possible by replacing all of the 44.1 audio with 48/16 wavs.

Correct answer by Adam_Carrel | Community Beginner

I found this on another forum:

There were MANY other problems that came up on this project and as a result I was put on the pre-release group with Adobe, but the cause for the issue described above was due to the audio bitrate for the project not matching the bit rate of the audio clips. It has a resample them as a result.


This seems to have solved it for me.  I opened my audio files in another program, re-sampled them, and then put them back in to Premiere.


EDIT:  I can confirm that this worked.

Views

40.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unbelievably slow audio render times!

Explorer ,
Aug 05, 2013

Copy link to clipboard

Copied

I've been dealing with his for a while now on this documentary I've been working on. When I export my timeline which is right around an hour, it takes around 2 HOURS just to render audio previews before it will export! The bulk of my timeline is a single track with no effects at all. Video renders faster than the audio! The only thing unusual about my project is it is largely composed of longish multi-cam sequences - about 30 sequences ranging from 30 mins to 90 mins. It's appears PP is rendering audio for every bit of my source sequences even though only a few seconds or minutes of each one is actually being used. I don't know what else could be happening.

I was thinking that since some of the audio was recorded at 44.1K maybe that was a problem and some of the sequences had several tracks of audio so to solve this I went through every sequence and rendered out a stereo mix at 48/16 and deleted the old audio. That seemed to help for a while as with CS6 I was getting a very annoying "rendering required audio files" message every time I hit play until I rendered the audio which as I said takes a really long time. Also I can render this but if I close Premiere and re-open I have to render it all over again. It is not keeping the audio render files. Premiere CC is better about playing back without the render message but it still needs to render for export. I have no idea why it would need to render audio from 48/16 source files.

I have reported this to Adobe but just thought I'd put this here to see if anybody else is having issues. If any audio rendering should ever be required in this day and age it should be extremely fast. This problem has really brought exporting to a crawl for this project.

screenshot2013-07-28at12.24.29pm.png

Adobe CC, OSX 10.8.4 on a 12 core Mac Pro with a GTX 570 32GB ram, and BM Studio. My RAID is a 3 disk internal raid with 3 3TB disks in RAID 0. The video renders reload properly. The situation would be better if the audio renders reloaded at least but why it needs to render "audio previews" for such simple audio is beyond me. And as I mentioned I went through quite a bit of trouble to make it as easy on Premiere as possible by replacing all of the 44.1 audio with 48/16 wavs.

Correct answer by Adam_Carrel | Community Beginner

I found this on another forum:

There were MANY other problems that came up on this project and as a result I was put on the pre-release group with Adobe, but the cause for the issue described above was due to the audio bitrate for the project not matching the bit rate of the audio clips. It has a resample them as a result.


This seems to have solved it for me.  I opened my audio files in another program, re-sampled them, and then put them back in to Premiere.


EDIT:  I can confirm that this worked.

Views

40.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 05, 2013 0
LEGEND ,
Aug 05, 2013

Copy link to clipboard

Copied

How do you know that it is rendering audio files as opposed to video files?

Try a test and turn of all audio tracks (test export or render of a section (shortWork area bar).

Try a test an Delete Render Files. (ie start a fresh render)

Try exporting Audio Track only and re laying that into the Sequence.

Exports do nor rely on Render filesu nless you want them to. (ie a fresh render occurs when exporting)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 05, 2013 0
Explorer ,
Aug 06, 2013

Copy link to clipboard

Copied

Well if you took a look at the little screen grab I sent you would see it says rendering audio previews. If I delete the audio from the timeline I don't get the rendering audio previews message and it goes straight to exporting my video. I have tested this a bit and it's definitely the audio that is the bottleneck.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2013 0
LEGEND ,
Aug 06, 2013

Copy link to clipboard

Copied

I have never seen a separate Audio Render Window (and progress bar).

Its also interesting that you are saying Export ..yet I am seeing the Timeline (Seq) in your sreen grab.  Not sure what to make of that because I would expect to see AME???

Any how...there is a Preference Setting that says something like "Render Audio with Preview".

Try it OFF or vice versa

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2013 0
Explorer ,
Aug 06, 2013

Copy link to clipboard

Copied

It's all the same. I can render audio from the render sequence drop down and I get this window, or if I export I will get this render window before before actual exporting begins. And as I mentioned if I close the project it has to do it all over again, it will keep the renders as long as the project stays open. I'm having no issues with video renders not coming back. All render folders set to same as project which is on my RAID. IMO PPro is being asked to do WAY more than it actually needs to in regards to audio. Why in the world would it need to render audio previews from uncompressed files? It should just transfer what is needed from point A to point B. It should be way faster than real-time but is in fact slower than rendering 1080 video.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2013 0
Contributor ,
Aug 06, 2013

Copy link to clipboard

Copied

I have a similar workstation. My sequence is a little more complex, no multicam, but its says it will take 6 hours to render my 27 minute film. No effects are applied as I've not yet mixed. Rendering audio for export should not take this long.

Plus it fails when it reaches 99.6%. Infuriating.

Edit:

Let me elaborate.

MacPro 5,1

10.8.4

CC (fully updated)

Nvidia k5000

Mercury wGPU Active

Timeline: 1920 x 1080 x 23.976

Master Track: Mutlichannel (2 ch)

No Submixes (yet)

(60) Standard Tracks containing Mono and Stereo

(3) 5.1 tracks of Surround FX

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2013 0
Contributor ,
Aug 07, 2013

Copy link to clipboard

Copied

My Solution:

Removed all 5.1 tracks. Audio render for my 27 minute film now takes just a few minutes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2013 0
Explorer ,
Aug 07, 2013

Copy link to clipboard

Copied

Well that's a clue. I don't have any 5.1 in my piece. In any case that still doesn't make any sense. Does Adobe monitor these threads?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2013 0
Contributor ,
Aug 07, 2013

Copy link to clipboard

Copied

Yes. I know they do. I get responses from "staff" people sometimes.

Okay, so removing 5.1 worked for a couple hours, now it's back to its same old tricks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2013 0
Explorer ,
Aug 09, 2013

Copy link to clipboard

Copied

I've been getting crashes too while rendering. It finishes the audio but crashes halfway through the video. If I restart the mac it's fine but I'm having to restart a lot! I'm thinking it's something to do with the NVidia drivers because I start to get little drawing errors on the screen. All drivers and Cuda is current.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2013 0
Adobe Employee ,
Aug 09, 2013

Copy link to clipboard

Copied

NickelplateSpiro wrote:

Yes. I know they do. I get responses from "staff" people sometimes.

Hi NickelplateSpiro,

Right, we have Adobe staff that do monitor the forums, myself included. However, it is a user-to-user forum primarily. Thanks for providing feedback to our staff, we like to interact with our users to improve Premiere Pro as much as possible.

Thanks,

Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2013 0
Contributor ,
Aug 09, 2013

Copy link to clipboard

Copied

I do occasionally see noisy GPU screen printing for a split second when scrubbing non rendered portions of the timeline while waiting for the drive to respond to file reads. But they are very fleeting. Not a concern for me. I would describe them as flashes of digital "snow" in my viewer during scrub, never during playback or in rendered content.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2013 0
LEGEND ,
Aug 06, 2013

Copy link to clipboard

Copied

Just an observation. The 44.1KHz Audio should not be an issue, since PrPro Conforms that to 48KHz 32-bit floating point in the CFA files, upon Import. I think that you can rule the 44.1KHz material as the cause of the bottleneck.

However, I do not have any thoughts on what the issue could be, unfortunately.

Good luck,

Hunt

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2013 0
Adobe Employee ,
Aug 09, 2013

Copy link to clipboard

Copied

Hi robmbrown,

Sorry about your experience. Have you tried to flatten your multicamera sequence before rendering and exporting?

Thanks,

Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2013 0
Explorer ,
Aug 09, 2013

Copy link to clipboard

Copied

Would flattening affect audio?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2013 0
Explorer ,
Sep 10, 2013

Copy link to clipboard

Copied

That did the trick! And make sure you do the same for all multi-cam clips - not just the ones in the work area.  It tries to render audio from the entire sequence.  Weird bug.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2013 0
New Here ,
Sep 10, 2013

Copy link to clipboard

Copied

What did the trick?  This thread is long, can you be more specific please? was it flattening the layers?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2013 0
Explorer ,
Sep 10, 2013

Copy link to clipboard

Copied

Yeah what did the trick?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2013 0
Explorer ,
Sep 10, 2013

Copy link to clipboard

Copied

What did the trick? I'm having the same issues.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2013 0
New Here ,
Sep 11, 2013

Copy link to clipboard

Copied

I believe it was the post by Kevin Monahan regarding "Have you tried to flatten your multicamera sequence before rendering and exporting?"  I haven't tried this yet and feel like this is a work around when the problem never manifested itself with CS6...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2013 0
Explorer ,
Sep 11, 2013

Copy link to clipboard

Copied

Thanks jt20194. I tried that, and although it reduced the full number of audio clips that needed to be referenced (not sure why that makes a difference), it was still over 100 audio clips that "needed" to be rendered. I had chosen a 10 second clip with In and Out points, and the MAXIMUM possible audio clips that are in any way connected to the video clip is 4.

It's a bug, or a bad design choice. Either way, it needs to be changed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2013 0
Explorer ,
Sep 11, 2013

Copy link to clipboard

Copied

Just submitted a bug report. If anyone finds any real solution to this, please let us all know.

Thanks all!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2013 0
New Here ,
Jan 08, 2014

Copy link to clipboard

Copied

Any headway in this problem? I'm just running into it now, rendering out 10 second .wav audio files takes 20 mins the first time, only a second the 2nd or third time though. What gives?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2014 0
New Here ,
Apr 09, 2020

Copy link to clipboard

Copied

Listen there is something wrong with your Premiere software. I have been using these tools for years and exporting audio from a video track has always taken seconds even for video clips that are 60 min long. So it's nothing else but a flaw in the way that the developers changed the way the audio is processed. It's not a setting on the user end this is obvious. I just imported a video clip that was rendered as video so it is so basic now no cuts or anything just a video track and an audio track on the timeline. Clip is only 36 minutes long. Changed export setting to audio only mp3 output and it takes a long time about real time 36 minutes same thing with older versions would do the task in seconds. I tell you if I win the lottery I'm going to hire a bunch of software engineers and put your company out of business. Adobe started out making some great products but now its stuck in making a bunch of new products that basically do the same thing. Don't make new software just to make it look like your innovative make your products better. Sometimes that means consolidating your products into more useful products. Combine Illustrator and photoshop into one app, Combine Premeir and Aftter effects into one app etc. Trim the fat and make it more useful for the professionals that use your products all the time. Make the software work faster not slower. You idiots should of never released this software with slower render times are you stupid or what?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 09, 2020 0
New Here ,
Aug 15, 2013

Copy link to clipboard

Copied

I am having the same problem with a fairly high end rig...  i7-3930K, 32Gb RAM, GTX 780 with MFE on, OCZ Revo system drive, SSD scratch drive, 3 7200RPM project disk and 1 7200 disk where I write my rendered files to.  With my old projects and multiple videos and separate audio recorded at 96K never have a problem after importing from CS6 to CC.  With a new project that had 3 video sources and one audio source I used PluralEyes 3 to sync the files. Worked great, but when I went to render the final video which is 47 minutes long, the video took maybe 10 minutes and the audio and hour…  

Help!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2013 0
New Here ,
Sep 01, 2013

Copy link to clipboard

Copied

I have had this problem too ever since upgrading to CC from CS6.  I always use nested sequences for syncing up my system sound, so I have not tested if this bug or 'feature' is premiere feeling the need to make audio previews for nested sequences vs other ways of syncing sound with video clips.  I did an experiment. One sequence had 192 sequences, but only 33 within the work area for rendering.  When I went to render, premiere wanted to render 192 audio previews.  When I copied just the work area to its own new sequence, premiere wanted to render 33 audio previews. So annoying that it wants to render a 'preview' for every sequence on the timeline, not just only what is in the work area. Why is that, Adobe?! Do you understand how much editing time this wastes when I can't be using my machine?  I think from now on, I will be sure to keep a fresh sequence only for rendering out from. 

And I too can confirm CC renders audio slower than video.  Just got my new core i7. The video encodes soo much faster than my old rig, but the audio seems to be stuck in molasses.  Would really love to hear an answer from the high software paid engineers at Adobe who get health insurance why they have taken audio rendering back 20 years.  What do we have to do to not get this annoying glitch?  Not use nested sequences? That makes keeping sync soo much harder if that's the case.  

Message was edited by: Kevin Monahan

Abusive language. Please do not use profanity.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2013 0
Community Beginner ,
Jan 28, 2014

Copy link to clipboard

Copied

For me, when I use Sequence->Render Audio in Premiere Pro CC, there is a huge difference in rendering time depending on whether the audio tracks are locked or not.  This is obviously a bug, because clicking the lock icon on/off shouldn't affect anything about the audio itself.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 28, 2014 0
Contributor ,
Jan 28, 2014

Copy link to clipboard

Copied

Which is it? Do you get faster renders with locks activated or locks deactivated?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 28, 2014 0
Community Beginner ,
Jan 29, 2014

Copy link to clipboard

Copied

Just to give a few more details, the project is 100 minute film with 22 audio tracks, and stereo master output.  The audio is fairly complex, but no nesting.  With all tracks unlocked it takes less than 5 minutes.   With all the tracks locked it went for almost 2 hours before I cancelled it; I've never had the patience to see it all the way through. 

After rendering all audio with the tracks unlocked, if I then switch even one track to locked, it will re-render, even if that newly locked track has no audio on it.  Again, no sound is being moved or modified in anything I am doing. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2014 0