Unsupported video driver issue

New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

I currently have an Intel(R) HD Graphics 520 and whenever I try to launch Premiere Pro, I always get this error report. I looked around and this might be tied to a program monitor issue I am having in which it does not display my video after a certain period of time in any of my projects (here is the link: https://community.adobe.com/t5/premiere-pro/program-monitor-stuck-on-one-frame/td-p/12065885). I also have an Acer Spin 3 laptop and it has an Intel(R) Core(TM) i3-6100U CPU @ 2.30GHz 2.30 GHz with 6.00 GB of RAM and is operated by Windows 10. I also tried using the export report issue and followed the steps on the website but it did not work. Please help!

TOPICS
Error or problem, Hardware or GPU, Performance, User interface or workspaces

Views

149

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Your system is way underpowered for PrPro to run proper despite the error message.

 

Adobe Premiere Pro CC System Requirements

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

LATEST

So the only thing I can do at this point is to manually install a new processor?

 

Also, would you happen to know how to fix the program monitor issue?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines