Upgraded to Premiere 2020 - Now Playback is Abysmal

Community Beginner ,
Nov 30, 2020

Copy link to clipboard

Copied

Looking for some kind of starting point to troubleshoot as a I am insanely frustrated with Premiere.

 

Recently upgraded to Premiere 2020 as we decided it was 'time'.  I was running 2018 previously. Pretty vanilla PC setup, a i9-9900X and a 2080 GPU. Ran Premiere 2018 blazing fast.

 

Once I upgraded to 2020 and all my projects will play a few frames every second, stuttering all over the place. Audio still plays.  I am doing super basic stuff - importing rendered .jpg sequences from after effects and adding a text disclaimer, and exporting out of Premiere. One video track (plus the text layer), one audio track.

 

Created a new project, imported an image sequence and can't play that smoothly either. Actually get marginally better performance WITHOUT using CUDA acceleration. Nothing makes sense. Tried resetting prefs, re-installing latest nVidia driver, updating windows.

 

Ready to pull my hair out, anyone have any advice? I can't downgrade because the rest of the studio upgraded as well, they are on 5 year old macs with no issues. I can't believe my new PC is the one having the problems.

TOPICS
Error or problem, Performance

Views

79

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 30, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Nov 30, 2020

Copy link to clipboard

Copied

Is this a bot response? I posted in above that I already cleared my prefs.

 

Also did the cache empty before. I've been working with Adobe products for 10+ years, that's usually the first set of steps before seeking support.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Nov 30, 2020

Copy link to clipboard

Copied

Did some more playing around with Premiere - I can play video files smoothly no issues

 

So narrowed it down to image sequences not playing nice with whatever changed in Premiere. Import the same image sequence in CC2018 (which I left installed) and it plays realtime with no issues. Create a new project in 2020, import image sequence and it can't play more than 1 frame every 2-3 seconds.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Nov 30, 2020

Copy link to clipboard

Copied

aye for me it was something to do with my graphics card so id give them a call and let them walk you through the steps on downloading that software

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 01, 2020

Copy link to clipboard

Copied

What GPU do you have?

 

I am using a GTX2070, shouldn't be an issue. Could you tell me what they had you download? I am running the latest nvidia drivers and just did a clean install after running into this issue

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 01, 2020

Copy link to clipboard

Copied

I should add, i tried both the game-ready and studio-ready versions of the Nvidia drivers.

4K footage plays flawlessly. JPG sequences can't play at all.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
joeym4130 AUTHOR LATEST
Community Beginner ,
Dec 01, 2020

Copy link to clipboard

Copied

Continuing to experiment

I can play back .TIFF & .EXR(with alpha) sequences in realtime without any problem. PNG or JPG sequences are making Premiere sht the bed. Something fishy going on here with some software bug.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more