Upscaling 720p Video Game Footage to 4k Issues

New Here ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

Hello,

 

I'm new to premiere pro and I've been running into issues upscaling my 1280x720p (29.97fps) video game footage to 3840x2160p using the adobe after effects detail-preserve upscaling.

 

I've followed several different tutorials via youtube but as soon as I apply the detail-preserve upscaling and scale it up to 300% and save it, not only is it incredibly laggy//choppy to play in adobe after effects but returning back to premiere pro it is also very laggy//choppy when trying to sample play it from the sequence timeline. However, I've tried another method whereby I adjust sequence settings to 3840x2160p then select Set to Frame Size and the video plays seamlessly but not quite as crisp quality.

 

List of my Steps:

  • Open Premiere Pro, Import Media to start (Vide game footage)

  • Drag media into Timeline

  • Adjust sequence settings to Custom 3840x2160p

  • Right-click Timeline video and select Replace with After Effects Composition

  • Adobe after effects opens

  • locate detail-preserving upscaling and set scale to 300% (save)

  • Return to Premiere Pro with laggy video playback

 

All the tutorial videos I've seen on youtube use camera footage so I'm wondering if detail-preserve upscaling only works for that type of recorded video, or if it's even compatible//possible with video game recorded content in the first place.

 

Thanks for the help, I'll be ready to respond as best I can for any further details.

 

TOPICS
Editing, Effects and Titles, Error or problem, Performance

Views

550

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

The footage doesn't matter.  You need to either pre-render the footage, or let it render a preview file.  the process of upscale at 300% using preserve details has lots of CPU time, it cannot play back real time.  you must pre-render or render previews first, then it will play back smooth.

 

This video goes through the process you described, and he talks about the impacts to performance.

How to Upscale Video (with the best results) in After Effects - YouTube

 

The real time playback when you set-to-frame-size is very easy math to scale it up for the CPU, so it plays back fine.  Preserve Details is much better looking when done, but the cost is time and thus you loose real time until pre-rendered.  If you pre-render it, you only have to do it once, and then place it on the time line over the aftereffects section that needs rendering and it will not need to render again to playback smooth.

 

Also,  if you have a few bucks to put towards a bit of software, try Topaz Video Enhance AI - it works miracles with upscale.  I hope Adobe builds something like it into premiere in the future.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Ah, Thank you! It totally was the rendering that was bogging it down, after a couple of tests of pre-rendering it was a vast improvement with only a slight bit of chop, once I exported it out and played it on its own it ran super smooth. 

 

Thanks for the tutorial video and feedback, If I do more editing in the future I think I'll definitely opt out and go for the Topaz AI lol.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

LATEST

You're welcome!

Glad to get you back on track and doing the creative part and getting frustrated waiting for things to finish.

If you're still seeing some choppy playback when you render the timeline, you might need to tweak the seq settings, so it used a better codec for your machine.

 

Most of the time the ones that start with "DN" on the list below work well, try changing the setting, it should help.  BUT do not use the one with 1080i (interlaced) there is no reason to use interlaced - you will know if you need it, don't use it otherwise.

 

FlyingFourFun_0-1620787758067.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines